How could one add one or more keywords to all or some of the folders / documents in a search result?

Bi
Biff
Posts: 365
Joined: Mon Jan 16, 2017 7:59 am
Platform: Windows

Mon Sep 21, 2020 9:33 am Post

How could one add one or more keywords to all or some of the folders / documents in a search result?
Windows 10, 64bit

User avatar
rdale
Posts: 2070
Joined: Tue Jul 14, 2015 1:07 pm
Platform: Mac, Win + iOS
Location: St. Louis, MO
Contact:

Mon Sep 21, 2020 1:11 pm Post

Simply select all of the documents (CTRL-clicking on each one, or click the first, and then SHIFT-click the last), and then open the keywords window and drag keywords onto the selection.
FKA: robertdguthrie
AKA: R Dale Guthrie, Robert, Mr. Obscure, and "Oh, it's you again".

Bi
Biff
Posts: 365
Joined: Mon Jan 16, 2017 7:59 am
Platform: Windows

Mon Sep 21, 2020 1:38 pm Post

Yes, the same method like in the normal view, but it does not work with the search results here.
Windows 10, 64bit

JJ
JJSlote
Posts: 646
Joined: Tue Oct 26, 2010 5:44 pm
Platform: Windows
Location: Unlogged bugs thru RC11:  t=61527 HTML clpbrd, 63330 kwd drag.

Mon Sep 21, 2020 2:33 pm Post

Biff wrote:Yes, the same method like in the normal view, but it does not work with the search results here.

Not sure which Scriv version you're working with, but for beta RC 10 it looks like you're absolutely right. If we multiselect within Search Results or any Collection, then drag a keyword onto the selection from the Project Keywords control, the keyword will *not* be assigned. Same if we select all in the Multiple Selection outliner pane shown when multiselecting in the Search Results or Collection.

If we multiselect in the Binder, dragging a keyword works properly.
If we multiselect within search results or a Collection, we can right click on the desired keyword and select Apply Keywords to Selected Documents. That works properly.
But if we multiselect within search results or a Collection, dragging the keyword silently fails.

This does appear to be an RC10 bug.

Rgds - Jerome

Bi
Biff
Posts: 365
Joined: Mon Jan 16, 2017 7:59 am
Platform: Windows

Mon Sep 21, 2020 4:46 pm Post

Image

So it simply does not work at all in the search results.

OK, many thanks for trying, Jerome.
Windows 10, 64bit