Setting the margins in the editor - having issues

wj
wjtucker
Posts: 1
Joined: Sat Apr 11, 2020 3:33 am
Platform: Windows

Sat Apr 11, 2020 3:36 am Post

In the editor window (tools>options>editor), I am trying to set the right margin to 10". However, you can't slide it past 6". Since page view isn't a thing, apparently, I need to know how to fix their terrible default margins. Is there a way around this?

br
brntoki
Posts: 9
Joined: Wed Apr 22, 2020 11:52 pm
Platform: Mac

Thu Apr 23, 2020 12:23 am Post

I'm completely with you. Setting margins is a total nightmare and I can find 3 or 4 supposed ways to fix the issue, none of which work. Frustrating is an understatement.
I'm on a Mac and want to have .5" margin left, and .45" margin right. But it is impossible to get any margin to be less than one inch, even though I've set new documents to open that way (they don't), and converted document to adopt my settings (they won't), have set the margins in the global preferences, turned off "use fixed width editor" (theoretically unnecessary, but when desperate . . .) and set editor margins to 0, attempted to set margins on the page view using ruler (unable to go less than an inch, while I can go greater), . . .

As I typed this I tried yet again. This is the most absolutely frustrating crap ever.

EDIT: And yes, I've also used the "Page Settings" (custom paper size), attempting both margin zero and setting desired margins there, but . . . here I am, still.

br
brntoki
Posts: 9
Joined: Wed Apr 22, 2020 11:52 pm
Platform: Mac

Thu Apr 23, 2020 5:04 am Post

wjtucker wrote:In the editor window (tools>options>editor), I am trying to set the right margin to 10". However, you can't slide it past 6". Since page view isn't a thing, apparently, I need to know how to fix their terrible default margins. Is there a way around this?


In case you didn't notice, I'm on Mac. I did finally find the solution to my margin issue, but don't know if it will apply to you on Windows. Perhaps it will be a hint in the right direction though.

Apparently, Scrivener defaults to 1 inch margins when in page view mode. I could not get the margin to less than 1 inch for the longest time, but found that going into my (again, Mac lingo here . . .) File>Page Setup>Page Attributes>Scrivener 3, I was able to adjust the margins to my preference there. I like to view my page view as a 2 page spread, and the margins cannot be set for "inside/outside" so it isn't perfect, but gives me a much nicer preview than I could hope to have with forced 1 inch margins.

I've been out of the Windows system for a while and don't recall exactly, but I'm somewhat doubting that changing the default margins is too similar to the Mac way. Sorry if this doesn't help you. Good luck though.

User avatar
lunk
Posts: 4082
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Thu Apr 23, 2020 6:36 am Post

wjtucker wrote:In the editor window (tools>options>editor), I am trying to set the right margin to 10".

Why? What is it you ate trying to accomplish? If you describe the problem there might be another solution.
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, all running Mojave.
* iOS Scrivener 1 on an iPhone 11 Pro, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS

User avatar
tarzanofmars
Posts: 41
Joined: Wed Dec 20, 2017 11:49 pm
Platform: Mac + Windows

Sun May 17, 2020 12:21 am Post

Same problem. I just now downloaded the latest version out of curiosity and within 30 seconds I'm reminded why I don't even need to bother.

On Mac you go to preferences>appearance>composition mode>options and you can set scroller type and importantly 'editor margins', and you can set it to use current composition setting for new projects

I can find nowhere on PC Scrivener to adjust margins so that it reflects in composition mode. The word 'margin' doesn't even appear in the help search function.

The only option in options (f12)>appearance>composition mode>options is 'highlight current line'.

User avatar
tarzanofmars
Posts: 41
Joined: Wed Dec 20, 2017 11:49 pm
Platform: Mac + Windows

Sun May 17, 2020 6:25 pm Post

So I discovered how to adjust margins, but despite that the bizarre stretched out composition mode is not for me. Even more thankful now for the mac version. Uninstalled.

My only reason for trying this out is that sometimes I want to work on a bigger screen than my macbook and I have a large PC monitor, but I think my personal solution is going to be an adapter to HDMI.

Fix the composition mode to mirror the mac version and I may give it another try after release.

Ji
JimRac
Posts: 1664
Joined: Wed Aug 27, 2014 2:06 pm
Platform: Win + iOS

Sun May 17, 2020 6:42 pm Post

tarzanofmars wrote:..but despite that the bizarre stretched out composition mode is not for me.
tarzan,

In Windows Scriv (1.9 and beta) composition mode width & height are adjustable via the control strip that pops up at the bottom of the screen, along with Text Scale. So it doesn't have to be stretched out, if that's not what you want.

You probably already know that, but mentioning just in case it works differently on Mac.

Best,
Jim
I’m just a customer.

Tr
Trapp
Posts: 1
Joined: Sun May 24, 2020 2:29 am
Platform: Windows

Sun May 24, 2020 2:42 am Post

In Windows Scriv (1.9 and beta) composition mode width & height are adjustable via the control strip that pops up at the bottom of the screen, along with Text Scale. So it doesn't have to be stretched out, if that's not what you want.

You probably already know that, but mentioning just in case it works differently on Mac.

Best,
Jim[/quote]

The control strip you mention.....sounds great but I just purchased Windows Scriv 1 and I can't find that control strip. As mentioned by others, I don't like the stretched out way my Word doc appears in editor once imported.

Ji
JimRac
Posts: 1664
Joined: Wed Aug 27, 2014 2:06 pm
Platform: Win + iOS

Sun May 24, 2020 5:45 pm Post

Trapp wrote:The control strip you mention.....sounds great but I just purchased Windows Scriv 1 and I can't find that control strip.
Maybe this is version terminology confusion. In Windows Scrivener v1, 'Composition Mode' is called 'Full Screen', and the 'Control Strip' is sometimes referred to as the 'Control Panel'. :( To get the v1 Control Panel, enter Full Screen mode and move your mouse to the bottom of the screen.

See the Scrivener Interactive Tutorial for details. (Full Screen info is under Draft > Part 1: Basics > Step 4: Full Screen.)

Or for even more details, see the Scriv manual, Chapter 16 Full Screen.

If that doesn't get you what you want, post a screen shot so we can see what you're seeing.

Best,
Jim
I’m just a customer.