Can I turn off autocorrect just for proper nouns?

gr
greendragon9
Posts: 2
Joined: Thu Jan 23, 2020 7:55 pm
Platform: Windows

Thu Jan 23, 2020 8:04 pm Post

This is my first time using Scrivener. I'm already a bit frustrated with the over-aggressive autocorrect (why is 'adn' assumed to be 'Adam' rather than 'and'?) but now I'm writing a novel with six protagonists and a variety of places.

Every time I type a new one in (Wexford, Benjamin. Emain Macha. Galway) it autocorrects to something strange.

Word has the option of turning off autocorrect for capitalized words, i.e., proper nouns. Does Scrivener? Or do I have to stop and add each and every one to the library? It halts my flow and makes things much more difficult. Also, in Word, if I go back and correct the autocorrect, it leaves well enough alone, but Scrivener INSISTS that my correction is incorrect and re-autocorrects it. Very frustrating.

User avatar
DavidR
Posts: 878
Joined: Fri Mar 08, 2013 12:21 am
Platform: Windows

Thu Jan 23, 2020 10:00 pm Post

I don't believe there's an option to turn off autocorrect for proper nouns. If it were me, I'd just turn it off altogether, then go through and do a spell check afterward. Or make a list of names to be added before opening Scrivener and add them to the end of C:\Users\{your username}\AppData\Local\Scrivener\Scrivener\wordlists.ini, which is a plain-text file. Scrivener will take care of alphabetizing them when you look at them within the program.
David
Scrivener for Windows Version 1.9.9
Windows 7 Pro 64-bit

What's the difference between a free lance and a loose cannon?

gr
greendragon9
Posts: 2
Joined: Thu Jan 23, 2020 7:55 pm
Platform: Windows

Fri Jan 24, 2020 5:54 pm Post

I'll have to just disable it completely, then. I add names and places while I'm creating. There is no way I would know which ones I'll need ahead of time. And with the amount of Irish words I'll be using in this, it will be distracting. I type about 70 wpm and that will seriously slow me down. Thanks.

User avatar
DavidR
Posts: 878
Joined: Fri Mar 08, 2013 12:21 am
Platform: Windows

Fri Jan 24, 2020 11:42 pm Post

Considering who uses Scrivener, I'm a little surprised that this doesn't come up more often. Maybe it does, and (since I don't write fiction) I just haven't noticed. OTOH, I write a lot of stuff with foreign names in it. I keep autocorrect turned off for just the reasons you indicated in you OP. Since I use Scrivener as an organizing tool for the most part, and do the final writing in a word processor, I tend to mainly catch spelling issues there. Horses for courses, as they say somewhere. I wonder if your already fast typing speed might actually increase, liberated from the concern over getting typos fixed automatically, even though your post-processing time will get more burdened.
David
Scrivener for Windows Version 1.9.9
Windows 7 Pro 64-bit

What's the difference between a free lance and a loose cannon?

User avatar
magnoliasouth
Posts: 30
Joined: Sat Feb 27, 2016 10:16 pm
Platform: Windows

Fri Feb 07, 2020 6:28 pm Post

greendragon9 wrote:(why is 'adn' assumed to be 'Adam' rather than 'and'?)
One of the first things I did was make my own customized Substitution list. You can add "adn -> and" in the Substitutions. One of my frequent typos is "it;s" rather than "it's". UGH. I added that and no more. Ever. Again.
greendragon9 wrote:Every time I type a new one in (Wexford, Benjamin. Emain Macha. Galway) it autocorrects to something strange.
Ctrl+z works wonders on things like that but you will be doing it a lot. Still, I recommend adding them to your speller anyway. There are two benefits. 1. It'll stop correcting but more importantly is 2. It will guarantee that you won't misspell "Emain" to something like "Eman" during your writing. It's actually simple to right click > Learn Spelling > DONE! You will never see it again, unless you misspell it.