Error: A connection to the licensing server could not be established

Ma
Max Gardin
Posts: 9
Joined: Thu Jun 27, 2019 3:58 pm
Platform: Windows

Mon Sep 02, 2019 5:38 pm Post

I didn't get again the License Engine broken connection error after I run Scrivener as administrator, but I got again, today, more times, the freeze on start up when I not run the program as administrator and I suspect this freeze (not happening all times) was a license provider related issue too.
So maybe running the program as administrator could be a workaround (at least for me it seems one).

What worring me, anyway, is something going wrong with my project (even if I use Always the backup feature) when I force the program shutdown and, in general, a progressive feeling of poor reliability of the stable release after the last updates (the version 1.9.0.9, before the license provider change, seemed quite solid to me).
I really hope you will fix this issue soon because I like very much Scrivener and I'm using it for work.

ts
tswalker
Posts: 27
Joined: Sun Nov 26, 2017 9:06 pm
Platform: Linux

Mon Sep 02, 2019 7:51 pm Post

@ Cranky

After looking at some of the other posts in this thread, I need to change some things from my previous posts.

After the new install of Scrivener and manually starting Paddle.exe, I was able to activate the program. I still get the error message about not being able to connect to the server. I don't know why it could connect to activate but not after that. Starting Paddle.exe manually may have had nothing to do with it.

I was thinkng of trying to use mono instead of .Net but that will have to wait until Paddle fixes their end of things. As of yesterday, I now have the same problem on my desktop box. Apparently this doesn't effect Apple?

It's a pain, but at least we have functioning installs.
TSWalker

sg
sgerdom
Posts: 9
Joined: Tue Dec 06, 2011 6:02 pm
Platform: Windows

Tue Sep 03, 2019 10:11 am Post

ECJ wrote:Sorry for any inconvenience!! We hope to get it fixed soon!


I know you will. :D

I'm working all my stuff (not only my novels) with Scrivener for years now and I love and recommend your program ever since.

You are doing a fine job. I know you will fix it!

User avatar
AmberV
Posts: 24402
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Tue Sep 03, 2019 11:27 am Post

Just to update, it looks like they've found the source of the problem, as a crash in a piece that tries to activate. Since it is separate from the main program it isn't the kind of crash that halts the software itself. It looks like they've got that fixed, and should have a build out soon.

Meanwhile, just to reassure everyone: you're in no immediate risk of losing access to anything! It'll just be a "nag screen" you have to put up with until it is fixed. It's annoying, but just click though it!
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

sg
sgerdom
Posts: 9
Joined: Tue Dec 06, 2011 6:02 pm
Platform: Windows

Tue Sep 03, 2019 5:59 pm Post

Thank you - that is good news! :D

ce
ceetee
Posts: 5
Joined: Sat Aug 31, 2019 4:33 pm
Platform: Windows

Tue Sep 03, 2019 7:49 pm Post

Whew, that is good news! Thanks for keeping us updated!

Ma
Mark Penny
Posts: 1
Joined: Sat Sep 07, 2019 5:28 am
Platform: Windows

Sat Sep 07, 2019 5:32 am Post

Glad it's being worked on. I get this message every time I open a project. Good luck!

User avatar
tiho_d
Posts: 1299
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Sat Sep 07, 2019 1:35 pm Post

Hi All,

We managed to pinpoint the problem. Before releasing it to public, I would like to ask you to test it first and report your results.

This is a Dropbox link to a Scrivener.zip archive file with the Scrivener.exe inside:
https://www.dropbox.com/s/v6orz5b8aq4mt ... r.zip?dl=0

Please, close Scrivener, extract the archive contents and replace the Scrivener.exe file within your Scrivener installation folder with the file extracted from the archive.

Start Scrivener as usual. You should no longer receive the nag messages. We tested it internally and it worked, but would be thankful to verify it with a small group of users before we publish the official release to a wider audience. Looking forward for the results of your tests.

Thank You in advance!
Tiho

sg
sgerdom
Posts: 9
Joined: Tue Dec 06, 2011 6:02 pm
Platform: Windows

Mon Sep 09, 2019 8:00 pm Post

tiho_d wrote:We managed to pinpoint the problem. Before releasing it to public, I would like to ask you to test it first and report your results.


Hi Tiho: It seems to work on first sight. But the nag message/s don't pop up every single time I open Scrivener, so I will test it a few days and come back to report.
Thank you!
Susanne

kb
kbell1111
Posts: 5
Joined: Sat Sep 14, 2019 7:21 pm
Platform: Windows

Sat Sep 14, 2019 7:26 pm Post

Hi,

I am getting this error as well and have been for weeks. I contacted your support weeks ago, and no one ever responded. I just get automated emails saying to "expect delays", and then literally nothing else EVER.

I have written an entire book in your program, which I PAID FOR, and now every time I open it I get an error threat telling me the program is going to be taken from me.

If I lose this entire book I will of course be furious, and the fact that your support does not respond at all is really frustrating.

Reading this thread says we will not lose anything - can someone please confirm this is correct???

Honestly answering your support emails would be really helpful during an issue like this :\.

Ma
Major Major
Posts: 238
Joined: Tue Apr 30, 2013 7:52 pm
Platform: Windows
Location: Oakville, ON Canada

Sat Sep 14, 2019 9:14 pm Post

Kbell -

Did you even read Tiho's message a few above yours?

Br
BratFace
Posts: 5
Joined: Fri Oct 24, 2014 6:00 pm
Platform: Windows

Sat Sep 14, 2019 9:24 pm Post

sgerdom wrote:
tiho_d wrote:We managed to pinpoint the problem. Before releasing it to public, I would like to ask you to test it first and report your results.


That worked for me!

kb
kbell1111
Posts: 5
Joined: Sat Sep 14, 2019 7:21 pm
Platform: Windows

Sat Sep 14, 2019 9:29 pm Post

Major Major wrote:Kbell -

Did you even read Tiho's message a few above yours?


Yes, I thought that was a specific message to the person they were addressing? It says "Before we release to the public". I took that as needing to wait for something to be released to us?

Tried downloading the link at dropbox and installing - it has an error. No sure what it means to "Extract the archive".

I'm not technical person- just trying to get my product I paid for to work. Would appreciate the product to respond to support inquiries.

Br
BratFace
Posts: 5
Joined: Fri Oct 24, 2014 6:00 pm
Platform: Windows

Tue Sep 17, 2019 9:11 pm Post

BratFace wrote:
sgerdom wrote:
tiho_d wrote:We managed to pinpoint the problem. Before releasing it to public, I would like to ask you to test it first and report your results.


That worked for me!


Apparently it's broken again. Now the program won't launch at all.

User avatar
AmberV
Posts: 24402
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Tue Sep 17, 2019 10:02 pm Post

Did you reboot after upgrading? I've seen a few cases where that is necessary.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles