License manager ended unexpectedly

Pa
Pagecrawler
Posts: 6
Joined: Sat Feb 14, 2015 4:55 pm
Platform: Windows

Sun Sep 08, 2019 3:33 pm Post

I'm afraid I don't really understand any of the technical stuff mentioned here as a solution so I really hope the upcoming update works as my Scrivener is now telling me my trial period has come to an end and I need to enter my licence number I've entered my licence number which I purchased in 2015 but it wouldn't accept it Desperately crossing fingers here

HG
HGT
Posts: 4
Joined: Sun Sep 08, 2019 9:09 am
Platform: Windows

Sun Sep 08, 2019 4:11 pm Post

In my case the program needs several starts and hangs at best several minutes before giving me control. And the new vrsion is even worse, I do not get control at all.. I would appreciate it very much, if somebody from the technical staff would look into this problem, as I have to do an urgent final revision of my work of three years.

Tw
Twolane
Posts: 144
Joined: Sat May 12, 2012 7:39 pm
Platform: Windows

Sun Sep 08, 2019 5:38 pm Post

Okay, after a bit of experimenting, I've determined the following for Laptop #1:

Running today's updated Scrivener.exe file shows me what I quoted in an earlier post.

If I run yesterday's Scrivener_UPDATE1.exe, the programs asks for an email address and a serial number. Once that is entered, the program runs normally. I've closed and restarted numerous times to verify.

If I run the original Scrivener.exe v1.9x file, it behaves the same as yesterday's updated Scrivener.exe, and runs normally.

I don't know if that's any help.

User avatar
philjaq
Posts: 46
Joined: Tue Dec 22, 2015 7:07 pm
Platform: Linux + Windows

Sun Sep 08, 2019 6:44 pm Post

Hi again - tried your second fix, Tiho. Works fine but I can't say the startup is perfect.

Initially, Scrivener starts up in a flash with the previous used project opened. But the formatting of the project is not correct and it takes a full 10 seconds of inactivity (in the visual sense - obviously something is going on in the background) before the project is ready to go, correctly formatted.

But, for me, that's not a great problem.

User avatar
philjaq
Posts: 46
Joined: Tue Dec 22, 2015 7:07 pm
Platform: Linux + Windows

Sun Sep 08, 2019 8:48 pm Post

Further to my last post, I have just looked in the drop down box under Help in Scrivener : the eighth entry which normally says "Deactivate Scrivener" now says "Deactivate Scrivener (Searching for License Server)" and it is grayed out.

So although I'm happily working as usual with no apparent problem, Scrivener is failing to connect to the License Server - wherever that might be. And I am using the second fix version just supplied today by Tiho. I'm on-line and working normally with no internet connection problems.

Tw
Twolane
Posts: 144
Joined: Sat May 12, 2012 7:39 pm
Platform: Windows

Sun Sep 08, 2019 10:56 pm Post

I've re-downloaded today's Scrivener. exe file and copied it appropriately. It now runs accordingly.

Thanks for all the effort.

R.
R.Ruules
Posts: 3
Joined: Fri Sep 06, 2019 8:34 am
Platform: Windows

Mon Sep 09, 2019 10:54 am Post

Hi,
Just tried out the fix on one of my Win10 Pro machines and it worked fine, no nag screen, no delays in startup to speak of. I will try later on my two other machines (they are in different location).
Thanx for the effort!

Ma
Max Gardin
Posts: 6
Joined: Thu Jun 27, 2019 3:58 pm
Platform: Windows

Mon Sep 09, 2019 3:33 pm Post

Tested the second fix on Intel-based Windows 10 Pro (full updated) notebook and AMD-based Windows 10 Home (full updated) desktop.

First run:
Intel notebook: 15 seconds from launch to be ready, Scrivener shows the 100% text scale before to switch at 130% (used) and become usable
AMD desktop: 14-15 seconds from lauch to be ready. Same as the notebook about text scale behaviour.

Following runs (same session, no windows restart):
Intel notebook: 9-10 seconds from launch to be ready
AMD desktop: same as first run (still 14-15 seconds)

----

Long story short, the second fix is faster the first fix for the following runs (the first run is similar) but only for Intel-based machine despite the AMD desktop was more powerful as hardware. Both fix are definitely better than Scrivener 1.9.13 (hung up for 25-30 seconds, sometimes freezed forcing quit, and, ofc, license activation error occasionally) but still slower than Scrivener 1.9.9 (the first version I used, I remember it worked perfectly and very fast on both my pc, surely faster than 9-10 seconds).
I guess the second fix makes a better use of Windows Prefetch or something like that. It would be nice it was optimized for AMD cpu too.
This about speed and freezes. About "2 weeks" message. I didn't get others after I installed the fix executables, so I imagine this bug was fixed.

R.
R.Ruules
Posts: 3
Joined: Fri Sep 06, 2019 8:34 am
Platform: Windows

Mon Sep 09, 2019 5:12 pm Post

Following up on my previous post, tried the fix (downloaded today, identifies itself as "Version: 1.9.13.0 - 07 sep 2019") on my other machines, Win10 Pro and Win7 Pro. Both ran without the nag screen, no noticeable delays (other than what I am used to, often switching between the Win and the iOS version and having complex projects with back-ups).
So as far as I'm concerned, this is absolutely fine :-)

User avatar
philjaq
Posts: 46
Joined: Tue Dec 22, 2015 7:07 pm
Platform: Linux + Windows

Mon Sep 09, 2019 6:12 pm Post

[quote="philjaq"]Further to my last post, I have just looked in the drop down box under Help in Scrivener : the eighth entry which normally says "Deactivate Scrivener" now says "Deactivate Scrivener (Searching for License Server)" and it is grayed out.

I have a little further information about this today.

When I run Scrivener on W10 from my admin account, the "Deactivate Scrivener" entry in Help drop down displays correctly. When I'm running Scrivener from my unprivileged user account, the deactivate entry is greyed out and shows that it is searching for the license server.

Since I operate generally from the unprivileged user account, does this mean that in 2 months I'll again get the warning that I'm going to revert to 'trial' version? Do I have to remember to run Scrivener from my Windows admin account at least once every 2 months?

That would seem like an unreasonable burden.

User avatar
philjaq
Posts: 46
Joined: Tue Dec 22, 2015 7:07 pm
Platform: Linux + Windows

Tue Sep 10, 2019 10:02 am Post

Re: using second fix version of scrivener.exe supplied by Tiho a couple of days' ago --

Previously over the several years that I have been using Scrivener, every time I shut Scrivener down there would be a slight pause and a dialogue box with a progress bar would advise me that a copy was being made [strange, but I got so used to seeing it that I don't remember exactly what words this box used].

Yesterday, after a lengthy writing session, when I closed down, this advisory no longer appeared and the closure of scriv was almost instantaneous.

This morning, when I started Scrivener, I got a warning that my project was already in use somewhere else or Scrivener had not closed down properly last time. I took the 'continue anyway' option and the project opened and was ok, complete and uncorrupted.

I have since repeated the shutdown, the advisory dialog still doesn't appear but the project reopens ok. Is this a result of the changed exe file supplied by Tiho or a glitch on my pc?

Pa
Pagecrawler
Posts: 6
Joined: Sat Feb 14, 2015 4:55 pm
Platform: Windows

Tue Sep 10, 2019 4:56 pm Post

Is it possible that someone can explain in (very) basic terms what I have to do to fix this as all I'm getting at the moment is
Scrivener telling me that my trial period is over and to enter my licence number which I have done (purchased in 2015) but it does nothing I'm afraid I have very little computer knowledge so I really do need basic instructions Thanks very much in advance

User avatar
kewms
Posts: 5438
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Tue Sep 10, 2019 5:42 pm Post

If you're having to enter your license number, that's a different issue. Please open a support ticket.
https://www.literatureandlatte.com/contact-us

Katherine
Scrivener Support Team

User avatar
philjaq
Posts: 46
Joined: Tue Dec 22, 2015 7:07 pm
Platform: Linux + Windows

Tue Sep 10, 2019 8:46 pm Post

Pagecrawler wrote:Is it possible that someone can explain in (very) basic terms what I have to do to fix this as all I'm getting at the moment is Scrivener telling me that my trial period is over and to enter my licence number which I have done (purchased in 2015) but it does nothing I'm afraid I have very little computer knowledge so I really do need basic instructions Thanks very much in advance


Hi PA - first, check the first two postings of this thread (on Page 1 of this thread - we are presently here on page 5) and be sure that you are seeing the same error message as one of those reported. The screen shots are in the first 2 messages.

If your error message is different from those shown at the beginning of this thread, it is possible that your problem is something different but since you seem to have been operating Scrivener ok since 2015, it is likely that this thread is relevant.

If your check confirms that you are a victim of the time bomb which lived in the 1.9.13 update of Scrivener (around June or July this past summer), then you need to refer to the instructions provided by tiho_d in his post in this thread on Sat Sep 07, 2019 14:45 (on page 3) but don't use the link in that post.

Instead, use the link in his post of Sun Sep 08, 2019 15:18 (on page 4) which I repeat here :

https://www.dropbox.com/s/v6orz5b8aq4mt ... r.zip?dl=0

If you are hesitant about being able to download the zip file from Dropbox, change the dl=0 at the end to dl=1 and it should download automatically ie

https://www.dropbox.com/s/v6orz5b8aq4mt ... r.zip?dl=1

If you feel that you will have difficulty in carrying out tiho's instructions in that Saturday post, then you'd probably need to seek hands-on help from a friend to unzip the file and swap the new scrivener.exe with the old one in your Windows folder.

The location of this folder may be dependent on your version of Windows. On my Windows 10 box it is in the folder C:\Program Files (x86)\Scrivener\

hth - Philip

rh
rhoogschagen
Posts: 1
Joined: Wed Sep 11, 2019 10:26 am
Platform: Windows

Wed Sep 11, 2019 10:58 am Post

Same here. Computer is fully updated, but the bugger keeps telling me that it can't check my registration and threatens me with going to trail mode soon. It has cost me half a day. Fix this please.