Bug? How to set "Wrap text"

User avatar
uhu
Posts: 97
Joined: Wed Oct 20, 2010 6:43 am
Platform: Mac
Contact:

Thu Feb 28, 2019 9:46 am Post

EDIT: This actually may fit into "Bug Hunt" now.

The problem has been:
I had a problem with both Compose and Editor mode, where I (still) cannot find any answer to on teh web for the win version, and which makes it impossible to use both for a project.

I pasted a longer text from a Win 10 Thunderbird e-mail into the Editor, checked Invisible Characters (all in order, no nb spaces and such), but still, the text wouldn't wrap. So a line just continues happily to it's and about four screens to teh left, while I only ave one single screen available ...

Where exactly is the switch to enable Text Wrap so that I actually see the whole line no matter how high I set teh Zoom and Page Width?


EDIT Workaround:
I copied the Thunderbird mail text in Openoffice, copied it from OpenOffice into Scrivener and now Text Wrap seems to work ...

Version: Current version of Scriv for Win, Win 10, current Thunderbird build. Pasted both normally and with "Match Style".
Book on Jugger, download for free –- a real-world post-apocalyptic sport :: twitter :: writing factbooks, novels and SciFi series books with Scrivener

Ji
JimRac
Posts: 1722
Joined: Wed Aug 27, 2014 2:06 pm
Platform: Win + iOS

Thu Feb 28, 2019 5:35 pm Post

Hi uhu,

A screenshot of the complete Scrivener window showing the issue would help me better understand what you mean.

ETA: Also, a screenshot of your Editor options please. Tools > Options > Editor.

Best,
Jim
I’m just a customer.

st
steveshank
Posts: 380
Joined: Tue Mar 07, 2017 8:28 pm
Platform: Windows

Fri Mar 01, 2019 1:38 am Post

If you want to paste text from one program into another and do not want the formatting and other control to be exercised from the original program, you must strip the formatting out of the original. In the case you had, someone wrote something in some program using some formatting and you shoved it into Scrivener and it looks wrong.

To strip out the formatting you must first paste into a text editor (NOT Open Office or any other office program that tries to format). A text editor that has no formatting. NotePad in windows will work fine if you don't have a good text editor. In this case Open office worked, but notepad will always work.

You could also try the option of Pasting with matching style to see if that gets you something closer to what you want.

If you just willy nilly paste anything from anywhere into other places, you'd be surprised how often you will get smacked sometime when that text doesn't act like you thought it would. It might even wait until you try to compile before it hits you.

User avatar
uhu
Posts: 97
Joined: Wed Oct 20, 2010 6:43 am
Platform: Mac
Contact:

Fri Mar 01, 2019 7:25 am Post

Thanks for the hint, that is the workaround I already used and described above. Good point with text editors. While copying in Notepad or a similar editor might throw other unwanted issues, they should be more likely to be visible ones.

But the behaviour is still strange:
- I used "Paste with match style", as I wrote above, yet with the same results.
- If the lines don't break, than this should be due to nb spaces, which in turn should be shown via "Show Invisible". But there, the text appeared as normal. No special characters whatsoever.
- I looked into the source code of the e-mail, and it has been received as text/plain without any special formatting or HTML. So the problem seems to be between Thunderbird's copied text format and Scriv. Will try to duplicate with another e-mail.

(plus a formatted e-mail should be either html or some xml code, so quite easy for the program to strip off the text, I guess? Not some old .doc voodoo)

A screenshot is not really necessary, I guess, nor possible due to confidentiality, sorry. Just imagine a text line continuing forever until a paragraph return hits hit.
Book on Jugger, download for free –- a real-world post-apocalyptic sport :: twitter :: writing factbooks, novels and SciFi series books with Scrivener

User avatar
rdale
Posts: 2071
Joined: Tue Jul 14, 2015 1:07 pm
Platform: Mac, Win + iOS
Location: St. Louis, MO
Contact:

Fri Mar 01, 2019 2:18 pm Post

uhu wrote:But the behaviour is still strange:
- I used "Paste with match style", as I wrote above, yet with the same results.

I've encountered this in a number of different programs across operating systems, where I paste text, but didn't want the source formatting. So I undo and paste-and-match-style, only to find that the formatting didn't get reset.

If you run into this again, you have a few options: Paste the text back in anyway, then click on the document in the binder and go to Documents->Convert->Text to Default Formatting. If that doesn't work, then trash the new/empty document and start over, using Paste and Match Style from the get-go.
FKA: robertdguthrie
AKA: R Dale Guthrie, Robert, Mr. Obscure, and "Oh, it's you again".

User avatar
uhu
Posts: 97
Joined: Wed Oct 20, 2010 6:43 am
Platform: Mac
Contact:

Mon Mar 04, 2019 9:50 am Post

Hej,

thanks for the reply!
rdale wrote:If that doesn't work, then trash the new/empty document and start over, using Paste and Match Style from the get-go.

"Paste and Match Style" didn't work for me.
Book on Jugger, download for free –- a real-world post-apocalyptic sport :: twitter :: writing factbooks, novels and SciFi series books with Scrivener