Help! Downloaded update now Scrivener won't load

User avatar
Aryadna
Posts: 11
Joined: Sun Jul 24, 2016 11:10 pm
Platform: Windows

Sat Jul 30, 2016 3:07 am Post

tiho_d wrote:The log procedure is not a cure to run Scrivener, but a test to verify that something on the system prevents Scrivener from starting normally.


I understand that. I'm just confirming that it is not working, and I need advice on other troubleshooting methods.

Tricia wrote:Hi,

Just to say - I have been away for a few days and now I'm back - and this thread has exploded. What's the latest thinking on this? I'm confused by all the replies...and things that haven't/have worked.

Funny thing was that this morning I absentmindedly clicked the icon and there it was - my project loaded normally! So - someone said earlier - perhaps leave it for a while and it will work and that seems to have happened! But why?!

Still wondering what other glitches I'll find though...


Welcome back! Latest thinking seems to be that there is something on our computers keeping the program from opening. We're still waiting on more troubleshooting tactics for this since the devs can't seem to replicate the problem. I really wish leaving it for a few days worked for me. Super glad you're up and running, though!

User avatar
shaybella
Posts: 11
Joined: Thu Dec 06, 2012 4:53 am
Platform: Windows
Contact:

Sat Jul 30, 2016 6:32 am Post

I'm running Windows 10 Pro, just updated from Scrivener 1.7.3 to 1.9.5 in one swell foop ... and nothing. Btw, when I navigated to the scrivener folder in C:\Programs (x86)\, no logs, no log folder. I uninstalled / reinstalled, same issue.

for those who need to roll back, just pointing out that prior versions can be downloaded from: https://www.literatureandlatte.com/scri ... geList.php

you may need to copy/paste the link.

Tr
Tricia
Posts: 90
Joined: Fri Dec 17, 2010 8:33 am
Platform: Windows

Sat Jul 30, 2016 10:37 pm Post

Thanks yes just to confirm Scrivener has worked normally all day! Yay.. I wonder if the fact I used it by going In through the 'back door' (see earlier posts for how! ) somehow got the registry up and running again!

Mi
Mitchell.Ha
Posts: 1
Joined: Sun Jul 31, 2016 3:31 am
Platform: Mac, Win + iOS

Sun Jul 31, 2016 3:51 am Post

The "New Project" window comes up but cannot create a new project or load an existing project.

What should I do??? How could you do this to us?


Debug: "Sat Jul 30 23:43:28 2016" "
Scrivener

Application: Scrivener
Version: 1.9.5.0
Build: Release

Executable: Scrivener.exe
Compiler: MSVC.NET 1600
Qt-Compiled: 4.8.6
Qt-Runtime: 4.8.6
Windows Version: Windows 7
Created: Jul 19 2016 12:39:52
"

User avatar
MimeticMouton
Posts: 8711
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sun Jul 31, 2016 11:34 pm Post

Hi guys,

We've been working on this and have been experimenting with different builds that tweak various settings from 1.9.5, but I'm sorry to say we still have not been able to find what's preventing 1.9.5 from running on some systems. None of the 1.9.5 beta testers ran into any issues with installing or running the program other than an early case of a security program flagging it and preventing installation, which sometimes happens with new software that hasn't been OK'd by a number of the security software's users. Whitelisting Scrivener in his security program's settings and reinstalling fixed the issue. So regrettably, the first instance we had of people having difficulty running 1.9.5 was when it went live to the public.

We're truly sorry you're having trouble and are doing our best to resolve it as quickly as we can. Unfortunately, despite there being a number of you unable to get Scrivener running, we're still very short on information about what is causing it, why you're not able to run it but other users are, and why there's a difference in behaviour between 1.9 and 1.9.5 on your machines.

To help, we would appreciate if you could share some logs from the Windows Event Viewer. On Windows 10 and 8.1, you should be able to run it by right-clicking the Windows start menu and selecting "Event Viewer" from the list. For other versions, open the Control Panel and choose System and Maintenance > Administrative Tools, then double-click Event Viewer.

In the left sidebar of the Event Viewer, expand "Custom View" and select "Administrative Events", then from the menu select Action > Save All Events in Custom View As... and save the file as the "Event Files (*.evtx)" type.

Please then expand the Windows Logs folder in the Event Viewer sidebar and repeat the Save As for "Application", "Security", "Setup", and "System".

You can send the logs to windows.support AT literatureandlatte DOT com (Attn: Jennifer) with a reference to this thread, or if they are too large to attach to the email, let us know and we can set up a shared Dropbox, or you can upload them to your own server (Dropbox or otherwise) and provide a link from which we can download them (after which you can remove them--we'll let you know as soon as we've got the files). Hopefully that will provide some more insight into what's going on with the system when you're trying to launch Scrivener.

Additionally, comparing the program installed on these systems where 1.9.5 won't run may give us some further clues. To create a list of the majority of installed programs, please do the following:

1. Type "powershell" into the Windows search (be sure it is searching "Everywhere" on Windows 8.1), then click to run the Widows PowerShell program that it returns.

2. Copy and paste the following into PowerShell window:

Code: Select all

Get-ItemProperty HKLM:\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\* | Select-Object DisplayName, DisplayVersion, Publisher, InstallDate | Format-Table –AutoSize | Out-File $env:userprofile\Desktop\InstalledPrograms1.txt

3. Press enter; it will create a new text file on your desktop called "InstalledPrograms1". Then paste into the PowerShell window:

Code: Select all

Get-ItemProperty HKLM:\Software\Microsoft\Windows\CurrentVersion\Uninstall\* | Select-Object DisplayName, DisplayVersion, Publisher, InstallDate | Format-Table –AutoSize | Out-File $env:userprofile\Desktop\InstalledPrograms2.txt

4. Press enter again and it will create a second text file on the desktop, "InstalledPrograms2". Please attach both lists to your post here or email them to windows.support AT literatureandlatte DOT com (Attn: Jennifer).

With your email or post, please include your version of Windows and the screen resolution and display scaling settings (even if you have posted previously earlier in the thread, just to help keep things clear please!).

Thank you all for your patience and assistance. Your help with this is invaluable, as we cannot reproduce the problem on our own systems, and we want to get you a working updated Scrivener ASAP. Even if you are unable to provide all the information above, any that you can send would be helpful!

For those who need to get Scrivener running immediately, you can download the 1.9 version from this page, as previously noted.

Thank you,

Jennifer
Jennifer Hughes
(MM for short)

Tr
Tricia
Posts: 90
Joined: Fri Dec 17, 2010 8:33 am
Platform: Windows

Mon Aug 01, 2016 8:54 am Post

HI MM I started to do this but only got as far as Save as for Application when I ran into a problem - I was trying to save it and it kept saying 'invalid file type' I tried a couple of different names for the file but it wouldn't work. I saved the first OK.
Also - running in the background now is the Windows Management console which says 'waiting for all snap-ins to complete' - it came up after the invalid file type and I can't get rid of it.
Grrr. Sorry not a techy type - struggle with all this sort of thing. Will come back to this later.
Thanks for your efforts on our behalf!

Tr
Tricia
Posts: 90
Joined: Fri Dec 17, 2010 8:33 am
Platform: Windows

Mon Aug 01, 2016 3:40 pm Post

Update - I've managed to do it! Yay. I've sent the email with a dropbox link. Just checking - is it windows DOT support?

User avatar
MimeticMouton
Posts: 8711
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Mon Aug 01, 2016 4:09 pm Post

Hi Tricia - Sorry you were having some trouble getting the files. I see you did get it all running and sent them to support (yep, with the dot was the correct address), so thank you very much for that!
Jennifer Hughes
(MM for short)

cm
cma01
Posts: 3
Joined: Thu Jul 14, 2016 7:38 pm
Platform: Windows

Mon Aug 01, 2016 5:29 pm Post

I'm having the same issue with everyone else on the thread. I updated Scrivener to 1.9.5 and now it won't load. This is on Windows 10.

I completely uninstalled, reinstalled, made sure antivirus was off. Ran CC Cleaner, checked the file system, and tried to run in compatibility mode. It wouldn't load.

Things I noticed, before I completely uninstalled the program, Scrivener didn't show as a background process. After I uninstalled, rebooted, and reinstalled it did. The very first time I tried to update it, the process somehow got interrupted. I don't know if that started my issues.

Regardless, I've gone back to 1.9.0 I did save the log files as Jennifer requested in an earlier thread and I will email them to windows support.

Hopefully this will get resolved soon.

ji
jimbro
Posts: 5
Joined: Mon Aug 01, 2016 11:26 pm
Platform: Mac, Win + Linux

Mon Aug 01, 2016 11:38 pm Post

Okay, I'm having the same problem:
Installed the new update.
It installs and does not report any problems. - pops up the readme file. Creates new desktop icon.
Attempting to open fails - nothing happens. Scrivener does not open, does not give error message.
Nothing happens if I click on the desktop icon.
Nothing happens if I go thru the Programs/Scrivener menu.
I tried a complete uninstall followed by a fresh install of the latest version: Same result, Scrivener will not open.
I ran the two powershell scripts you specificed, but no files were created on my desktop.
This is on Windows 7.
Hope this helps.
Thanks.

Edit: I rolled back to version 1.9.0.0 and that version still works fine.

User avatar
MimeticMouton
Posts: 8711
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Tue Aug 02, 2016 12:53 am Post

Hi cma01 - Thanks for copying the logs. Did you have a chance to send them yet? I didn't see an email from your forum address, but I realize it may have been under a different account/name, so I just want to be sure I don't miss it. (windows.support AT literatureandlatte DOT com, Attn: Jennifer) Thank you!

Hi jimbro - Could you try grabbing the event logs? Those might be most helpful. For the powershell lists, try these commands instead:

Code: Select all

Get-ItemProperty HKLM:\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\* | Select-Object DisplayName, DisplayVersion, Publisher, InstallDate | Format-Table –AutoSize

This will spit out a list right in the window. Go ahead then and run this command:

Code: Select all

Get-ItemProperty HKLM:\Software\Microsoft\Windows\CurrentVersion\Uninstall\* | Select-Object DisplayName, DisplayVersion, Publisher, InstallDate | Format-Table –AutoSize

That will give another list in the window. Then right-click the window title bar and choose Select All, press Enter to copy the text, and then paste it into a new text document (Notepad or WordPad is fine) that you can save and send. Thank you!
Jennifer Hughes
(MM for short)

ji
jimbro
Posts: 5
Joined: Mon Aug 01, 2016 11:26 pm
Platform: Mac, Win + Linux

Tue Aug 02, 2016 2:51 am Post

Ok. I have the event logs now and have emailed them to you.
Hope they help. Best wishes.

ji
jimbro
Posts: 5
Joined: Mon Aug 01, 2016 11:26 pm
Platform: Mac, Win + Linux

Fri Aug 05, 2016 2:13 am Post

Okay. After version 1.9.5.0 failed to load, I rolled back to 1.9.0.0 and have been using it the last few days.
When I opened it today, I got the notice that 1.9.6.0 was available, so I downloaded and installed that.
As before, it appears to install fine. I even got to the readme file. The desktop icon was created, and the program was listed under All Programs/Scrivener.
However same problem - Scrivener does not load when selected.
Curiously, the "Uninstall Scrivener" program that was installed with 1.9.6.0 does load and work. I was able to use that to uninstall 1.9.6.0 and reinstall 1.9.0.0

Tr
Tricia
Posts: 90
Joined: Fri Dec 17, 2010 8:33 am
Platform: Windows

Fri Aug 05, 2016 9:21 am Post

Oh no! IThe new update works for me but then somehow 1.9.5 had decided to too. That's strange...

User avatar
Marta
Posts: 537
Joined: Sat Feb 05, 2011 2:23 am
Platform: Windows
Location: Los Angeles
Contact:

Fri Aug 05, 2016 9:28 am Post

Tricia wrote:Hi - this morning I downloaded the update which you sent out yesterday, prompted to do so when I opened Scrivener. I followed the instructions carefully and the download seemed to proceed normally - no glitches. I then tried to launch Scrivener but the timer went for about 30 seconds but then just disappeared.

Here are the things I've tried. Restarting computer. Clicking on icon in tray bar and on desktop - both respond (or don't!) in the way I've outlined. I've also tried taking the backup copy of my project from Dropbox and trying to launch it after extracting files. Still no joy.

Please help - I have a day to work on my project today and was looking forward to getting on with it!

I'm having exactly the same issue after installing. Had to go back to my earlier version. Thought it was just me because I'm on XP.
I see it isn't. :?:
Marta
Scrivener 1.9.7.0
http://www.spookyfilms.com