Help! Downloaded update now Scrivener won't load

User avatar
Aryadna
Posts: 11
Joined: Sun Jul 24, 2016 11:10 pm
Platform: Windows

Wed Jul 27, 2016 4:20 pm Post

tiho_d wrote:1) Open Command Prompt
2) Navigate to the Scrivener installation folder. Default location is: "C:\Program Files (x86)\Scrivener"
Type inside the Command Prompt: cd "C:\Program Files (x86)\Scrivener"
3) Type inside the Command Prompt: "Scrivener.exe --log"
4) Check for the *.log file inside the "C:\Program Files (x86)\Scrivener\log" directory.


When I did this, I got the following:

Code: Select all

Microsoft Windows [Version 10.0.10586]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\Users\redacted>C:\Program Files (x86)\Scrivener
'C:\Program' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\redacted>cd "C:\Program Files (x86)\Scrivener"

C:\Program Files (x86)\Scrivener>Scrivener.exe --log

C:\Program Files (x86)\Scrivener>


When I navigated to the Scrivener folder, there was no log folder inside, nor any log file. I tried this step four times. The first time I tried without disabling any antivirus or firewall. The second time I disabled everything: antivirus, antimalware, firewall. Third time I rebooted and again made sure my protection was turned off. Fourth time, I tried (in mild desperation) refreshing the folder to see if I was missing anything. I also made sure that all hidden folders were visible.

Just in case, I checked my AppData>Local>Scrivener folders, and there was no log file or folder.

When I ran the command, it tried to open Scrivener, but as with every other time I tried opening the program, the "working" circle comes around for a moment, then goes away and Scrivener never opens, BUT, it shows up in my background processes.

As an added step, I terminated the background process to see if that would show any kind of log file, and got nothing.

ETA: I don't know if this makes any difference, but I'm running Windows 10. I reformatted and installed a clean version (not the update from when I updated from Windows 7) about 4 months ago. Scrivener 1.9.0.0 works perfectly on my machine. But, when I install 1.9.5.0 either as an update or as a fresh install after uninstalling the one currently installed, the "working" circle pops up, spins a moment, and goes away without ever opening the program, and only leaving a trace in my background processes visible in Task Manager.
Last edited by Aryadna on Wed Jul 27, 2016 4:27 pm, edited 1 time in total.

It
Itman
Posts: 10
Joined: Tue Jul 26, 2016 3:36 pm
Platform: Win + iOS

Wed Jul 27, 2016 4:24 pm Post

You are right, as I wrote before, this method works with an older version, because the scrivener.exe is working and I get a log file. But with 1.9.5 I get nothing and I don´t see it in the background process. I wrote to the support, but no reply yet.

User avatar
tiho_d
Posts: 868
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Wed Jul 27, 2016 4:31 pm Post

You have missed the 'cd' command in front.
Type exactly the following line including the double quotes:
cd "C:\Program Files (x86)\Scrivener"

Log files are within the "log" subfolder and not the root installation folder.

Ensure that Scrivener is NOT running when you run "Scrivener.exe --log"

Give it one more try.

It
Itman
Posts: 10
Joined: Tue Jul 26, 2016 3:36 pm
Platform: Win + iOS

Wed Jul 27, 2016 4:39 pm Post

Image

No Log File and no Log Folder in C:\Program Files (x86)\Scrivener

User avatar
tiho_d
Posts: 868
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Wed Jul 27, 2016 9:34 pm Post

Itman, if you are sure that Scrivener was not running before you executed "Scrivener.exe --log" and a log file is missing, this means that something on your system is totally preventing Scrivener from starting up. Creating the log file is one of the very first things that are created upon starting Scrivener. In your case it might be a Security or Identity Protection application that has no record of the new Scrivener version and blocks the new executable from starting. We have had reports and I have experienced myself such problem with the HSBC - Trusteer Rapport Software in the past. Uninstalling the software fixed all my troubles back then.
If running Scrivener under Windows Safe Mode does not help either, I am afraid you need to trace which application is blocking Scrivener from running normally. If you are willing to send us a list of installed applications on your system, we might also give it a look.

It
Itman
Posts: 10
Joined: Tue Jul 26, 2016 3:36 pm
Platform: Win + iOS

Wed Jul 27, 2016 10:04 pm Post

How do you explain the fact, that I can run the version 1.9.0 without any problems? But 1.9.5 is not working? How can something block the new version?

I installed and reinstalled it many times, it doesn´t work. If I install 1.9.0 back, it is working, altough i cannot sync with my ipad.

User avatar
tiho_d
Posts: 868
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Wed Jul 27, 2016 10:08 pm Post

v1.9.0.0 is live for quite some time and has a lot of usage history collected from security apps. The new executable is brand new, and the security software has not still collected enough trusting info.

I also found another user(Markio) posting in another thread with the same troubles the following:
"I ended up booting in Safe mode and deinstall and install from there. It works now ..."

You might give this another try. Running the installer with Admin rights might also help further.

It
Itman
Posts: 10
Joined: Tue Jul 26, 2016 3:36 pm
Platform: Win + iOS

Wed Jul 27, 2016 10:27 pm Post

I saw this post too and tried it without succsess. I don´t understand what you mean by usage history. I have scrivener not longer than a week. I found this great software through the ios app.

User avatar
tiho_d
Posts: 868
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Wed Jul 27, 2016 11:37 pm Post

Security software collects information about applications running on many different computers. This creates a community database of trusted applications at the server of the security software. When the security application detects that an application is unknown, i.e. no record has been found it might prevent the application from running completely. Every new version of a software is a new application without any community record.

As Scrivener v1.9.5.0 is a new version without community usage history, it might be blocked. After a month for example, when the new version has collected enough usage history(and you have updated your antivirus/security definitions) it can be automatically allowed. All this is not new, and many antivirus and security applications use a community watch database of applications, to protect us from malicious software.

User avatar
Aryadna
Posts: 11
Joined: Sun Jul 24, 2016 11:10 pm
Platform: Windows

Thu Jul 28, 2016 12:20 am Post

I also tried installing in safe mode, and in a sandbox. It still isn't working, nor is it creating a log. The only thing I can suggest from here is sharing screens on Skype or something, since you seem to not believe us that we are turning off our antivirus programs and are capable of following directions.

User avatar
tiho_d
Posts: 868
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Thu Jul 28, 2016 12:36 am Post

I have never meant that you cannot follow directions, or turn off antivirus software Aryanda. There are so many things that might go wrong, and so many different applications. I believe that you will agree that we cannot login on all user machines with problems, and debug the local machine problem. Our support team is currently collecting more details trying to find the bottleneck of the problem.

One more hint about the log files when you try it. You should open an Admin Command Prompt. Sorry, that I have missed to point it out in my previous post. I will update it, too.

User avatar
Aryadna
Posts: 11
Joined: Sun Jul 24, 2016 11:10 pm
Platform: Windows

Thu Jul 28, 2016 1:07 am Post

I'm sorry if I sounded snotty. This is really frustrating, especially when it seems to be happening to a good number of people and no one knows why. Anyway, I tried it again. Both in normal mode, and Safe Mode. Again without my protection active. Here's what I got when I ran it as administrator:

Code: Select all

Microsoft Windows [Version 10.0.10586]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>cd "C:\Program Files (x86)\Scrivener"

C:\Program Files (x86)\Scrivener>Scrivener.exe --log

C:\Program Files (x86)\Scrivener>


Again, it did not open Scrivener, and it did not generate a log file or folder.

User avatar
tiho_d
Posts: 868
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Thu Jul 28, 2016 10:23 am Post

The log procedure is not a cure to run Scrivener, but a test to verify that something on the system prevents Scrivener from starting normally.

sw
swingsetlife
Posts: 4
Joined: Thu Jul 21, 2016 10:01 pm
Platform: Win + iOS

Thu Jul 28, 2016 9:34 pm Post

I can verify that I'm having the same issues, cannot create a log, uninstalled and reinstalled in safe mode as an administrator. I've tried disabling windows defender, elevating the user, and all the other things.

Tr
Tricia
Posts: 90
Joined: Fri Dec 17, 2010 8:33 am
Platform: Windows

Fri Jul 29, 2016 10:10 am Post

Hi,

Just to say - I have been away for a few days and now I'm back - and this thread has exploded. What's the latest thinking on this? I'm confused by all the replies...and things that haven't/have worked.

Funny thing was that this morning I absentmindedly clicked the icon and there it was - my project loaded normally! So - someone said earlier - perhaps leave it for a while and it will work and that seems to have happened! But why?!

Still wondering what other glitches I'll find though...