Strange margins formatting in screenplay mode

Ma
Manilov
Posts: 7
Joined: Sun Oct 11, 2015 6:41 pm
Platform: Windows

Sun Oct 11, 2015 6:45 pm Post

Hello,
I just updated to version 1.9.0.0 and I just noticed that something is off with the formatting in screenplay mode. The Action margins are at 6.5, which is just about middle of the page. And the line spacing is non-existent. Please see screenshot attached. Is this something on my side or does everybody get that? Can I correct this? Thank you.
Attachments
strange formatting.jpg
strange formatting.jpg (98.46 KiB) Viewed 1005 times

Ma
Manilov
Posts: 7
Joined: Sun Oct 11, 2015 6:41 pm
Platform: Windows

Tue Oct 13, 2015 4:31 pm Post

Has nobody ever encountered this error? Am I the only one? :oops:

User avatar
MimeticMouton
Posts: 8824
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Tue Oct 13, 2015 9:22 pm Post

I believe this is a scaling bug with the zoom factor, not specific to 1.9 but rather related to the default Windows zoom on high-res monitors. Have you switched anything else between working on the script in 1.8.6 to 1.9? I'd expect the high-res problem to be present in both.

Have you tried the manifest fix suggested here? This has helped a lot of users working with high-resolution monitors, but I don't think anyone has mentioned script mode specifically and I'd be interested to see if it helps workaround the problem you're having.
Jennifer Hughes
(MM for short)

Ma
Manilov
Posts: 7
Joined: Sun Oct 11, 2015 6:41 pm
Platform: Windows

Thu Aug 11, 2016 8:34 pm Post

Hello again.
Am I really the only one having this problem?

With the new update, this is still what my Screenplay formatting looks like:

Capture.PNG
Capture.PNG (22.37 KiB) Viewed 939 times


Just to compare, this is what it _should_ look like.

wp1f6c57c5_00.png
wp1f6c57c5_00.png (27.19 KiB) Viewed 939 times


I'm running the 'Disable display scaling on high DPI settings' compatibility mode and a Dell XPS 13 running Win 10. :(

User avatar
MimeticMouton
Posts: 8824
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sun Aug 14, 2016 4:21 am Post

It's definitely a scaling issue with the editor, I'm afraid, so it's not something we can fix properly in the current version because the framework as a whole doesn't have true High DPI support. If you don't tick the "Disable scaling" option, does it correct the spacing?
Jennifer Hughes
(MM for short)

Ma
Manilov
Posts: 7
Joined: Sun Oct 11, 2015 6:41 pm
Platform: Windows

Sun Aug 14, 2016 8:52 am Post

MimeticMouton wrote:It's definitely a scaling issue with the editor, I'm afraid, so it's not something we can fix properly in the current version because the framework as a whole doesn't have true High DPI support. If you don't tick the "Disable scaling" option, does it correct the spacing?


Ah, yes, once DPI scaling is removed, then the formatting works properly. But now the whole program is a bit blurry (text and icons).

Ok, thank you! Now at least I know what the issue is.

But it's really strange because my screen resolution is 1920x1080... Is that really high DPI?

RL
RLeal
Posts: 31
Joined: Mon Jul 21, 2014 4:03 pm
Platform: Windows

Tue Aug 16, 2016 2:25 pm Post

Manilov wrote:Hello again.
Am I really the only one having this problem?


You're not alone.

I have a 3200x1800 monitor which I use in a 1600x900 resolution exclusively so I can use Scrivener but while normal writing is doable, the screenplay problem persists.