Page 1 of 2

Autocorrect is turning dont into dint. How to fix?

Posted: Thu Jun 25, 2015 11:56 pm
by ghbanks
Hi. When I type the word dont it is autocorrected to dint. This is the only word that my ScrivWin does this to, and I've tried various ways of solving the problem... but it persists.
Here are my settings.
On the Options>Corrections screen, I have ticked 'Correct spelling errors as you type' and 'Enable additional substitutions'.
When I 'View Personal Word List', I have added the word don't with the apostrophe. The word dint is not there. There is no other relevant term there. The word won't is there and that autocorrection works perfectly, that is, I type wont and it autocorrects to won't.
On the 'Edit Substitutions' screen, there is nothing relevant.
So...I'm stumped. Can anyone assist?

Re: Autocorrect is turning dont into dint. How to fix?

Posted: Fri Jun 26, 2015 12:57 am
by gr
Not a very wise auto-correct obviously, but 'dint' is a word and that is how it can be showing up as an auto-correct without being specially added.

Sorry, I know that is not a help.

--gr

Re: Autocorrect is turning dont into dint. How to fix?

Posted: Fri Jun 26, 2015 5:23 am
by MimeticMouton
Disable "Correct spelling errors as you type", then type "dont" in the editor and right-click. Choose "don't" from the spelling suggestions. That will give it precedence over "dint". You should then be able to reenable the "Correct spelling" option and have it autocorrect to "don't".

Re: Autocorrect is turning dont into dint. How to fix?

Posted: Fri Jun 26, 2015 11:47 pm
by Graybyrd
That's one reason I tend to be skeptical about "artificial intelligence" ... !

We are frequently required to tell the computer what it doesn't already know. :?

Re: Autocorrect is turning dont into dint. How to fix?

Posted: Sat Jun 27, 2015 1:17 am
by ghbanks
Jennifer Hughes... BRILLIANT. THAT WORKED. I AM SO HAPPY.

Also, importantly, you shared the principle of why this works.

HAPPY INDEED.

Re: Autocorrect is turning dont into dint. How to fix?

Posted: Wed Jul 01, 2015 11:59 am
by ghbanks
A related issue:

I know the word "cant" is a real word but most times I mean "can't" (cannot). How do I tell the spelling list that this is my #1 priority version of the word?

Re: Autocorrect is turning dont into dint. How to fix?

Posted: Wed Jul 01, 2015 3:40 pm
by reepicheep
You can't or is that you cant.

Re: Autocorrect is turning dont into dint. How to fix?

Posted: Wed Jul 01, 2015 10:46 pm
by ghbanks
Really?

Is there no way to set "can't" as the priority autocorrect rendering for the letters c a n t ?

Re: Autocorrect is turning dont into dint. How to fix?

Posted: Wed Jul 01, 2015 10:58 pm
by reepicheep
Dont no ov n e spell chequer that can select based on user preference.

Re: Autocorrect is turning dont into dint. How to fix?

Posted: Wed Jul 01, 2015 11:06 pm
by Briar Kit
In OS X, you can set up a system-wide autocorrect. Not possible in Windows?

Or using the dont/dint/don't fix above, can you fudge an autocorrect by changing cantt (or something else that is easy to type) to can't?

Is it possible to edit/hack the list of words in the main dictionary…removing cant?

Re: Autocorrect is turning dont into dint. How to fix?

Posted: Wed Jul 01, 2015 11:28 pm
by ghbanks
Briar Kit,

1, To set up a system wide autocorrect, I highlight the word and then right click to open up a list of options. Unfortunately spelling is not one of them.

If there's another way to correct the spelling list, I have yet to find it.

2. And I dont yet know how to edit the main spelling master list.

Thanks for your suggestions.
Gary

Re: Autocorrect is turning dont into dint. How to fix?

Posted: Wed Jul 01, 2015 11:47 pm
by MimeticMouton
You can set up a substitution to replace "cant" with "can't" via the "Edit Substitutions" button at the bottom of to Corrections pane in Tools > Options. Be careful with this, though--you may want to add a space on the end to help avoid replacing the sequence "cant" within the middle of a word.

Alternatively you could look into a more sophisticated global tool like AutoHotKey or Breezy to handle corrections like these, which will let you define it as a "whole word" replacement and will work outside of Scrivener as well.

Re: Autocorrect is turning dont into dint. How to fix?

Posted: Thu Jul 02, 2015 3:31 am
by ghbanks
Thanks MM.

Jennifer, that WORKS for me.

I notice the autocorrection only kicks in when I type the next letter after the blank space.

Re: Autocorrect is turning dont into dint. How to fix?

Posted: Thu Jul 02, 2015 6:01 am
by gr
This discussion would not be complete without someone pointing out this alt fix: the method of explicitly typing the apostrophes. Just saying.

-gr

Re: Autocorrect is turning dont into dint. How to fix?

Posted: Thu Jul 02, 2015 1:18 pm
by Sanguinius
MimeticMouton wrote:You can set up a substitution to replace "cant" with "can't" via the "Edit Substitutions" button at the bottom of to Corrections pane in Tools > Options. Be careful with this, though--you may want to add a space on the end to help avoid replacing the sequence "cant" within the middle of a word.

Alternatively you could look into a more sophisticated global tool like AutoHotKey or Breezy to handle corrections like these, which will let you define it as a "whole word" replacement and will work outside of Scrivener as well.

MM, couldn't you make a substitution that takes the spaces around "can't" into account? This would avoid changing longer words that include "cant."