Using the Compiler

User avatar
Marilynx
Posts: 180
Joined: Mon Oct 31, 2011 10:26 pm
Platform: Windows

Tue Dec 16, 2014 1:01 am Post

OK, mental substitution is no biggie. I found it.

Except it's still not coming out the way I thought it would.

Fae Journey is listed to the left as the name of Chapter One, except it should be Canada, Summer, 1835.

ScrivenerCompile_2014-12-15a.JPG
This is how the header for Chapter One comes out.
ScrivenerCompile_2014-12-15a.JPG (15.03 KiB) Viewed 1428 times


And there is no name for Chapter Two.

ScrivenerCompile_2014-12-15b.JPG
This is the break between what should be two Chapters. The page break occurred just fine, but there is no Chapter indication.
ScrivenerCompile_2014-12-15b.JPG (54.98 KiB) Viewed 1428 times
-- Marilynx

User avatar
robertdguthrie
Posts: 3075
Joined: Mon Nov 09, 2009 10:06 pm
Platform: Mac
Location: St. Louis, MO, USA
Contact:

Tue Dec 16, 2014 1:57 pm Post

I'm sorry. It looks like there's an extra option on the Mac version to exclude the container (the Fae Journey folder) from the compile list, and therefore to elevate the documents under it. It appears that there are just two ways around this limitation on Windows. Pick the one you like best...


METHOD ONE

* Click the first document (Canada...).
* SHIFT-click the last document.
* Use the menus Documents->Move->Left
* Remove the Fae Journey folder from the Drafts folder

Now if you compile, the files should all be treated as "level 1" documents (Because they well and truly ARE level 1s).

METHOD TWO

Go back to the Contents drop-down, and select the Draft folder again, just to reset everything where it belongs. Un-check the "Fae Journey" folder's "Include" checkbox in the list of documents there.

Then, in the Formatting pane, do the following:
Select the level 2+ document row.
Click the "-" button in the upper right corner of the pane, to the right of the "Options" and another button. This should delete the Level 2+ row, which was treating each of your documents (at level 2) as scene files in a chapter folder. With the Level 2+ row gone for that kind of document, the "Level 1+" document row will also format Level 2s (and 3s, and 4s.... essentially, the 1+ means "level 1, plus all similar documents above it").
Often wrong, rarely in doubt.
Time for a change... I'm now rdale; same dog-avatar, same dog... channel?

User avatar
Marilynx
Posts: 180
Joined: Mon Oct 31, 2011 10:26 pm
Platform: Windows

Tue Dec 16, 2014 7:52 pm Post

robertdguthrie wrote:I'm sorry. It looks like there's an extra option on the Mac version to exclude the container (the Fae Journey folder) from the compile list, and therefore to elevate the documents under it. It appears that there are just two ways around this limitation on Windows. Pick the one you like best...


Ah hah! That devilish Mac/PC dichotomy! Strikes again!

(Y'know, that was the problem I had with all the videos, which were well-done, but... on a Mac. Nice machines, Macs, but alas, certain software I need for other things isn't available for Macs.)


METHOD ONE

* Click the first document (Canada...).
* SHIFT-click the last document.
* Use the menus Documents->Move->Left
* Remove the Fae Journey folder from the Drafts folder

Now if you compile, the files should all be treated as "level 1" documents (Because they well and truly ARE level 1s).


This method got me exactly one page... my title page. So... I went back and removed the folder Fae Journey altogether, leaving the Chapters directly under Draft.

This got me a close-to-right print out, with the text document names centered under Chapter One, etc.

METHOD TWO

Go back to the Contents drop-down, and select the Draft folder again, just to reset everything where it belongs. Un-check the "Fae Journey" folder's "Include" checkbox in the list of documents there.

Then, in the Formatting pane, do the following:
Select the level 2+ document row.
Click the "-" button in the upper right corner of the pane, to the right of the "Options" and another button. This should delete the Level 2+ row, which was treating each of your documents (at level 2) as scene files in a chapter folder. With the Level 2+ row gone for that kind of document, the "Level 1+" document row will also format Level 2s (and 3s, and 4s.... essentially, the 1+ means "level 1, plus all similar documents above it").


It was reading this which gave me the idea to try removing Fae Journey as a folder altogether, and just have the Chapter files under Draft.

So I actually ended up using parts of both methods.

It took me a bit to realize that by removing the Level 2s, I could then go into the level 1s and make sure the text would be justified.

I note that there does not appear to be a way to change the size of the font for "Chapter One" to something slightly larger than the title? (Not that it would be hard to go through and reformat it in Word, but if I don't HAVE to....)

This is ALMOST what I'm after! Finally... you must be about at the point where you log in to L&L and groan, "Oh, no... ANOTHER post from HER! But I do profoundly thank you for the amount of time you've put in to helping me with this!

I plan to go through and make myself a step-by-step with screen shots for future reference.

Is there a way to put a bookmark at the start of each Chapter for ease of navigation in the Word document?
-- Marilynx

User avatar
robertdguthrie
Posts: 3075
Joined: Mon Nov 09, 2009 10:06 pm
Platform: Mac
Location: St. Louis, MO, USA
Contact:

Tue Dec 16, 2014 8:41 pm Post

Marilynx wrote:I note that there does not appear to be a way to change the size of the font for "Chapter One" to something slightly larger than the title? (Not that it would be hard to go through and reformat it in Word, but if I don't HAVE to....)

Actually, it's so simple and straight-forward, that it seems impossible. Seriously. In the formatting pane, click on the appropriate row (I'm assuming at this stage it's the Level 1+ document row). Click on the "CHAPTER ONE" sample text in the text area below that. Click on the blue slanted "A". Choose your font size (and a different font if you prefer). Similarly, you can alter how the Title text is formatted by clicking on it and then the "A".

Marilynx wrote:This is ALMOST what I'm after! Finally... you must be about at the point where you log in to L&L and groan, "Oh, no... ANOTHER post from HER! But I do profoundly thank you for the amount of time you've put in to helping me with this!

I'm glad we're getting it sorted out. If I were solely a Windows Scriv user, I would more likely stop "helping" so much and let the real experts chime in. But no matter the circuitous route to the solution, all's well that ends well. :?

Marilynx wrote:I plan to go through and make myself a step-by-step with screen shots for future reference.

Is there a way to put a bookmark at the start of each Chapter for ease of navigation in the Word document?


I'm not so sure about bookmarks... I mean, you can do a CTRL-F and search for CHAPTER, and then subsequently hit the F3 key to repeat the search. You can create a clickable table of contents though, if that's of use to you. To do that create a file into which you'll paste the ToC. Then select all the documents in your Draft folder, and go to Edit->Copy Special->Copy Documents as ToC. Then go to your empty document and paste that in.

Beyond that... I don't know Word very well, but I've seen people mention that you can search for text formatted a particular way (say 18 point comic sans) and automatically apply a Word text style. With that in mind, I think you can make Word auto-generate a ToC that is available no matter where you are in the document. :?: If that's possible, then the in-Scrivener ToC generation may not be necessary.
Last edited by robertdguthrie on Thu Dec 18, 2014 9:41 pm, edited 1 time in total.
Often wrong, rarely in doubt.
Time for a change... I'm now rdale; same dog-avatar, same dog... channel?

User avatar
MimeticMouton
Posts: 9007
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Tue Dec 16, 2014 11:24 pm Post

The default compile settings should have RTF bookmarks enabled, so you may already have this set for the start of each document. In the Formatting pane of Scrivener's compile, you'll see a checkbox just above the format bar to "Include in RTF bookmarks". You can set this for each row in the table above, so e.g. you could turn it on for folders but leave it off for single text files. In your case, if I skimmed correctly, each text file in the binder is a separate chapter, so you'd want this on for the text documents, and it's probably already enabled. The bookmark should use the document's title when you view the list in Word.

RTF bookmarks are supported when compiling to RTF, to PDF, DOC and DOCX using the Microsoft Office converters, and to DOC using the RTF-Based converters. You can set which converters are used in the Import/Export tab of Tools > Options by clicking "Export Converters", then choosing the format from the left drop-down menu and the converter from the options in the right drop-down.
Jennifer Hughes
(MM for short)

User avatar
Marilynx
Posts: 180
Joined: Mon Oct 31, 2011 10:26 pm
Platform: Windows

Wed Dec 17, 2014 5:11 am Post

robertdguthrie wrote: Actually, it's so simple and straight-forward, that it seems impossible. Seriously. In the formatting pane, click on the appropriate row (I'm assuming at this stage it's the Level 1+ document row). Click on the "CHAPTER ONE" sample text in the text area below that. Click on the blue slanted "A". Choose your font size (and a different font if you prefer). Similarly, you can alter how the Title text is formatted by clicking on it and then the "A".


D-uuuh! The problem is that I did SEE the A, but when I clicked on it, nothing happened. It was inactive. Because I didn't have any text selected.

My method of working in Word is to select the formatting I want, and then apply it to the text, rather than blocking the text first, although it can be done either way. It never occurred to me that the control would be inactive without text selected to apply it to.

I'm glad we're getting it sorted out. If I were solely a Windows Scriv user, I would more likely stop "helping" so much and let the real experts chime in. But no matter the circuitous route to the solution, all's well that ends well. :?


As long as we get there in the end. Like I said, I intend to make myself a guide from all this and then see if I can duplicate, step by step, the formatting of another project, AND getting a .mobi file out of it as well.

I'm not so sure about bookmarks... I mean, you can do a CTRL-F and search for CHAPTER, and then subsequently hit the F3 key to repeat the search. You can create a clickable table of contents though, if that's of use to you. To do that create a file into which you'll paste the ToC. Then select all the documents in your Draft folder, and go to Edit->Copy Special->Copy Documents as ToC. Then go to your empty document and paste that in.


Erm, okay... I'm half asleep at the moment. I think I'll try that one when I'm more awake. I had a Beagle and a Dachshund hunting (I think) an opossum at four ye ghods ay em this morning... not wishing to wake the neighbors, I had to get dressed and go out and haul the noisy pair in and shut the critter door.

Beyond that... I don't know Word very well, but I've seen people mention that you can search for text formatted a particular way (say 18 point comic sans) and automatically apply a Word text style. With that in mind, I think you can make Word auto-generate a ToC that is available no matter where you are in the document. :?: If that's possible, then the in-Scrivener ToC generation may not be necessary.


Well, MM has stepped in with a comment, and I checked, and the book marks are already there, so, no worries!

I've been a Word user now for twenty years. Before than, it was WordStar. I've done things with both in terms of formatting and output that the creators of the programs thought wasn't possible. But oddly, an automated ToC wasn't one of the things I ever did.

I will still have to do some tinkering with the formatting if I decide to go with Smashwords to publish an ebook of any of several items, as they have a specific format required which calls for using styles. And of course, Scrivener isn't set up to output things with Word Styles.

I believe I'm correct that I can compile a single file or files as opposed to exporting them?

You've been extremely helpful, and I want to reiterate that I am truly appreciative of your time. It's especially amazing given that, from your comments, your primarily a Mac user.
-- Marilynx

User avatar
Marilynx
Posts: 180
Joined: Mon Oct 31, 2011 10:26 pm
Platform: Windows

Wed Dec 17, 2014 5:24 am Post

MimeticMouton wrote:The default compile settings should have RTF bookmarks enabled, so you may already have this set for the start of each document. In the Formatting pane of Scrivener's compile, you'll see a checkbox just above the format bar to "Include in RTF bookmarks". You can set this for each row in the table above, so e.g. you could turn it on for folders but leave it off for single text files. In your case, if I skimmed correctly, each text file in the binder is a separate chapter, so you'd want this on for the text documents, and it's probably already enabled. The bookmark should use the document's title when you view the list in Word.

RTF bookmarks are supported when compiling to RTF, to PDF, DOC and DOCX using the Microsoft Office converters, and to DOC using the RTF-Based converters. You can set which converters are used in the Import/Export tab of Tools > Options by clicking "Export Converters", then choosing the format from the left drop-down menu and the converter from the options in the right drop-down.


Yes! They are there! This is another "D-uuuhh!" in that I didn't even LOOK for the bookmarks. I just assumed they weren't there, and I should know better than that when dealing with Scrivener. It has so many cool features and capabilities, and I know I'm barely scraping the surface with it.

It's just that the way Scrivener achieves something, and the way Word does it are typical of the two different mindsets of the respective programmers / companies -- different philosophies, different methods of working.

I worked with WordStar under CP/M and then DOS for ten years, then Word 6 for nearly ten years, and I've been using Word XP for 12. It's taking me a little bit to rattle the habits of thought out of their accustomed ruts and get on with something new.
-- Marilynx

User avatar
Marilynx
Posts: 180
Joined: Mon Oct 31, 2011 10:26 pm
Platform: Windows

Wed Dec 17, 2014 6:45 pm Post

robertdguthrie wrote: I'm not so sure about bookmarks... I mean, you can do a CTRL-F and search for CHAPTER, and then subsequently hit the F3 key to repeat the search. You can create a clickable table of contents though, if that's of use to you. To do that create a file into which you'll paste the ToC. Then select all the documents in your Draft folder, and go to Edit->Copy Special->Copy Documents as ToC. Then go to your empty document and paste that in.


Okay, I decided to try this on this bright, chilly morning.

I created a blank document just as you said. (I keep looking for that under "Documents" and not under "Project," although if I could just remember Ctrl+N, I wouldn't have to remember that New Document isn't under Documents at all.

Since ToCs are usually (except in E-books) at the beginning of the book, I put it in the Front Matter Folder after the Title Page.

It came out as shown in the first clip below -- I found and fixed the problem there, as I had not clicked Page Break Before for that text document.

ScrivenerCompile_2014-12-17b.JPG
ScrivenerCompile_2014-12-17b.JPG (24.32 KiB) Viewed 1359 times


But the ToC is now labeled as Chapter One, and the real Chapter One is now Chapter Two, and so on. My Binder currently looks like this second clip.

ScrivenerCompile_2014-12-17a.JPG
ScrivenerCompile_2014-12-17a.JPG (37.07 KiB) Viewed 1359 times


I'm assuming I've missed yet another item?
-- Marilynx

User avatar
robertdguthrie
Posts: 3075
Joined: Mon Nov 09, 2009 10:06 pm
Platform: Mac
Location: St. Louis, MO, USA
Contact:

Thu Dec 18, 2014 8:42 pm Post

Click the "As-Is" checkbox for your ToC document. That suppresses the addition of stuff like titles and title prefixes (the CHAPTER ONE bit).
Often wrong, rarely in doubt.
Time for a change... I'm now rdale; same dog-avatar, same dog... channel?

User avatar
Marilynx
Posts: 180
Joined: Mon Oct 31, 2011 10:26 pm
Platform: Windows

Thu Dec 18, 2014 8:57 pm Post

robertdguthrie wrote:Click the "As-Is" checkbox for your ToC document. That suppresses the addition of stuff like titles and title prefixes (the CHAPTER ONE bit).


Argh. That's a "Well, duh!" yet again.

This one came out better, except that the page numbers run off the edge of the page.

ScrivenerCompile_2014-12-18a.JPG
ScrivenerCompile_2014-12-18a.JPG (64.56 KiB) Viewed 1328 times


I tried setting the right hand side of the text to 4.1" which would be the width of the text on the paper between the margins, and that did not help.
-- Marilynx

User avatar
robertdguthrie
Posts: 3075
Joined: Mon Nov 09, 2009 10:06 pm
Platform: Mac
Location: St. Louis, MO, USA
Contact:

Thu Dec 18, 2014 9:52 pm Post

This... I'm not so certain about. You could edit the ToC so that the font is smaller, or it has fewer dots between chapter name and the page number... So much for whiz-bang-easy-peazy, eh? :? I think this is an opportunity for the developers to make an enhancement; tailor the width of the auto-generated ToC to fit the page settings.

Do note that the ruler settings in Scrivener start (on the left) reletive to the margins on the output. So the zero mark in the margins is zero + whatever the left margin is in the Page Settings tab. I think the right indent in Scrivener is also like that. You probably want to calculate how many inches of space you have between the margins, use that as a guide to how wide your ToC ends up.

Another hint: If you added a chapter in there somewhere, the ToC page wouldn't update itself, so this feature is only really useful for after you've done all your final edits, and have settled on chapter titles (if you're using them), etc...
Often wrong, rarely in doubt.
Time for a change... I'm now rdale; same dog-avatar, same dog... channel?

User avatar
Marilynx
Posts: 180
Joined: Mon Oct 31, 2011 10:26 pm
Platform: Windows

Fri Dec 19, 2014 3:40 am Post

robertdguthrie wrote:This... I'm not so certain about. You could edit the ToC so that the font is smaller, or it has fewer dots between chapter name and the page number... So much for whiz-bang-easy-peazy, eh? :? I think this is an opportunity for the developers to make an enhancement; tailor the width of the auto-generated ToC to fit the page settings.


Tried editing the ToC. THe dots are one "character," if you will, and if I place the cursor directly to the left of the code for the page number and do a single back space, ALL the dots disappear.

In Word, I would set a tab to the point at which I wanted the page numbers to appear, and then tab to that point for the page number.

Now, I've been tinkering with this, and, in point of fact, in the Compiled document, if I select the ToC itself, and set the second tab to 4.1", I have the page number area on the page. Similarly, I was able to reposition the "Table of Contents" header which is actually part of the page.

But take a look at the clip here from the document: the page numbers are all "3" or "2". They did not auto update in the Compile. Is that a result of having the ToC at the beginning of the file, rather than at the end as seems to be done in e-books?

And, the first one I edited lost the dots, but the others did not, and, in fact, have TWO sets of dots.

ScrivenerCompile_2014-12-18c.JPG
ScrivenerCompile_2014-12-18c.JPG (34.3 KiB) Viewed 1314 times


Do note that the ruler settings in Scrivener start (on the left) relative to the margins on the output. So the zero mark in the margins is zero + whatever the left margin is in the Page Settings tab. I think the right indent in Scrivener is also like that. You probably want to calculate how many inches of space you have between the margins, use that as a guide to how wide your ToC ends up.


Right. It will be 4.1" You just confirmed what I thought it might be. My page is 5.5" wide, and the margins are each .7" for 1.4" of margins, leaving 4.1" for the text.

Another hint: If you added a chapter in there somewhere, the ToC page wouldn't update itself, so this feature is only really useful for after you've done all your final edits, and have settled on chapter titles (if you're using them), etc...


I did figure that part out -- that if I edited in Scrivener and rearranged the Chapters, or added or subtracted a Chapter here or there, it would be necessary to re-do the generation of the ToC.

I was thinking that what I needed to do was to set the formatting of the Scrivener page to 0 and 4.1 for that page. I tested it, and got the same off-the-page numbers.

Bug? Feature? Not sure... this is kind of weird.
-- Marilynx

User avatar
Marilynx
Posts: 180
Joined: Mon Oct 31, 2011 10:26 pm
Platform: Windows

Fri Dec 19, 2014 4:59 am Post

Addendum: I experimented with moving the ToC up to the end of the Draft to see if it affected the pagination. It did not. All Chapters still generate 2 or mostly 3.

The attached clip shows the ToC in Word after I went in and added a tab stop at 4.1". THat immediately brought the page numbers back onto the page.

The Word dialog shown is the formatting on title. Take a look at the right hand indentation. Scrivener set it to -2.4", but if I change that to 0, the ToC header will be properly centered on the 5.5" wide page with .7 margins.

ScrivenerCompile_2014-12-18d.JPG
ScrivenerCompile_2014-12-18d.JPG (110.13 KiB) Viewed 1312 times
-- Marilynx

User avatar
robertdguthrie
Posts: 3075
Joined: Mon Nov 09, 2009 10:06 pm
Platform: Mac
Location: St. Louis, MO, USA
Contact:

Fri Dec 19, 2014 5:28 pm Post

Now I'm really at a loss. I'm afraid this stuff is so far outside my wheelhouse that it's treading water. :| Maybe someone else can chime in?

Good luck!
Often wrong, rarely in doubt.
Time for a change... I'm now rdale; same dog-avatar, same dog... channel?

User avatar
Marilynx
Posts: 180
Joined: Mon Oct 31, 2011 10:26 pm
Platform: Windows

Fri Dec 19, 2014 7:04 pm Post

robertdguthrie wrote:Now I'm really at a loss. I'm afraid this stuff is so far outside my wheelhouse that it's treading water. :| Maybe someone else can chime in?

Good luck!


OK! At least it doesn't seem to be me missing the obvious which has happened several times already.

And I do thank you once again for all your time. I have learned quite a bit during the course of the thread. I even managed to get MOST of a decent compile out of another Project, although I have to go back over the notes and figure out what I did wrong!
-- Marilynx