How to turn OFF full justification?

da
dallmon
Posts: 3
Joined: Sat Jun 14, 2014 9:40 pm
Platform: Windows

Sat Jun 14, 2014 9:57 pm Post

I've found several threads about Kindle justification, and several threads with people asking how to turn ON full justification, but none explaining how to turn it OFF.

Any time I try to Compile to Standard Manuscript Format using just default settings, the resulting document ends up fully justified. There seems to be no way to change this justification, not within Scrivener or within another word processor.

For example, if I compile a ms then open it in MS Word, the document will be full justified even though it shows in the formatting toolbar as left justified. Selecting some other justification, then going back to left does nothing. In fact, justification settings seem completely broken.

In Scrivener, going into the Compile -> Formatting -> Level/Text settings (the solution presented for other similar problems) seems to have no effect either.

Does anyone know a solution to this? I'm using version 1.7.1.0 for Windows.

Thanks in advance!

Br
Briar Kit
Posts: 1787
Joined: Thu Apr 04, 2013 9:04 am
Platform: Mac

Sun Jun 15, 2014 8:55 am Post

Controlled by Kindle...not Scrivener?

Forced justification: The text of all Kindle books is “force justified,” meaning that with the exception of the last line of a paragraph, all the words that fit on a line spread out so that the rightmost letter of the rightmost word sits exactly on the right margin, creating a solid cylinder of text.

Some people love justified text. I hate it, especially on computer-based text displays with either no hyphenation or hyphenation controlled by software. Inevitably books end up with lines where the words just don’t fit right, and a force-justified line suffers from giant gaps between the words. It drives me crazy, and I have no way to turn it off.


http://www.techhive.com/article/2010924 ... crazy.html
Account closed January 2017

da
dallmon
Posts: 3
Joined: Sat Jun 14, 2014 9:40 pm
Platform: Windows

Sun Jun 15, 2014 3:50 pm Post

Sorry, I wasn't clear. I'm trying to Compile to an .rtf or .docx using the Standard Manuscript Format settings. That should have nothing to do with Kindles.

I have found that if I create a new blank .rtf in MS Word, then copy and paste "text only" from the Scrivener file into the new .rtf, the problem is fixed. Guess that's a workaround at least.

User avatar
MimeticMouton
Posts: 9046
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Wed Jul 30, 2014 3:09 am Post

This is an issue with how Word is interpreting the RTF tags in the compiled document. We're investigating what changes we can make in the RTF encoding to work around this problem with Word without negative effects in other word processors (or invalid RTF!). Meanwhile, if you compile to RTF and re-save in Word as a DOCX file, that should correct it. You could also compile in DOCX format directly using the "Scrivener" converter. Set this in the Import/Export tab of Tools > Options by clicking the "Export Converters..." button and choosing "DOCX" in the left drop-down menu and "Scrivener" in the right.
Jennifer Hughes
(MM for short)

Bi
BillAltmann
Posts: 1
Joined: Thu Feb 11, 2021 8:36 am
Platform: Mac

Wed Mar 31, 2021 4:19 pm Post

I am using Scrivener 3.2.2 on MacOS.
I am compiling a document for paperback, trying to output a PDF file.
No matter what I do, I cannot turn off the full-justify text in the body paragraphs of my book.
I have checked the paragraph styles, and the layouts used in compile.

Please tell me that the problem reported in 2014 and earlier has been fixed.

br
brookter
Posts: 2301
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Thu Apr 01, 2021 6:39 am Post

The process is:

1. In compile, right click on the format (Modern etc) and choose 'Duplicate and Edit'
2. Save so you're back at the starting compilation screen.
3. In your duplicated format assign the relevant Section Type to the Section Layout in the normal way
4. Click on the little pencil to edit that Section Layout
5. Click on 'override text and formatting
6. Click on the 'left align' icon in the dummy text tool bar.
7. Click Save (or Test).

You'll tell if it's worked by the look of the Section Layout in the starting compilation dialogue.

Before:
Screenshot 2021-04-01 at 07.47.04.png
Screenshot 2021-04-01 at 07.47.04.png (400.2 KiB) Viewed 132 times


Section Layout panel:
Screenshot 2021-04-01 at 07.45.27.png
Screenshot 2021-04-01 at 07.45.27.png (423.38 KiB) Viewed 132 times


After:
Screenshot 2021-04-01 at 07.47.43.png
Screenshot 2021-04-01 at 07.47.43.png (395.76 KiB) Viewed 132 times




As usual, writing out the steps makes it look far more complicated to describe than it is to do — it should only take a few seconds in practice.

That should be all you have to do if you've followed the recommended practice of not assigning a style to standard paragraphs in your text (ie. they're all "No Style").

If you have assigned your own style to these paragraphs (and there's really no need to do so), then that complicates matter a bit. I think you may need to make the adjustment in the 'Styles' panel as well or instead (click on the left most icon in the formatting bar to select your style — you can edit it from there).

If you can't get it to work, perhaps you could explain your setup (styles, types, layouts) and the steps you've taken so far?

HTH.