Scriv importing - without hard returns

Br
Brevoort
Posts: 22
Joined: Sun Sep 04, 2011 3:02 pm
Platform: Windows

Fri May 16, 2014 11:47 pm Post

I have tried researching this issue in the manual, on-line, and in Scrivener for Dummies but I can't figure it out.

    When I export a document as RTF to be able to work on it in Word (to run a couple of grammar addins) I get as expected in Word, the same font size etc as the original, with soft-returns at the end of lines.

    When I Save-as from Word, in either RTF or DOC(X) and import to Scrivener I get a document that has hard returns at each EOL.

    I also get hard returns if I do a straight Ctrl-a (copy) in word and then paste into Scrivener. That has me puzzled because the Word version does not have hard-returns.

    If I Save-As in TXT, (any variety), I get soft returns on import to Scrivener but no preservation of font size etc.

So how do I do this? I want to get my Word files into Scrivener in the same font and size that they left Scrivener with, and with soft returns at the end of lines instead of hard-returns.

Is there a way in Scrivener to convert hard-returns? Or is there a way to import raw text and have Scrivener apply the default manuscript settings I have (font-size etc) with no hard returns except for paragraph markers of course?

(I am using the latest Beta but this has always been this way for me. Sorry if I have missed something obvious -- I would appreciate some advice.)
Rick Grant
Calgary
www.rickgrant.com

User avatar
MimeticMouton
Posts: 8874
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sat May 17, 2014 1:29 am Post

Are you actually seeing an additional return character at the end of every line, or are you basing this on the way the text is wrapping? My guess is that it's just a right-indent that's being copied/imported into the project from Word, so it's causing the lines to wrap differently. Try selecting the document in the binder and choosing Documents > Convert > Formatting to Default Text Style to apply the default settings from your Editor options. Italics, bold and other character formatting will be kept intact.
Jennifer Hughes
(MM for short)

Br
Brevoort
Posts: 22
Joined: Sun Sep 04, 2011 3:02 pm
Platform: Windows

Sat May 17, 2014 3:33 am Post

MimeticMouton wrote: Try selecting the document in the binder and choosing Documents > Convert > Formatting to Default Text Style to apply the default settings from your Editor options.


Thank you so much. In following your suggestion I discovered that a couple of days ago I had changed my default zoom levels and margins and some other stuff for another project and had forgotten to reload my normal preferences. That coupled with a recently upgraded and larger monitor, a press of urgent work, and general forgetfulness, caused me to think something much more serious was going on.

All is well, thank you again.
Rick Grant
Calgary
www.rickgrant.com