Problem with auto caps option in Turkish

oy
oymen
Posts: 4
Joined: Fri Jul 06, 2012 11:05 pm
Platform: Windows

Wed Feb 27, 2013 9:28 am Post

I write in Turkish and I use the auto caps (automatic uppercase) option in the script mode.

In Turkish lowercase i refers to İ and lowercase ı to I. However scrivener makes them both I.

I believe this happens because scrivener doesn't set any language properties (unlike MS word which doesn't have this problem) to the text and converts i only according to English language.

Is there a way to overcome this? Otherwise I cannot use the auto caps option which is very handy.

Regards
Oymen

Ay
Aycae
Posts: 50
Joined: Sat Nov 05, 2011 10:19 pm
Platform: Windows

Fri Mar 01, 2013 4:43 am Post

Merabaa :)

Check whether "Capitalize 'i'" checkbox is ticked, from "Tools > Options > Corrections" menu (or press F12) --under "Auto-Capitalization" heading. If it is ticked, then untick.

Türkçe arayüzde: "Araçlar > Seçenekler > Düzeltmeler" menüsünden 'Otomatik Büyük Harf' başlığındaki "'i' Büyük Harf' kutusu işaretliyse işareti kaldırın.

Edit: Sorry, what you mention is a totally different beast from what I understood; my bad. My trick doesn't work in Script Mode with Auto Capitalization, as indeed Scrivener capitalizes i with I and vice versa, which is a problem.

Ayca
Windows 7 x64 (main) -- Ubuntu 10.10 on VirtualBox + Mac OSX Leopard