Upgrade going to wrong file path, can't change

User avatar
L'escritora
Posts: 15
Joined: Wed May 30, 2012 2:36 pm
Platform: Windows

Mon Jun 18, 2012 7:20 pm Post

I have been attempting to upgrade to 1.2.1.0.

It keeps trying to install to a non-existent directory C:\Program Files\Scrivener_beta

I did have such a directory once, for betas 5 and 7, but I uninstalled it and deleted the left over folder. I then restarted my computer. In all of my upgrade attempts, I have only opened the official scrivener (C:\Program Files\Scrivener) and tried updating from within. Update still wants to install to the non-existent beta folder.

I tried moving the update file from the temp folder to the actual install folder of the official scrivener. Still wants to install to the non-existent beta. I finally let the install run, and that's when I discovered it will just make its own "Scrivener_Beta" directory since I don't have one.

So--is update 1.2.1.0 actually a beta?

Or is it screwed up?

Since I don't see a link on the website -- in the technical support page or as a sticky in the windows forum (did I miss it?) -- Where should I look for an official version? My official scrivener program led me to 1.2.1.0 when I told it to check for updates. Did it lead me astray?

User avatar
AmberV
Posts: 24893
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Jun 18, 2012 8:20 pm Post

Could you try with this direct download link? For future reference, the latest official version can always be downloaded from the main website---easiest way to do so is to use the link at the top-right of every single page.

It's an odd result, the betas do not install in a special location ordinarily. They install right over the main copy, so I'm not sure why it's acting funny like that, but I just ran the update myself a few hours ago and it went smoothly into the correct folder. So maybe it is a problem with the copy that gets downloaded with the update notification.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles