Page 1 of 2

Autosave question

Posted: Mon Jan 16, 2012 7:15 am
by StefanG
On the general tab of Options, the section "Saving" refers to autosaving (an educated guess?)
It will save after the specified period of inactivity ?!?

What does that mean? That saving won't occur when I need it most, when I am hacking away for long stretches, capturing the stream of my thoughts? I want it to save my work when I am active, not inactive. Is this a typo?

Re: Autosave question

Posted: Mon Jan 16, 2012 12:47 pm
by Spitfire
No, it is not a typo. Scrivener will save after periods of inactivity. I'm sure even during your most productive moments you pause for 2 seconds briefly to ponder something or reconsider your wording which is when Scrivener saves.

You'll see an asterisk appear at the top of the window at the end of your project name before disappearing. If you notice it that is.

Re: Autosave question

Posted: Mon Jan 16, 2012 1:48 pm
by StefanG
I don't want to save every time I pause for a second. Nor do I want having to remind myself of pausing regularly to trigger higher save settings. Why can't I just autosave the old-fashioned way:
"Autosave every xx minutes/seconds."

I am easy to convince of new ideas if I see their benefit. What is the advantage over the old method?

Re: Autosave question

Posted: Mon Jan 16, 2012 1:55 pm
by Spitfire
For me, the advantage over the old method is more frequent saves so my work has less chance of being lost than having to wait a specific amount of time between autosaves.

There is still the option to manually hit save every time you feel it's necessary if you don't prefer the autosave method as is.

Re: Autosave question

Posted: Mon Jan 16, 2012 2:42 pm
by StefanG
Spitfire wrote:For me, the advantage over the old method is more frequent saves

But this is not true: Using your example of 2 seconds:
old method: Autosave every 2 seconds
Scrivener: Save if inactive for 2 seconds

Unless you force yourself to pause for 2 seconds every 2 seconds you will end up with fewer saves, not more :!:

Re: Autosave question

Posted: Mon Jan 16, 2012 2:52 pm
by pigfender
Yes, but you wouldn't set it to autosave every 2 seconds would you? You'd be taxing the processor constantly and waiting for little slow-downs mid sentance.

Basically, the Scriv option says,
Only bother to save if:
- I've actually made a change; AND
- saving won't cause me to slow down.

With a 2 second save selected you will are pretty unlikely to either notice the saving happen or to lose anything more than a sentance or two.

For example, I'm guessing you didn't actually notice the save process until you read about it in the manual?

Re: Autosave question

Posted: Mon Jan 16, 2012 3:09 pm
by StefanG
pigfender wrote:Yes, but you wouldn't set it to autosave every 2 seconds would you?

Of course not. Spitfender suggested it, I just used his example. I prefer much higher settings which is why I asked this qestion. If I have to take a break to wait for autosave to kick in, I rather hit Ctrl S myself. Not exactly my idea of autosave. I dropped the Ctrl S nuisance a long time ago thanks to an invention called Autosave.


pigfender wrote:I'm guessing you didn't actually notice the save process until you read about it in the manual?

Wrong. I was wondering if the accumulation of temp files could have anything to do with it. That's why I went into the dialog and tried to make sense of it.

Re: Autosave question

Posted: Mon Jan 16, 2012 3:11 pm
by Spitfire
Like pigfender says, the save process goes largely unnnoticed and that's where I prefer it instead of having to worry about if I had saved frequently enough after something catastrophic happened. There are plenty of times when I pause just long enough for Scrivener to save then continue on without even noticing it has.

The 2 second autosave is the default in Scrivener as far as I recall.

Re: Autosave question

Posted: Mon Jan 16, 2012 3:55 pm
by StefanG
Spitfire wrote:Like pigfender says, the save process goes largely unnnoticed and that's ...

Same with traditional autosave. Still waiting for one advantage of the new method. We're talking in circles here.

The setting of 2 seconds keeps my laptop fan blowing. Loud and noisy. I don't want this frequent saving. I want an occasional autosave every 10 minutes or so (provided something has changed, of course). This has always worked great for me.

If this is not possible, how do I switch off Autosave?

Re: Autosave question

Posted: Mon Jan 16, 2012 4:33 pm
by pigfender
Personally, I work on some pretty large files. A regular autosave on a lot of programmes really slows my machine down and wastes time. The Scriv method I really don't notice. Even on super huge files. Even when going full stream-of-consciousness style.

Sorry to hear you're having problems though. I'm surprised you are typing fast enough (ie without pauses) that you saves are including enough data to cause a spike that would require the fan to kick in. Assuming there is nothing else running on your machine to cause this heavy use, perhaps it might even be worth shortening the autosave time DOWN to only 1 second. That should mean that if you really are typing the quickly and continually that the program has more chance to save littel chunks often rather than having to play catch up when you do eventually come up for air.

I don't think it's possible to turn the autosave feature off, I'm afraid. I'm guessing it cuts down on the "I never saved my work but somehow it's your fault my work has gone missing" type technical support queries that the tema has to deal with.

Re: Autosave question

Posted: Mon Jan 16, 2012 6:36 pm
by StefanG
pigfender wrote:A regular autosave on a lot of programmes really slows my machine down

But that would not happen in Scrivener, since the saving process were the same. Even the frequency would stay roughly the same, if you chose an interval that matches your needs. My other programmes behave nicely. Even the autosave of a very demanding music software stays within the required latency to not disturb live recordings.
pigfender wrote:I'm surprised you are typing fast enough (ie without pauses) that you saves are including enough data to cause a spike that would require the fan to kick in.

I do not. I don't think anyone could type so fast as to cause data spikes. The memory of text is ridiculously low compared to movies or music. I blame frequency, because 10 minutes is a critical threshold with my other applications. Lower than that, and the fan kicks in. I wish I could try higher settings in Scrivener, but it won't let me enter more than 5 minutes.
pigfender wrote:Assuming there is nothing else running on your machine to cause this heavy use

Maybe it really has to do with the temp folder problem in Scrivener, it would explain it. Which is why I tried to increase autosave settings or turn it off.

Re: Autosave question

Posted: Mon Jan 16, 2012 11:33 pm
by Jaysen
Just a thought: is it possible that you are using one large file instead of several small files for your writing? The more traditional scriv use of many small files makes saving a trivial CPU/IO comparison issue. If you use large files you will see slow downs as compares and IO must block to flush.

Alternatively you could be looking at an issue where there are images embedded in the file you are editing and their relative position (at pos x now at posx+y) are requiring CPU and IO blocking. Solution: use separate file for those items and smaller text chunks.

I am not sure the large tmp file issue is a red herring or not. Try quitting scriv, cleaning temp, then starting over. If you see improvements then you have a possible code issue to report. If performance is the same I would suggest a simple evaluation of how you are utilizing the software for potential file/workflow optimization.

Just a thought.

Re: Autosave question

Posted: Tue Jan 17, 2012 10:58 am
by StefanG
Thanks Jaysen,

no images in my project, just 30 small documents, around 10,000 words in total, for testing purposes only. To rule out misunderstandings: I do NOT experience slowdowns. It's the noise that's unnerving me.

I think it's the frequency of autosaves in combination with my notebook. When I decrease the autosave value in other software from my present 10-15 minutes down to 1 minute, the noises also pick up.

Re: Autosave question

Posted: Tue Jan 17, 2012 2:26 pm
by jravan
I would suggest your best compromise of the moment is to set autosave to 300 seconds, the highest value the dialog accepts currently, and use CTRL-S instead.

Re: Autosave question

Posted: Tue Jan 17, 2012 2:45 pm
by StefanG
javran,
yes, I agree, and that's what I've been doing, except that I keep forgetting to Ctrl S. Not used to saving manually anymore after a decade of not doing it.

In my mind I still assume the 300 seconds are counting upwards from when I first hit a key.
It's very hard to think the other way round: That the seconds are constantly reset while I type and that saving won't occur unless I wait 5 minutes or hit Ctrl S myself.