Can I add a line feed after the header?

Ma
Major Major
Posts: 238
Joined: Tue Apr 30, 2013 7:52 pm
Platform: Windows
Location: Oakville, ON Canada

Tue Apr 30, 2013 7:56 pm Post

I'd like more space between the header and my body of text. Is there a way to do this? I didn't see anything appropriate in the placeholder tags list.

User avatar
MimeticMouton
Posts: 9046
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Wed May 01, 2013 1:55 am Post

In the Formatting tab of Compile, select the row for the document type and level that you want to change, then click the "Modify" button to the upper right of the preview area. There you can either select the title and adjust the line spacing to add some space after the paragraph (choose "More" from the drop-down menu to have options for before and after paragraph spacing) or you can click "Section Layout" and add a couple carriage returns to the title suffix area.
Jennifer Hughes
(MM for short)

Ma
Major Major
Posts: 238
Joined: Tue Apr 30, 2013 7:52 pm
Platform: Windows
Location: Oakville, ON Canada

Wed May 01, 2013 12:24 pm Post

Jennifer -

Thanks for the information. I can't seem to quite get it to work, however. The changes appear to be taking effect in the preview window, but when I do the actual compile, they don't show up. As an extreme test, I set the spacing after the tile to 48 points. That should create quite a gap, but it doesn't. If you like, I will send you the file and some screen shots.

Ma
Major Major
Posts: 238
Joined: Tue Apr 30, 2013 7:52 pm
Platform: Windows
Location: Oakville, ON Canada

Mon May 06, 2013 12:26 pm Post

Major Major wrote:Jennifer -

Thanks for the information. I can't seem to quite get it to work, however. The changes appear to be taking effect in the preview window, but when I do the actual compile, they don't show up. As an extreme test, I set the spacing after the tile to 48 points. That should create quite a gap, but it doesn't. If you like, I will send you the file and some screen shots.


Bump.

Is there no solution to this?

User avatar
MimeticMouton
Posts: 9046
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Wed May 08, 2013 8:05 am Post

Sorry for the delay. What format are you compiling to and what program are you using to view it? Have you double-checked that the row you modified in the compile formatting matches up with the document type and level of the documents you're trying to change in the binder? E.g. If this is an issue for single document texts, adjusting the spacing on the title in the folder row won't affect it. Assuming that's right, in the files you're compiling, is the space between the title and the text of the same document, or is the header coming from one file and the text from a different one?
Jennifer Hughes
(MM for short)

Ma
Major Major
Posts: 238
Joined: Tue Apr 30, 2013 7:52 pm
Platform: Windows
Location: Oakville, ON Canada

Mon Jun 03, 2013 10:49 pm Post

Jennifer -

Sorry for MY delay. I did not get notification of your reply.

I am a total newbie to Scrivener so I'm not quite sure what I'm doing, but here is what I've tried:

I go to compile, and click on the first row (Level 1+), then modify. I highlight TITLE, which is the first thing in the dialog box text (and shows up left justified even though it is actually right justified in the output file). Now, I am assuming this is what I'm calling the header - the thing that appears at the top right of each page and reads My Last Name | Story Title | Page number. Then, as a test, I've selected 50 points for the "after" spacing. But I still don't get any extra space between the header and the text. I've tried the same adjustment in the second row (which also says "Level 1+"), but in this row I've tried adjust the "before" spacing. Still no go. I'm sure I'm doing this wrong.

I am not sure what the last two sentences of your not means. This is a very simple Scrivener document that I began from the Short Story template. I am outputting to a pdf file and reading it with Adobe Reader.

Thanks for any help.

User avatar
MimeticMouton
Posts: 9046
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Tue Jun 04, 2013 8:39 am Post

Sorry, I completely misunderstood this one. I was talking about section titles, which often get called "headers" when people are asking about them, so that's my paltry excuse for not realizing you meant the actual document header. Ignore everything I said!

The short of it is, no, you can't add a blank line to the header or adjust the spacing or any such thing, but I do see what you're talking about--it's not sticking up in the header area like it should, so adjusting the margins isn't fixing this. What I'd do for now is compile to RTF or the like and open in Word or other word processor that supports headers, then save to PDF from there.
Jennifer Hughes
(MM for short)

Ma
Major Major
Posts: 238
Joined: Tue Apr 30, 2013 7:52 pm
Platform: Windows
Location: Oakville, ON Canada

Tue Jun 04, 2013 4:02 pm Post

Jennifer -

Thanks for your reply. Well, I guess I can use the work-around, but it's kind of a pain. This seems like a reasonably simple thing to add, so can I please ask that you consider including this feature in future releases?

User avatar
MimeticMouton
Posts: 9046
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Tue Jun 04, 2013 5:46 pm Post

Yes, I put it on the bug list after I posted here; sorry I wasn't clear about that!
Jennifer Hughes
(MM for short)

Ma
Major Major
Posts: 238
Joined: Tue Apr 30, 2013 7:52 pm
Platform: Windows
Location: Oakville, ON Canada

Tue Jun 04, 2013 6:14 pm Post

Thanks, Jennifer. Any ETA for a new release?

User avatar
MimeticMouton
Posts: 9046
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Tue Jun 04, 2013 6:32 pm Post

Not at the moment, no, and I can't promise then when this will get addressed--I'm not sure of the issues behind it, so I don't know what it will take to fix. Fingers crossed it's a couple simple tweaks!
Jennifer Hughes
(MM for short)

Ma
Major Major
Posts: 238
Joined: Tue Apr 30, 2013 7:52 pm
Platform: Windows
Location: Oakville, ON Canada

Tue Jun 04, 2013 7:42 pm Post

Okay. Thanks for your help.

User avatar
jrgarrigues
Posts: 13
Joined: Sun May 03, 2015 6:18 am
Platform: Mac + Windows

Sun Apr 11, 2021 2:41 am Post

@MajorMajor

I had the same question you did. Got around it by setting a "Replacement" in the Compile section that replaces <$blank> with a single space (e.g., " " - sans the double-quote marks). Then, in my header, I added a new line below the text and entered:

Code: Select all

<$name>
<$date>
<$blank>

User avatar
xiamenese
Posts: 4798
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Sun Apr 11, 2021 10:13 am Post

jrgarrigues wrote:@MajorMajor

I had the same question you did. Got around it by setting a "Replacement" in the Compile section that replaces <$blank> with a single space (e.g., " " - sans the double-quote marks). Then, in my header, I added a new line below the text and entered:

Code: Select all

<$name>
<$date>
<$blank>

Only 8 years too late! :lol:

Mark
The Scrivenato sometimes known as Mr X.
M1 MacBook Air (2021), 11.3, 16GB RAM, !TB SSID
iMac 27" (late 2015) 11.3, 24GB RAM, 512GB SSID
2017 iPad, iPadOS 14.5 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

User avatar
jrgarrigues
Posts: 13
Joined: Sun May 03, 2015 6:18 am
Platform: Mac + Windows

Sun Apr 18, 2021 6:18 am Post

xiamenese wrote:Only 8 years too late! :lol:

Mark


So true, but at least now there will be more options for the next 8 years! :wink: