Scrivener 2.0 wonderful, but a little slow

ro
rochefore
Posts: 152
Joined: Sun Sep 24, 2006 11:33 am
Location: Germany

Tue Nov 02, 2010 7:36 am Post

Wonderful work Keith. Just fantastic. Gladly paid the 20 odd Euros.

There is one thing though that I feel you should know. When I type there is a slight lag between hitting the key and the screen reaction.

I write on a MacBook with 2.2 GHz and 2 GB ram.

I never had this problem with Scrivener 1.5.

Best,
R.

User avatar
Jenny_Y8S
Posts: 189
Joined: Tue Jun 01, 2010 7:49 pm
Platform: Mac
Location: Surrey

Tue Nov 02, 2010 9:24 am Post

Strangely this was an occasional issue with 1.x on Snow Leopard (For me it only occured on files with 1k+ (ish) words in them, and then could be solved with an application restart).

I've had no such slowdowns with S2.

What OS are you using? Is it fully up to date?
Feed me chocolate, I'm developing Scrivener for iOS.

ro
rochefore
Posts: 152
Joined: Sun Sep 24, 2006 11:33 am
Location: Germany

Tue Nov 02, 2010 9:54 am Post

I am using 10.5.8 (Leopard).

User avatar
KB
Site Admin
Posts: 20718
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Nov 02, 2010 10:24 am Post

It should be a lot faster on 2.0 - I spent a month optimising the code and all beta-testers have reported the known slowdown issues on 1.x as gone, so I think something else may be going on here.

Have you tried restarting Scrivener?

Is your project located on your hard drive or on some external storage?

Is anything getting reported on the Console as you type (~/Applications/Utilities/Console.app)?

What are the specifics? Are you typing in full screen, Edit Scrivenings, in a long document, a short document, what are your preferences, what happens if you revert to the default preferences? Do you have "highlight current line" or block cursors turned on? If so what happens when you turn them off?

Do you have lots of underlining in the file, or lots of links? Is this affecting every text document in your project or just one? What about other projects?

Thanks,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

ro
rochefore
Posts: 152
Joined: Sun Sep 24, 2006 11:33 am
Location: Germany

Tue Nov 02, 2010 7:03 pm Post

Have you tried restarting Scrivener?

Yes. Several times.

Is your project located on your hard drive or on some external storage?

On hard drive.

Is anything getting reported on the Console as you type (~/Applications/Utilities/Console.app)?

As far as I can tell - no.

What are the specifics? Are you typing in full screen, Edit Scrivenings, in a long document, a short document, what are your preferences, what happens if you revert to the default preferences? Do you have "highlight current line" or block cursors turned on? If so what happens when you turn them off?

It happens even when I create a brand new project that has no prior text or media files or anything in it. I start a new, empty project - I start typing..and there it is immediately, a slight lag. I double checked with Pages: There is none.

ro
rochefore
Posts: 152
Joined: Sun Sep 24, 2006 11:33 am
Location: Germany

Tue Nov 02, 2010 7:07 pm Post

I turned off all other apps - to no avail.

User avatar
KB
Site Admin
Posts: 20718
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Nov 02, 2010 7:19 pm Post

If this is happening in a brand new document with very little text in it, then something is definitely going wrong on your system.

Try trashing the preferences file from ~/Library/Application Support/com.literatureandlatte.scrivener2.plist.

If that doesn't help, try creating a new user account on your machine and test to see if the problem occurs there.

Also try disabling any third-party tools that might intercept typing.

Thanks,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

ro
rochefore
Posts: 152
Joined: Sun Sep 24, 2006 11:33 am
Location: Germany

Tue Nov 02, 2010 7:54 pm Post

If that doesn't help, try creating a new user account on your machine and test to see if the problem occurs there.


This did the trick. So, yes, it seems to be a problem of my computer. What do I do? Thanks for your help.

User avatar
KB
Site Admin
Posts: 20718
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Nov 02, 2010 9:38 pm Post

The first thing to do is to go through your preference panes in System Preferences and turn them all off. If that fixes it, turn them all back on again, one by one, checking each time.

Also try disabling all your startup login items in your user account in the system preferences, and log out and back in again.

Thanks,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

Wa
WafflesNewton
Posts: 1
Joined: Thu Nov 04, 2010 12:37 am
Platform: Mac

Thu Nov 04, 2010 12:47 am Post

This may not help the specific case of the OP, but it is related to this thread and may be useful to someone. I have experienced typing lag in Scrivener 1.x and in the 2.0 NaNo preview version that I was able to trace to Spell Catcher. The lag occurred off and on when using Spell Catcher's 64-bit input method application. Switching to the old input method component for Scrivener solved the lag problem for me. In Spell Catcher's preferences, add Scrivener to the application list, select the Typing tab, then check the box beside "Use input method component in this application where possible."

User avatar
KB
Site Admin
Posts: 20718
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu Nov 04, 2010 1:04 am Post

Thanks for the info! I wonder if there's a conflict because Scrivener isn't 64-bit yet? (Going 64-bit is on the list to do for one of the free 2.0 updates, around 2.2-ish.)
Thanks again,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

ro
rochefore
Posts: 152
Joined: Sun Sep 24, 2006 11:33 am
Location: Germany

Thu Nov 04, 2010 4:03 am Post

The first thing to do is to go through your preference panes in System Preferences and turn them all off. If that fixes it, turn them all back on again, one by one, checking each time.


I did this. Did not change anything.

Also try disabling all your startup login items in your user account in the system preferences, and log out and back in again.


Ditto.

But then I discovered a strange thing. I downloaded the NaNo 2010 version (which I had downloaded before but then deleted after downloading the "regular" 2.0 Scrivener) - and lo and behold there was no typing lag. I started up the regular 2.0 Scrivener, klicked "Defaults" in "Scrivener Preferences" and the lag was almost completely gone.

I have gone back and forth now between the two Scriveners, writing in the same project and I am very sure now:
NaNo 2010 has no lag whatsoever, Scrivener 2.0 has a slight "un-smootheness" to it when typing which is a bit annoying nonetheless.

That said, let me repeat that you have done tremendous and wonderful work.


Best,

r.

User avatar
KB
Site Admin
Posts: 20718
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu Nov 04, 2010 10:10 am Post

Hi,

Something else must be at work, because there have been absolutely no changes between the NaNo version and the release version that would have affected this. The only changes I made between the NaNo version and release version were tweaks to the Compile settings and script formatting settings, while I finished off the templates - I didn't have time to do anything else. (Are you using script formatting?)

Thanks,
Keith

P.S. Are you on Snow Leopard?
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

ro
rochefore
Posts: 152
Joined: Sun Sep 24, 2006 11:33 am
Location: Germany

Thu Nov 04, 2010 10:17 am Post

I am on Leopard (10.5.8). No script formatting.
Just "Blank" as template.

To make sure I wasn't imagining things I opened both Scriveners, created new and empty projects, typed into both the very same text, and yes: One was "un-smooth" (Scrivener 2.0), the other very responsive (Nano 2010).

I have switched to the NaNo-Version for my writing. I have yet to check if it accepts my new serial number (I already paid for the regular Scrivener 2.0 update).



R.

User avatar
KB
Site Admin
Posts: 20718
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu Nov 04, 2010 10:26 am Post

It won't accept your serial number. I'm not belying your experience, but I have just gone through and compared every change I made since the NaNo version, and absolutely no changes were made to the typing or text system in the past week. So as I say, there must be something else strange at work - especially as it works fine in another user account, too.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."