Ellipses preference odd behavior (2.0b)

User avatar
KB
Site Admin
Posts: 20920
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Fri Nov 05, 2010 9:41 am Post

Hmm, no one has any feelings on this one then?
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

Wi
William
Posts: 135
Joined: Wed May 20, 2009 4:56 pm
Platform: Mac
Location: New Zealand

Fri Nov 05, 2010 1:07 pm Post

Option two sounds good to me - although someone is probably going to get confused and frustrated at some point, trying to paste an ellipsis over three dots! (Maybe a warning message as well?)

cheers
w
The worst are filled with passionate intensity while the best lack all conviction

User avatar
KB
Site Admin
Posts: 20920
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Fri Nov 05, 2010 1:39 pm Post

So you want a warning message every time Scrivener refuses to allow the system preferences to create an ellipsis - that is, every time you type one? :)
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

Wi
William
Posts: 135
Joined: Wed May 20, 2009 4:56 pm
Platform: Mac
Location: New Zealand

Fri Nov 05, 2010 1:43 pm Post

Let me see, er... now that you put it that way... I think that would probably be a "no" on that one. :shock: Maybe just a warning in the manual !

w
The worst are filled with passionate intensity while the best lack all conviction

User avatar
Script-O-Matic
Posts: 29
Joined: Sun Jul 25, 2010 7:04 pm
Location: San Francisco

Fri Nov 05, 2010 9:50 pm Post

KB wrote:2) Block ellipses from replacing three periods altogether...

If what you mean is block ellipses in Script Mode, I would think that's the best solution. I say that based on my understanding that standard screenplay formatting does not use ellipses, and always uses three periods. I would think someone like Sean Coffee, with more industry experience than I, could confirm this solution with more confidence. Perhaps he will chime in soon?

rv
rvdparis
Posts: 64
Joined: Fri Mar 09, 2007 12:47 am
Location: France

Sun Nov 14, 2010 2:35 pm Post

Keith would you clarify the recommended settings for automatic em-dashes?

As I understand it, you can EITHER set the double hyphen as em-dash in System Preferences/Language and Text/Text AND/OR you can set it in Scrivener. What's the best practice?

Right now, I have System Preferences em-dash OFF and Scrivener em-dash ON.

And despite what an earlier poster has claimed, I cannot get the em-dash to appear UNLESS I TYPE A SPACE after it...and the em-dash is never surrounded by spaces in correct usage. I can go to somewhere in a text and type a double hyphen and nothing will happen until I go somewhere else and hit a space. Yet when I type a double hyphen and then a word after it, an em-dash appears after some moments.

My main concern is if I revise a text by inserting em-dashes, that they won't "take" when compiling my draft.

User avatar
KB
Site Admin
Posts: 20920
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Nov 15, 2010 9:19 am Post

You don't need to type a space - any letter will do. It works the same as in other Apple applications (it is Apple's code, in fact).
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
AmberV
Posts: 24669
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Nov 15, 2010 5:38 pm Post

It doesn't even have to be a letter. It's anything. Type two hyphens and hit return--

By the way, it's a moot point, but spaced em-dashes are used in some style systems. I grew up with no spaces, but there are plenty of people who insist otherwise. :)

I'd love to put a warning in the manual, but haven't read the entire thread, could someone give me a simple summary of what the issue is? Is it just waiting for the typography to adjust?
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Ed
Eddy
Posts: 197
Joined: Wed Feb 03, 2010 8:00 pm
Platform: Mac
Location: Brighton, UK
Contact:

Mon Nov 15, 2010 5:52 pm Post

Script-O-Matic wrote:I un-selected the first four Substitutions in Auto-Correction Preferences, and tested them individually. When I turn smart quotes on, I get smart quotes while typing, when turned off, no smart quotes. When I turn em-dashes on, I get an em-dash while typing, when turned off, no em-dash. However, when I turn ellipses on and off, the result is always ellipses.
...

Now let me put this another way. If I un-select the first four Substitutions in Auto-Correction Preferences, there should now be no smart quotes, em-dashes, or ellipses created. I select Script Mode. When I type double quotes there are no smart quotes created. When I type a double hyphen there is no em-dash created, but when I type triple periods, ellipses are created (after hitting the space bar, followed by a brief pause). And if I turn Script Mode off, I get the same results.


I think this is the executive summary that describes the issue with brevity :)

Eddy
"Writerʼs block is just a symptom of feeling like you have nothing to say, combined with the rather weird idea that you SHOULD feel the need to say something." - Hugh MacLeod

User avatar
KB
Site Admin
Posts: 20920
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Nov 15, 2010 5:54 pm Post

Eddy wrote:I think this is the executive summary that sums it up :)


I think rvdparis was talking about something different - about how em-dashes get created.
Best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."