3.14 Issue with Editor position

User avatar
SarsenLintel
Posts: 458
Joined: Thu Jan 10, 2013 4:46 pm
Platform: Mac + iOS

Mon Oct 21, 2019 12:49 pm Post

Scriv 3.14 (12105)
Mac OS: 10.14.6

Since updating to 3.14*, the editor doesn't seem to realize that the ruler is on. This is most noticeable when using Go To | Next Document in a scrivenings session and the first line of the new document appears underneath the ruler.

Likely related - when using Text Editing | Show Line Numbers, normally there's a bit of padding between them and the text in the editor, now sometimes the text in the editor is jammed right up against the line numbers.

This:
Screen Shot 2019-10-21 at 8.43.24 AM.png
Screen Shot 2019-10-21 at 8.43.24 AM.png (264.25 KiB) Viewed 792 times


Instead of this:
Screen Shot 2019-10-21 at 8.45.36 AM.png
Screen Shot 2019-10-21 at 8.45.36 AM.png (267.17 KiB) Viewed 792 times




* Edit: I should probably mention that I also recently updated to 10.14.6 from 10.13.6, so maybe it's a Mojave thing.

User avatar
AmberV
Posts: 24331
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Oct 21, 2019 6:13 pm Post

Thanks, that does look to be specific to the Scrivenings scrolling mechanism. I’m not seeing that effect happen when navigating to documents individually.

As for the line numbering tool + margin/padding problem, yup, I spotted that one as well a while back and it is on the list to look into. It unfortunately looks like a tough one to nail down, so it might not get fixed in the very next bug update, but we’ll see.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
SarsenLintel
Posts: 458
Joined: Thu Jan 10, 2013 4:46 pm
Platform: Mac + iOS

Wed Oct 30, 2019 6:08 pm Post

If it helps, the line numbering thing might have something to do with the Inspector.

I hadn't seen it in days, but then today I accidentally toggled the inspector off and on (sometimes my fingers have a mind of their own). Then I started seeing it again.

As I was typing and neared the end of the line, the editor shifted to the left under the line numbers. I deleted the last character, toggled the inspector off and on and it would appear normal again, but the next character I typed would cause it to shift again.

Restarted Scriv, and the end of that line is nowhere near the edge, now in about the middle of the screen - Inspector off/on and the editor rewraps such that the end of the line is now back at the right edge.

For reference, I'm using scriv in a fairly small window (pretty much like the screenshot I posted earlier). I've got the binder and inspector turned on, and the editor is split horizontally with a media file playing in the top split, and the bottom editor in script mode.


Edit: also, when restarting a project it no longer starts up at the insertion point, but higher, in this particular document, it's about 14 paragraphs up.

User avatar
AmberV
Posts: 24331
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Wed Oct 30, 2019 6:59 pm Post

Checking my notes, it mainly has to do with compressing the width of the editor by any means, while the line numbering tool is enabled. You can reproduce this most simply by shrinking the window to the minimum width and then turning on line numbering, to see the problem immediately. So toggling the inspector would be a force that acts like narrowing the window does by hand.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
rdale
Posts: 2071
Joined: Tue Jul 14, 2015 1:07 pm
Platform: Mac, Win + iOS
Location: St. Louis, MO
Contact:

Wed Oct 30, 2019 9:02 pm Post

AmberV wrote:Thanks, that does look to be specific to the Scrivenings scrolling mechanism. I’m not seeing that effect happen when navigating to documents individually.

For me, it always happens when I have the ruler enabled, even for individual documents. I'm not sure what other factors may be at play, but I often have both binder and inspector open, plus (at minimum) either a split editor or copyholder open.

viewtopic.php?f=3&t=58543

EDIT: Perhaps I'm wrong about the individual documents; I just tried it out, and it only seems to be happening when the editor scrolls in Scrivenings mode, not when I'm loading individual documents. Maybe that was partly fixed since I posted my issue?

Also, maybe this has to do with displaying titles in Scrivenings mode, with the "Bookish" scrivenings separator playing a factor?
FKA: robertdguthrie
AKA: R Dale Guthrie, Robert, Mr. Obscure, and "Oh, it's you again".