3.1.3: Character styles no longer disable consistently

User avatar
llis
Posts: 7
Joined: Thu Dec 12, 2013 4:36 pm
Platform: Mac
Contact:

Sat Jun 29, 2019 1:49 pm Post

Bug

Conditions: Once a Character Style is in use, selecting the Character Style from the Styles menu no longer disables the Style.

Expected behavior: a Character Style can always be toggled on/off by selecting it from the Styles list.

Actual behavior: Enabling always works. Disabling the Character Style works if you have not typed anything using that Style. However, once you have started typing, you can no longer disable the Character Style by selecting it from the menu list—the toggling behavior no longer works.

For example: I can enable the Character Style and start typing in that Style. However, at the end of that word or sentence, disabling the Character Style by selecting the Style no longer works.

What still works: Toggling a Character Style on/off still works if you have not started typing with that Style. It also still works on selected text.

The only workaround has inconsistent effects:
The only way to disable a Character Style once you started using it is to select No Style. This disables the Character Style while leaving the Paragraph Style alone. However, if no Character Style is active, selecting No Style disables the Paragraph Style. Then you are chasing Styles around instead of writing.

I can't tell if this is related to this passage in the Release Notes:
Made improvements to the way styles are removed. Character styles can now be removed more easily when a paragraph style is present, and direct character formatting is no longer removed when resetting to “No Style”.

What's clear is that this update has introduced inconsistent UI behavior.

Impact:
From a writer's perspective, this is either a bug, or this update's changes have introduced UI functionality changes that result in inconsistencies I would call a UX bug of a semi-critical nature. (It's not a crash, but it makes writing aggravating to the point of being unusable.

This has killed my productivity because I use Character Styles in all my work—for example, to indicate a string of code, or a command, or a foreign term—and I have created several Mac OS X keyboard shortcuts to toggle these Character Styles.

Until this bug is fixed, my only choice is to roll back to 3.1.2.

User avatar
llis
Posts: 7
Joined: Thu Dec 12, 2013 4:36 pm
Platform: Mac
Contact:

Sat Jun 29, 2019 5:42 pm Post

I tried checking console, but it generates no scrivener-related log lines when I try to disable the Style by selecting it.