Text glitch in Binder after viewing imported Scapple Board

cl
clcampbell
Posts: 42
Joined: Mon Aug 06, 2012 11:37 am
Platform: Mac + iOS

Fri Feb 23, 2018 6:03 pm Post

1) Recently I imported a Scapple Board to a Scrivener 3.0.1 project. I did this by saving the Scapple file to my desktop, then dragging it into Scrivener into my Research section.

2) When I then click on a text file to return to writing/editing, the text in the Binder is much lighter than normal.

3) This is resolved by closing Scrivener and re-opening. So long as I don't click on the imported Scapple board, the text remains the same. Every time I click down on the Scapple board and return to a text file of the project, the text becomes lighter.

This isn't a major issue, but it is puzzling behaviour. There's no bold items in the Console.app, so I haven't copied any of that here. I'll attach before and after screenshots to show you the difference in text, between my normal setup and what it looks like after I've clicked on the imported Scapple board.

* This is unrelated, but I tried to access the forums by clicking on Help > User Forums, and Help > Support, but both opened a new Chrome window that directed to Google.
Attachments
Screen Shot 2018-02-23 at 6.01.34 pm.png
Screen Shot 2018-02-23 at 6.01.34 pm.png (154.65 KiB) Viewed 518 times

User avatar
KB
Site Admin
Posts: 19870
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Fri Feb 23, 2018 6:17 pm Post

Hi,

You said that the text in the binder was lighter than normal, but your screenshot seems to show text in the editor. Just to clarify, is it the text in the main editor that is getting lighter (I think it's the main editor in your screenshot - or is it the notes area of the Inspector)?

Thanks and all the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

cl
clcampbell
Posts: 42
Joined: Mon Aug 06, 2012 11:37 am
Platform: Mac + iOS

Fri Feb 23, 2018 6:23 pm Post

Sorry Keith. Yes, editor. I don't know why I typed binder! My brain is not switched on today...

User avatar
KB
Site Admin
Posts: 19870
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Fri Feb 23, 2018 8:47 pm Post

Thanks. I didn't see it at first because of the white background in my editor, but yes, I can reproduce this - very odd! I think the bug must be in Scapple's Quick Look generator (the editor shows a Quick Look preview when you click on a Scapple file), given that other files that show a Quick Look preview in the editor (such as OmniOutliner files) don't cause this problem. There must be something going on in Scapple's QL generator that is leaving drawing in an odd state. However, a quick look through the code doesn't reveal anything obvious - it just uses Apple's recommendations for drawing the preview - so this is going to take a bit of investigation!

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."