Outliner: Centered View, and Longer Synopsis Issues.

User avatar
ForgottenGold
Posts: 63
Joined: Mon Oct 07, 2013 6:08 pm
Platform: Mac + iOS

Mon Feb 19, 2018 5:04 pm Post

Scrivener 3.0 is a beast of awesomeness! I love it!

There is a couple little bugs I noticed though. If they aren't bugs and I'm just being stupid, let me know and I apologize!

- When you toggle the center view of the outliner, you get an option to click and drag and make the centered view wider, however when you leave centered view and go back it returns the centered view to its previous width.

- On synopses, the row stays at the height [EDIT: I do have fixed rows turned off.] it is when it's not being edited, but when it's being edited it adds more space between text lines and a good portion of the synopses disappears and the longer the synopsis the more disappears, but you can't scroll the text field, and of course if you hit the down arrow more than the right amount of times to get to the bottom you end up on the next document, not the one you intended to work on. I can't tell whether it's supposed to scroll, or the spacing between lines is a glitch. To my knowledge I didn't change any settings from default. I'm assuming the spacing between lines is a glitch, because when I click into the text field, the cursor is somewhere on an entirely different line than I clicked, but in the "right location" in relation to the text field itself. I hope that's enough detail. I can add a screenshot if that's helpful.

Thank you! Keep at the good work! Scrivener is the best. :D
Last edited by ForgottenGold on Fri Feb 23, 2018 7:06 pm, edited 2 times in total.

br
brookter
Posts: 1780
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Tue Feb 20, 2018 3:55 pm Post

On your two points:

The centred width does seem to return to the default — I don't know of any setting to prevent that, I'm afraid.

But on the second point: there are two ways of looking at the Synopsis in the Outliner: 'Normal' (it's not actually called that!) when the full synopsis is displayed, so the rows are all unequal heights, and 'Fixed Row Height', which as its name suggests, only shows a fixed number of lines, no matter how long the synopsis is, or whether there is a synopsis at all. (It's 3 lines, I think.)

Sounds like you've got the latter set — to turn it off, click View > Outliner Options > Use Fixed Row Height (it's a toggle).

HTH.

User avatar
ForgottenGold
Posts: 63
Joined: Mon Oct 07, 2013 6:08 pm
Platform: Mac + iOS

Fri Feb 23, 2018 6:44 pm Post

Thank you for the reply.

I do have the fixed rows turned off. It's only when my cursor is in the text fields does it mess up. The spacing between the lines gets bigger, but the text fields remain the same size as they were before clicking into them.

br
brookter
Posts: 1780
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Fri Feb 23, 2018 6:48 pm Post

ForgottenGold wrote:Thank you for the reply.

I do have the fixed rows turned off. It's only when my cursor is in the text fields does it mess up. The spacing between the lines gets bigger, but the text fields remain the same size as they were before clicking into them.


Ok -- I've not seen that, I'm afraid.

Perhaps you could post a screenshot so the support staff (not me — I'm just another user...) can see what you're seeing.

User avatar
ForgottenGold
Posts: 63
Joined: Mon Oct 07, 2013 6:08 pm
Platform: Mac + iOS

Fri Feb 23, 2018 7:06 pm Post

brookter wrote:Ok -- I've not seen that, I'm afraid.

Perhaps you could post a screenshot so the support staff (not me — I'm just another user...) can see what you're seeing.

Will do. Thank you for taking the time to help out. :)

User avatar
ForgottenGold
Posts: 63
Joined: Mon Oct 07, 2013 6:08 pm
Platform: Mac + iOS

Fri Feb 23, 2018 7:31 pm Post

Image
^This is the view I have before I click into the text field of the summary. As you can see, the rows are not a fixed height.
Image
^This is the view after I have clicked into the text field. I clicked at the end of the last word in the summary "custom", however as you can see the cursor is after "Bob" instead, and the row is the same height as it was before I clicked into the text field. I cannot see the last line at all, and even the current line is cut off a bit because as you can see, the spacing between the lines has increased dramatically. I do not mind the increase, it's only that I can't properly click into the box where I mean to, and then navigating the synopsis is now more difficult since the row doesn't adjust to the new height, and I cannot scroll to get to the bottom. I can use the arrow keys, as I did in the next image, although they are very exacting.
Image
^In this image I have used the arrow keys to get to the bottom of the summary, and as I mentioned in the OP, one too many clicks on the arrow keys and it will to go down and select "Test Title 2". I did not scroll, as scrolling does not work. Obviously the text is still quite cut off, but now it is the top that's cut off.

Thanks for your time.

sc
scshrugged
Posts: 347
Joined: Wed Feb 10, 2016 6:55 pm
Platform: Mac + iOS

Sat Feb 24, 2018 4:17 am Post

Just a thought—if you’re using a window management app or any app that can in any way manipulate a window, test with it completely disabled.
Scrivener user not affiliated with L&L.

br
brookter
Posts: 1780
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Sat Feb 24, 2018 8:04 am Post

Thanks for the screenshots — that helps visualise your issue nicely.

I can't actually replicate it though — when I click on the synopsis to select, then click to enter the field, the cursor goes to the exact spot I'm clicking in, every time. The line height stays the same as well. Have you changed the font in Preferences by any chance?

BTW, if you want to get to the bottom of the synopsis field, just use the standard Mac shortcut — cmd-down arrow, which works here (for me at least).

Sorry I can't be of any more use.

User avatar
ForgottenGold
Posts: 63
Joined: Mon Oct 07, 2013 6:08 pm
Platform: Mac + iOS

Mon Feb 26, 2018 6:29 am Post

scshrugged wrote:Just a thought—if you’re using a window management app or any app that can in any way manipulate a window, test with it completely disabled.

Nope. Don't think so.

brookter wrote:Thanks for the screenshots — that helps visualise your issue nicely.

I can't actually replicate it though — when I click on the synopsis to select, then click to enter the field, the cursor goes to the exact spot I'm clicking in, every time. The line height stays the same as well. Have you changed the font in Preferences by any chance?

Perhaps it has something to do with the row spacing and font? I did change those.

Image
Image

brookter wrote:BTW, if you want to get to the bottom of the synopsis field, just use the standard Mac shortcut — cmd-down arrow, which works here (for me at least).

Sorry I can't be of any more use.

Okay, Thank you. :)

User avatar
MimeticMouton
Posts: 8679
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Fri Mar 16, 2018 7:32 am Post

The spacing issue is caused by the Hiragino font set for synopses; try using a different sans serif font there.
Jennifer Hughes
(MM for short)