Two bugs // 1) Compiler controlling documents // 2) Loads of comments running slow

ed
edjamesauthor
Posts: 9
Joined: Mon Aug 27, 2012 4:37 pm
Platform: Mac
Contact:

Wed Feb 14, 2018 10:09 am Post

Hi,

got a couple of bugs in Scriv3, which I've been really enjoying. Hope they haven't been reported before -- I had a shufty and couldn't see them.

1) on my iMac, I use the Compiler in the left pane to control the document in the right pane. There's some weird behaviour about not being able to select a single document (seems to default to selecting the parent and showing all sub-documents?). There's also an issue where if I have say three scenes in a chapter folder and delete one of them, it still shows all three.

2) I've had some copy editing done to a manuscript done in Scrivener (not something we'd do again!) and the performance on clicking on comments and working within the box is really slow. It works fine outside it and if you backspace from the right, so I don't know what's going on.

User avatar
AmberV
Posts: 22419
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Wed Feb 14, 2018 12:34 pm Post

  1. on my iMac, I use the Compiler in the left pane to control the document in the right pane. There’s some weird behaviour about not being able to select a single document (seems to default to selecting the parent and showing all sub-documents?). There’s also an issue where if I have say three scenes in a chapter folder and delete one of them, it still shows all three.


I’m not following this problem description unfortunately. It might be a matter of terminology—the Compiler (via the File ▸ Compile... menu command) is not something one can put on the left side of anything. It is an export engine that replaces the whole project window, and you can’t delete stuff from within it.

Do you mean you have an Outliner or Corkboard in the left editor split, set to automatically load the selection via the Navigate ▸ Outliner|Corkboard Selection Affects ▸ Other Editor menu toggle?

If so, I suppose I can think of some scenarios that might work the way you are describing, but I think rather than speculating and potentially misleading you, it would be better to get a solid description of what is going on.

May also be worth using that Navigate ▸ Clear All Navigation Options command. Maybe you’ve toggled a few different settings on and their purpose is at this point working against your expectations. That command will return the window to a very basic default function: click on things in the binder, they load in the active editor split, and that’s it.

If you’re looking for something more complex, we can build up from that.

I’ve had some copy editing done to a manuscript done in Scrivener (not something we’d do again!) and the performance on clicking on comments and working within the box is really slow. It works fine outside it and if you backspace from the right, so I don’t know what’s going on.


There aren’t any known issues with slow downs in that area, so it might take some analysis into what is unusual about them. Are there thousands of them being loaded into one view at once, for instance? Are there lots of images stored within them?
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles