Compile to Draft forces A4 paper

gr
gregoreite
Posts: 6
Joined: Sat Dec 16, 2017 9:11 pm
Platform: Mac

Mon Dec 18, 2017 8:01 pm Post

When I compile to a word processor, I can obviously manipulate the document size. When I compile in default to either pdf or print, it pushes the A4 setting to my printer which I cannot override in any setting in the Print callout box (Paper Handling). The suggested paper size is grayed out:
Attachments
Screenshot 2017-12-18 12.00.19.png
Screenshot 2017-12-18 12.00.19.png (266.64 KiB) Viewed 1177 times

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Mon Dec 18, 2017 8:14 pm Post

Tick . . .

Screenshot%202017-12-18%2012.00.19.png
Screenshot%202017-12-18%2012.00.19.png (271.31 KiB) Viewed 1173 times

gr
gregoreite
Posts: 6
Joined: Sat Dec 16, 2017 9:11 pm
Platform: Mac

Mon Dec 18, 2017 11:14 pm Post

That worked for compiling from Default to Print. When I compile from Default to Microsoft Word, it forces A4. I have to go into Page Setup and manually choose US Letter. Not a big deal, maybe, but if I miss this, my printer goes into error mode because it is not set up to print using European metrics.

User avatar
Silverdragon
Posts: 700
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Tue Dec 19, 2017 12:16 am Post

For .docx (or .doc) you'll need to edit your compile format:
Screenshot_2017-12-18_16_07_39.png
Screenshot_2017-12-18_16_07_39.png (100.65 KiB) Viewed 1158 times

You can use page setup from the main editor, OR default page size (A4, for you), OR you can do a page setup right there in the compile format and set it up as you please. You can also preview there in the format editing pane to be sure you have your .docx file going out the way you want.
So you know where I'm coming from:
  • I'm a user, not an L&L employee.
  • Mac Scrivener 3.0.3, MacBook Air 11, MacOS 10.13.6 (High Sierra)
  • IOS Scrivener 1.1.5, iPhone 6s, iPad Air 2, iOS 12.0

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Tue Dec 19, 2017 8:09 am Post

If you're going from Scrivener to Word and then Word isn't printing properly, that's down to negotiation between Word and your printer, rather than Scrivener.

Silverdragon's screenshot above will help at the compile stage.

Alternatively, follow her idea about making a change at a project level. Choose File > Page Setup > and set the default paper size for the project. That should follow through automatically when you compile or print.

Page Setup.jpg
Page Setup.jpg (80.14 KiB) Viewed 1150 times

gr
gregoreite
Posts: 6
Joined: Sat Dec 16, 2017 9:11 pm
Platform: Mac

Wed Dec 20, 2017 6:36 pm Post

Silverdragon... I am not able to find a screen on my Scrivener that resembles your screenshot. :o Thanks for the help.

Bridey, I do appreciate your help and comments. I am surprised that A4 is the default for Scrivener that needs to be adjusted to US Letter. Will I have to adjust for every project?

My experience so far (and again, I am a novice to Scrivener. I have had it for awhile, but am just beginning to work on my writing projects) is that Scrivener has reacted defensively about this problem saying it is my fault or the fault of my printer, etc. I am willing to make adjustments to default settings on my printer, computer, Scrivener preferences, etc. recognizing that this is a European product, but a bit of empathy for the North American constituency and clear instructions how to adapt it for US use would be in order, wouldn't it? I doubt I am the only one that has experienced these problems. I have learned how to make adjustments for the three projects I am working on now, but I wish I could make North American settings the default. I have no other software that requires this much research to make functional for my purposes.

br
brookter
Posts: 1713
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Wed Dec 20, 2017 7:22 pm Post

I can force it to US Letter settings by default instead of A4 (though I can't convince Keith to spell Colour properly in the menus...)

It needs to be set in two places:

1. System Preferences > Printers and Scanners > Default Paper Size
2. Scrivener File > Page Setup > Page Attributes > Paper Size.

If you find it's not changing when both of those are set properly, then in Compile press the option key and the left hand button will change to Reset. Click that -- it may force the compiler to reread the setting.

That works for me, anyway.

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Wed Dec 20, 2017 8:39 pm Post

Thanks, gregoreite.

Brookter's post *should* provide a long-term solution, I hope.

gr
gregoreite
Posts: 6
Joined: Sat Dec 16, 2017 9:11 pm
Platform: Mac

Wed Dec 27, 2017 8:22 pm Post

Thanks all. I checked both and didn't need to adjust. They were already set to US Letter (yay!). I opened a new project and compiled to Word. Suggested size was US Letter.

So... All good.

Thanks.
G