Collections search defaults to "ignore case" and "contains"

Ch
ChiaLynn
Posts: 38
Joined: Wed Nov 16, 2011 2:11 am
Platform: Mac
Contact:

Fri Apr 15, 2016 6:48 pm Post

I'm not sure if this is actually a bug, or expected behavior, but—

If I run a search (of any kind) and save the results as a collection, then run a search inside the collection, the options always default to "ignore case" and "contains." If I run a search in the binder, though, then my next search retains the options I used last time.

It's not a big deal to double-check my search options when I'm searching in a collection, but it is an extra step—is this something that can be fixed, or is there a setting somewhere I can toggle so it doesn't happen?

Thanks!
Chia

ETA: Scrivener 2.7 (direct download) on OS X 10.11.4, Mid-2012 Macbook Pro.

User avatar
AmberV
Posts: 24272
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Fri Apr 15, 2016 8:38 pm Post

Are you referring to the normal “Cmd-F” way of searching text inside of documents? If so, that is indeed expected behaviour. Document search settings will adopt relevant search parameters from the project search terms in the current sidebar (i.e. the saved search collection you are looking at). The reasoning is that document search is a useful second-stage to project search. We look for case-sensitive/whole word “Sam” in the collection for the Sam character, and then use document search to find cases of “Sam” in the text itself. If the find rules were different from the sidebar search rules, you’d end up finding words like “assam”.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Ch
ChiaLynn
Posts: 38
Joined: Wed Nov 16, 2011 2:11 am
Platform: Mac
Contact:

Sat Apr 16, 2016 4:42 pm Post

Ah! Now I get it. I thought I'd toggled "case sensitive" in the search (from the search box), and I hadn't. I just ran a couple of test searches and got the results I was expecting. Thank you, and please feel free to tag this thread "PEBKAC."