Return key removes paragraph stlying

to
tomedwards4695
Posts: 3
Joined: Sat Jan 13, 2018 7:24 pm
Platform: Mac

Sat Jan 13, 2018 7:32 pm Post

Using Scrivener 3.0.1 on Mac High Sierra 10.13.2

I had tried earlier to figure out how to create a paragraph styling for my entire document—I wanted to have an indent at the start of each paragraph and a space after each paragraph. I couldn't figure out a way to do this for the whole document, so I just made the settings I wanted in one of my text files and then saved it as a "new paragraph style" with the selector at the top left of the editor window.

I then opened each chapter (text file) and selected all the text, then applied this paragraph style from the dropdown.


This was working fine, until now. All of the sudden when I hit the Return (Enter) key to start a new paragraph key, the paragraph style selector reverts to "no style" and everything reverts to the original formatting, including text size. I have to start typing in the middle of a sentence in the last paragraph and then hit enter and go back to fix the last sentence, etc. Obviously not ideal when you're trying to write a whole book lol

1. What I expect to happen: To hit Return and start a new paragraph.

2. What actually happens: I hit Return and my paragraph stying defaults to "no style"

3. I don't know how to reproduce it other than what I've outlined above!

br
brookter
Posts: 2212
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Sat Jan 13, 2018 7:56 pm Post

Basically, the way you're approaching the problem is making it harder for you.

The idea with styles is that:

a) Your standard, default paragraph style (what would be 'Normal' in Word, if that helps) should be 'No Style', not a defined style as you've tried to do. Styles are really for exceptions / amendments to the default 'No Style' — not for the standard paragraph.

b) You set the default ('No Style') paragraph format in Preferences > Editing > Formatting — click in the dummy text box and set the fonts, indents, spacing, ruler etc from there. (OR: if you've already set it up in a document, then in the same dialog box, click 'Use Formatting in Current Editor).
Screenshot 2018-01-13 19.39.17.png
Screenshot 2018-01-13 19.39.17.png (251.67 KiB) Viewed 3635 times


Once you've done that, any new documents in this or any other project will use your default paragraph style (it will appear as 'No Style') and it will continue when you press Return.

That's the basics: set the default paragraph format in Preferences > Editing > Formatting and then leave it alone.

More details:

a) The reason for using the default No Style this way is that it allows different compile formats to make suitable changes (eg Courier 12 pt for manuscripts, Palatino 10pt for eBooks etc) without you having to do anything. If you set a 'body' style with an explicit style, you have to do this work yourself and there are some odd effects.

b) There are a couple of ways to convert your now unwanted body style back to No Style. The easiest is probably to create a scrivening with all your documents, then highlight the first of your old-styled paragraphs. Click Ctl-S to get the Styles Panel, then right-click on the name of your style in the panel and click on 'Select All Text with Paragraph Style' — this will, not surprisingly..., highlight all such styled paragraphs. Then all you need to do is cmd-opt-0, which will apply 'No Style' to them all. NB: try this out on a dummy text first so you're happy with what's going on! (But cmd-z will undo it).
Screenshot 2018-01-13 19.48.04.png
Screenshot 2018-01-13 19.48.04.png (851.07 KiB) Viewed 3635 times


c) The reason you weren't continuing your style before was that you had the Next Style dropdown box set to 'No Style'. For future reference, this is on the dialogue box you get when you either create or redefine a style. Here I've set my List style to be followed by my List style... but I could choose any of the others, or none at all.

Screenshot 2018-01-13 19.55.07.png
Screenshot 2018-01-13 19.55.07.png (235.39 KiB) Viewed 3635 times




The way Scrivener uses styles is powerful, but there are a few assumptions you need to know — that's actually true for Scrivener as a whole. If you try to use it just as a word processor, some elements will seems confusing — once you've go the (relatively simple) concepts, everything slots into place and you can start getting the real benefits.

If you've not already done it, it will really help you to do the Interactive Tutorial (on the Help menu) — it will only take an hour or so and it will introduce you to the main features and concepts which will really help you start using Scrivener productively much quicker. (This is true, even if you're a V2 user — there's a special section detailing the elements which have changed.)

Hope this helps.
Last edited by brookter on Sat Jan 13, 2018 8:00 pm, edited 1 time in total.

User avatar
AmberV
Posts: 24540
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Sat Jan 13, 2018 8:00 pm Post

To get some of the basics out of the way, you would not ordinarily need a style for what you are describing—the default behaviour that you’re running into is that way precisely because the whole MS Word type idea plastering styles all over every shred of text isn’t necessary in Scrivener. It’s more designed around the model of using it for exceptional text. See §15.5.1, Think Different, in the user manual, starting on page 391 for more explanation on that concept.

Next, as for why it is working the way it is, and how to change it, read through §15.5.3, Using and Managing Styles, particularly the style creation screen, starting on page 399 and the Next Style option. For existing styles, redefinition is described on page 401.

P.S. If you’re selecting this format for how the document will look in the end, it’s very rare you would want to combine indents and paragraph spacing. It is better to choose one or the other. If this is just for your own writing space and that’s the way you like it, then never mind. :)

P.P.S. Again, with the caveat in mind that “body” styling is not usually important in Scrivener, if that is what really do want, a much easier approach is described in the Project Settings appendix, C.5, pg. 810, with the New documents use paragraph style setting. Now you don’t have to continually reapply the setting every time you create a new chunk of text.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

wg
wgracetyner
Posts: 1
Joined: Thu Jul 16, 2020 5:51 pm
Platform: Mac + iOS

Thu Jul 16, 2020 10:05 pm Post

I have one follow up question. I have set up my project as suggested, but the options you referenced only affect new documents. How do I update the 'No Style' across my entire project? Essentially I need to "Select All Text with No Paragraph Style" option, so that can update the paragraph, font, etc.
Is there an option for this that I am missing? Thank you for your help!

User avatar
kewms
Posts: 6987
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Fri Jul 17, 2020 12:35 am Post

To normalize existing text, use Documents -> Convert -> Text to Default Formatting.

Katherine
Scrivener Support Team

as
aspidoscelis
Posts: 2
Joined: Wed Jan 13, 2021 11:06 pm
Platform: Mac

Wed Jan 13, 2021 11:40 pm Post

Although changing the default style is the best solution in this case, what's the best approach for a document that has different styles for different sections. For instance, in academic writing the abstract and bibliography typically have smaller text, different line spacing, and different indentation formats than the body. The abstract is a single paragraph, so carriage return behavior is not a problem, but the bibliography of course has carriage returns separating the entries.

A part of me wants to say, "Don't worry about the formatting during writing and editing, do it at the end," but I'm finding that it is distracting to edit, e.g., a bibliography section that doesn't look like a bibliography section. The styling doesn't only provide useful information to the reader of the final document, it also provides useful information to me as I'm writing.

as
aspidoscelis
Posts: 2
Joined: Wed Jan 13, 2021 11:06 pm
Platform: Mac

Wed Jan 13, 2021 11:49 pm Post

As I'm thinking through this a little more, I guess what I'm wishing Scrivener would do is preserve the styling I set within each section of the document while I'm writing it, and then ignore all that at the "compile" stage. I don't really know if the styling that is useful at providing the relevant information to me as I'm writing the document will be the same as the styling I want in the compiled document--but there is styling that provides useful information to me as I'm writing the document, and I want to just set it for a section and then not worry about it later.

User avatar
kewms
Posts: 6987
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Thu Jan 14, 2021 5:46 am Post

It's not unusual for people to want different formatting for different sub-documents. If you set the document up using the commands on the Format menu, you should be fine.

If you use a Style, you'd need to set it so the "Next Style" is also "BibliographyItem" or whatever, and you'd need to wrestle with how the Compile command and Styles interact. But rich text formatting is just formatting, without any semantic content.

Katherine
Scrivener Support Team