[Aeon] Help wanted: Steps to track down a bug

ma
matt
Posts: 1180
Joined: Mon Jul 30, 2007 9:35 am

Tue Jun 05, 2012 2:09 pm Post

I have had several people separately report a bug with Aeon Timeline that causes one of the fields of the date picker tool to disappear in certain circumstances, leaving an empty white space in its place, as per the image posted here:

viewtopic.php?f=27&t=18818#p128930

Unfortunately, I have so far been unable to reproduce this behaviour, or work out a reliable way to make it appear.

If anyone has seen this behaviour, could you please let me know. Try to pay particular attention to the circumstances that may have made it occur. If anyone can work out a set of steps that can reliably reproduce the problem, that will be better still.

With most software bugs, they are easy to fix once they can be reliably reproduced, as it is then possible to determine the cause. When they cannot be reproduced consistently, it is a needle in a haystack (well... a few lines of code in amongst tens of thousands).

Matt

User avatar
xiamenese
Posts: 4066
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Wed Jun 06, 2012 2:29 am Post

Matt,

Even though I haven't yet purchased Aeon Timeline — as per our PM exchanges — looking at the thread you reference, I notice that Ursula shows what happens with her Aeon preferences set for System format, then changed to Day/Month settings, and she also shows her system Date & Time settings. I notice that she has the long date and the "xx.Monthname Year" set in Day/Month/Year order, but the two short dates are in Year/Month/Day order, the last without any separators.

I just wondered whether the fact that she has two different orders in her system settings may be a source of the problems she is reporting.

Mark
The Scrivenato sometimes known as Mr X.
rMBP 13" (early 2015) 10.14.5, 8GB RAM, 512GB SSID
MBP17" (late 2011) 10.13.6, 8GB RAM, 512GB SSID
2017 iPad, iOS 12.3.1, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

ma
matt
Posts: 1180
Joined: Mon Jul 30, 2007 9:35 am

Wed Jun 06, 2012 3:49 am Post

Hi Mark,
They're two separate problems. Ursula's problem I am helping sort out via email as well, but I think it is mostly down to some slightly awkward UI things that I want to fix up.

But the one that I really need to reproduce, and that is a genuine bug, are those disappearing fields in the date picker in the very first post of that thread (I linked to it just for the image of what I am discussing).

Matt

User avatar
xiamenese
Posts: 4066
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Wed Jun 06, 2012 4:28 am Post

matt wrote:Hi Mark,
They're two separate problems. Ursula's problem I am helping sort out via email as well, but I think it is mostly down to some slightly awkward UI things that I want to fix up.

But the one that I really need to reproduce, and that is a genuine bug, are those disappearing fields in the date picker in the very first post of that thread (I linked to it just for the image of what I am discussing).

Matt

Yes, I realised that. I just wondered if having two totally different orders in the system date settings could cause some kind of conflict as to which was day and which was month, when the Aeon settings are in numerical DD-MM-YYYY format and her equivalent system settings are YYYY-DD-MM, and so the blank. I wondered what the OP's system settings were too, as he didn't give them.

Of course, I'm more than willing to believe that this is a total red herring, just something I noticed.

Mark
The Scrivenato sometimes known as Mr X.
rMBP 13" (early 2015) 10.14.5, 8GB RAM, 512GB SSID
MBP17" (late 2011) 10.13.6, 8GB RAM, 512GB SSID
2017 iPad, iOS 12.3.1, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

ma
matt
Posts: 1180
Joined: Mon Jul 30, 2007 9:35 am

Wed Jun 06, 2012 6:41 am Post

It's confusing enough that I want to clean up that area, but I expect they are unrelated.

Of course, that doesn't mean that switching the date picker format back and forth between day/month and month/day, particularly while in the middle of an edit or something, wouldn't have an effect. Alternatively, perhaps clicking out of a field into somewhere else while editing, etc.

But all the things I have tried so far haven't reproduced it.

Matt

ma
matt
Posts: 1180
Joined: Mon Jul 30, 2007 9:35 am

Wed Jun 06, 2012 2:38 pm Post

Hi All,

Ursula sent through some information that didn't quite solve the problem, but at least set me on the right track.

As far as I can tell, the problem has been found and fixed, and I have improved a bunch of other idiosyncrasies with the date picker control at the same time.

I will close this thread.

Thanks,
Matt