Page 1 of 1

Markdown in Scrivener 3

Posted: Sat Nov 04, 2017 3:03 pm
by RobertG
Does anyone have information on Markdown output/processing in Scrivener 3? Before it was released, I often heard rumors that Pandoc would be integrated - is that the case?

Re: Markdown in Scrivener 3

Posted: Sat Nov 04, 2017 5:34 pm
by nontroppo
At least in the mac beta, Scrivener 3 is Pandoc aware, if you have it installed it will provide some custom compile presets, and it makes some minor changes when converting to markdown (the syntax is almost, but not quite, identical to MMD). For more flexibility, with post-processing you can run pandoc template systems like pandocomatic, which mean you can have a lot of control over the pandoc settings.

Re: Markdown in Scrivener 3

Posted: Wed Nov 22, 2017 10:03 am
by sero
The Tome of Scrivener (also known as the User Manual) has a whole chapter on "Using
MultiMarkdown and Pandoc". You can download it from http://www.literatureandlatte.com/learn ... ser-guides. Have a look at chapter 21.

Re: Markdown in Scrivener 3

Posted: Wed Nov 22, 2017 10:38 am
by AmberV
We don’t ship Pandoc with Scrivener like we do MMD, because the latter compressed down to 413kb and Pandoc compresses down to half of the size of Scrivener itself. So you’ll need to download and install it yourself, but once you do you’ll get appropriate options in the Compile for setting at the top.

Pandoc is huge, and we only provided a small selection of some useful formats that filled a few gaps people have asked for over the years. A better Word route, DocBook and a solid Markdown-based eBook publishing route. But, the door is wide open to whatever you need given that aforementioned Processing pane.

Re: Markdown in Scrivener 3

Posted: Sat Dec 29, 2018 12:28 am
by NinaAmir
I've recently upgraded to the newest version of Scrivener. I often use it for blogging and format using Multi-Markdown. I export to Multimarkdown-->webpage. Now, when I compile, the # signs stay in my headings and they do not turn into headlines.

For instance, I usually type ###**Subheading**### and get a bold H3. But not any longer. The bold comes through...but not the H3. I have to go in and delete the hashtags and add the heading specification.

All the * work to create bold, italics, etc.

I've tried compiling as default and basic, but I'm having no success. What am I missing?

Re: Markdown in Scrivener 3

Posted: Mon Jan 07, 2019 1:09 pm
by AmberV
That doesn’t look like valid MultiMarkdown syntax to me. It might have been accepted by older versions of MMD, but the latest version doesn’t like it, and that is what is embedded in Scrivener.

If you really wanted to do something like this, the syntax should be properly formed:

Code: Select all

## **A Strongly Emphatic Heading** ##


As I infer from my example however, what you are doing isn’t, pedantically speaking, good practice. Maybe you have a perfectly good reason, but for one thing by default h3 elements are rendered in bold in browsers, so in most cases this would be redundant. But if they aren’t bold with whatever system you’re using, that means there is a stylesheet somewhere overriding browser defaults and that is where you should be stipulating bold—as an aesthetic choice, rather than a semantic declaration with the <strong> element.