Page 1 of 1

some of my text disappeared on import :(

Posted: Sun Nov 14, 2010 9:00 am
by caiknbake
Hi all,

Just to begin, I am loving Scrivener. I'm working with the NaNoWriMo trial version right now, and it's working absolutely perfectly for my novel.

I'm so excited about it, in fact, that I wanted to start importing some of my research papers into it as well to play around and do some further editing. The paper I began with has extensive footnotes, and as I remember reading that only .rtf files will import the footnotes, I resaved the .doc version that had been my final draft as .rtf (I had originally composed it in Open Office). When I imported the .rtf version, although the formatting looked a little wonky, the footnotes were there as inline footnotes, which I then converted to inspector footnotes. All's well so far.

Then I began to look a little closer, and I noticed that small sections of text (within the body, not the footnotes, or at least as far as I noticed) had mysteriously vanished, splitting words and losing about a sentence worth here and there, with no apparent rhyme or reason to what was cut out. I have no idea if this is a Scrivener issue or if Open Office messed things up somehow when I resaved as .rtf (although the missing passages aren't missing in Open Office when I open the .rtf version), but I was wondering if you guys had ever heard of this happening or had ever dealt with it before.

This isn't a time-sensitive issue; as I said, I was merely playing around and procrastinating on my novel writing :lol: And thankfully since I still have the original files I haven't lost any data or anything. But I would really love to be able to tinker with this and other similar projects in Scrivener without having to proofread the whole thing for missing passages before I even begin. Any feedback would be appreciated.

Thanks!
Caitlin

P.S. I have no idea if it's relevant, but I'm running OS X 10.6.4 fyi...

Re: some of my text disappeared on import :(

Posted: Mon Nov 15, 2010 9:51 am
by KB
Hi,

I've never heard of anything like this happening - very weird, as the body of the RTF is brought in using Apple's standard RTf importer (although I wonder if something in the footnotes confused Scrivener's specific code). Could you please send me the RTF document that exhibited this behaviour, along with a note on which paragraphs I should look out for disappearing? You can send the file to support AT literatureandlatte DOT com, marking it for the attention of myself (I'll delete your file after investigating the problem of course).

Thanks,
Keith

Re: some of my text disappeared on import :(

Posted: Mon Nov 15, 2010 11:59 am
by caiknbake
Thanks - I've just sent it.

Re: some of my text disappeared on import :(

Posted: Mon Nov 15, 2010 12:21 pm
by KB
Thanks! I'll let you know what I find as soon as I get chance to look at it.