What Happened to My "Indent" Function?

User avatar
driver49
Posts: 53
Joined: Fri Dec 05, 2014 4:30 pm
Platform: Mac

Sun Apr 18, 2021 5:08 pm Post

Can somebody please help me figure out what happened to my ability to indent paragraphs? Instead of indenting, they are deleting.

Hopefully the attached screenshot illustrates the dilemma:
Screen Shot 2021-04-18 at 11.59.13 AM.png
Screen Shot 2021-04-18 at 11.59.13 AM.png (336.42 KiB) Viewed 350 times


You see a line of text that I want to indent. But when I hit <cmd>+ ], instead of indenting, the paragraph deletes and I get that right-facing arrow,
Screen Shot 2021-04-18 at 12.03.46 PM.png
Screen Shot 2021-04-18 at 12.03.46 PM.png (307.6 KiB) Viewed 350 times
. What you SHOULD be seeing is the same line of text as above, but indented. Instead it's deleted.

I tried opening a new document within the file, and the indenting function appears to work normally there, so I don't know if it's something that has gone haywire with this the one document within the file, or if I changed a setting unbeknownst, or... what exactly.

All I know for certain is that I've wasted the past 20 minutes trying to figure out why I suddenly cannot indent a paragraph like I've been doing normally for years.

And while I'm at it: I have noticed another anomalous behavior over the past few months. It used to be that I could <cmd>+] to indent and THEN start typing. But now I have to type something first and THEN go back and do the <cmd>+]. What's up with that?

Thanks,

--PS

User avatar
drmajorbob
Posts: 932
Joined: Sun Jul 01, 2012 1:38 am
Platform: Mac

Sun Apr 18, 2021 6:52 pm Post

driver49 wrote:Can somebody please help me figure out what happened to my ability to indent paragraphs?

It's not clear to me what ⌘] used to do for you. It's even less clear how much indentation you'd get from the shortcut and how you control that, so it doesn't seem useful to me.

At my machine, ⌘[ is previous viewed document and ⌘] is next document — though oddly enough, those are not the listed shortcuts in the menus! I use arrow icons at the top of the screen for that, since I don't learn keyboard shortcuts unless I need them often. Next and previous document don't qualify.

I indent the sample paragraph once and for all in Preferences, making it the default for "no style" in new documents. Pressing enter at the end of a paragraph yields another paragraph with the same specified indentation. If the default in Preferences isn't correct for some paragraphs, I'd create a style for them and give the style a shortcut. Hence I get consistent indentation and use a shortcut only for rare exceptions.

When I set or change default indentation, I can convert all documents to the default format.

What would you do, if you wanted to change your indents?
Teeth, without gums, fall loosely in the mouth.

(I'm not a Literature & Latte employee. Just another user.)

User avatar
driver49
Posts: 53
Joined: Fri Dec 05, 2014 4:30 pm
Platform: Mac

Sun Apr 18, 2021 7:01 pm Post

drmajorbob wrote:It's not clear to me what ⌘] used to do for you. It's even less clear how much indentation you'd get from the shortcut and how you control that, so it doesn't seem useful to me.

At my machine, ⌘[ is previous viewed document and ⌘] is next document — though oddly enough, those are not the listed shortcuts in the menus! I


Are we using the same program? This is what the Format > Paragraph > Indents menu looks like to me:
Screen Shot 2021-04-18 at 1.57.01 PM.png
Screen Shot 2021-04-18 at 1.57.01 PM.png (54.16 KiB) Viewed 330 times


Pretty clear to me I am using the right keystrokes. I've been using them for as long as I've used Scrivener. What I don't understand is why they have suddenly started behaving anomalously. And it's really slowing me down.

User avatar
Silverdragon
Posts: 1845
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac
Location: Tarzana, California, USA
Contact:

Sun Apr 18, 2021 7:21 pm Post

Interesting... these are the keyboard shortcuts for indents in my menus:
Screen Shot 2021-04-18 at 12.06.46.png
Indent keyboard shortcuts, Scrivener 3.2.2, MacOS 10.15.7, US keyboard layout
Screen Shot 2021-04-18 at 12.06.46.png (109.07 KiB) Viewed 327 times

And here are my document history shortcuts:
Screen Shot 2021-04-18 at 12.14.46.png
Document history keyboard shortcuts, Scrivener 3.2.2, MacOS 10.15.7, US keyboard layout
Screen Shot 2021-04-18 at 12.14.46.png (87.77 KiB) Viewed 327 times

Are you perhaps using a different keyboard layout or a different version of Scrivener?
  • Fiction-writer curled up on her silicon hoard
  • Mac Scrivener 3.2.2, MacBook Air 11, MacOS 10.15.7 (Catalina)
  • iOS Scrivener 1.2.1, iPad 6, iPhone 12 pro, i(Pad)OS 14.5
  • Website: https://silverdrag0n.wordpress.com

User avatar
drmajorbob
Posts: 932
Joined: Sun Jul 01, 2012 1:38 am
Platform: Mac

Sun Apr 18, 2021 7:23 pm Post

driver49 wrote:
drmajorbob wrote:It's not clear to me what ⌘] used to do for you. It's even less clear how much indentation you'd get from the shortcut and how you control that, so it doesn't seem useful to me.

At my machine, ⌘[ is previous viewed document and ⌘] is next document — though oddly enough, those are not the listed shortcuts in the menus! I


Are we using the same program? This is what the Format > Paragraph > Indents menu looks like to me: Screen Shot 2021-04-18 at 1.57.01 PM.png

Pretty clear to me I am using the right keystrokes. I've been using them for as long as I've used Scrivener. What I don't understand is why they have suddenly started behaving anomalously. And it's really slowing me down.

It won't slow you down if you change your methods to match mine, but that's a call you have to make. Literature & Latte may return it to the behavior you expect.

indent.png
indent.png (882.03 KiB) Viewed 325 times
Teeth, without gums, fall loosely in the mouth.

(I'm not a Literature & Latte employee. Just another user.)

User avatar
kewms
Posts: 7595
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Sun Apr 18, 2021 7:28 pm Post

What version of Scrivener? What version of Mac OS? And did you upgrade either recently?

Katherine
Scrivener Support Team

User avatar
drmajorbob
Posts: 932
Joined: Sun Jul 01, 2012 1:38 am
Platform: Mac

Sun Apr 18, 2021 7:38 pm Post

Silverdragon wrote:Interesting... these are the keyboard shortcuts for indents in my menus:
Screen Shot 2021-04-18 at 12.06.46.png
And here are my document history shortcuts:
Screen Shot 2021-04-18 at 12.14.46.png
Are you perhaps using a different keyboard layout or a different version of Scrivener?

That is an oddity, isn't it! I'm using 3.2.2 and macOS 11.3.

Edit: I misspoke before, somehow looking in the wrong place in the menus.

next previous.png
next previous.png (332.25 KiB) Viewed 312 times
Teeth, without gums, fall loosely in the mouth.

(I'm not a Literature & Latte employee. Just another user.)

User avatar
Silverdragon
Posts: 1845
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac
Location: Tarzana, California, USA
Contact:

Sun Apr 18, 2021 8:09 pm Post

driver49 wrote:Can somebody please help me figure out what happened to my ability to indent paragraphs? Instead of indenting, they are deleting.

Hopefully the attached screenshot illustrates the dilemma: Screen Shot 2021-04-18 at 11.59.13 AM.png

You see a line of text that I want to indent. But when I hit <cmd>+ ], instead of indenting, the paragraph deletes and I get that right-facing arrow, Screen Shot 2021-04-18 at 12.03.46 PM.png. What you SHOULD be seeing is the same line of text as above, but indented. Instead it's deleted.

I tried opening a new document within the file, and the indenting function appears to work normally there, so I don't know if it's something that has gone haywire with this the one document within the file, or if I changed a setting unbeknownst, or... what exactly.

All I know for certain is that I've wasted the past 20 minutes trying to figure out why I suddenly cannot indent a paragraph like I've been doing normally for years.

And while I'm at it: I have noticed another anomalous behavior over the past few months. It used to be that I could <cmd>+] to indent and THEN start typing. But now I have to type something first and THEN go back and do the <cmd>+]. What's up with that?

Thanks,

--PS

I strongly suspect that many years ago you reassigned the keyboard shortcuts. In Scrivener 2, cmd-[ and cmd-] wouldn't have conflicted with anything. In Scrivener 3, the document history shortcuts changed so that they conflict.

I suggest you check your system preferences: Are cmd-[ and cmd-] listed in the app shortcuts for Scrivener? If so, remove them. If you use any keyboard macro apps such as Keyboard Maestro or Better Touch Tool, I suggest you check them as well.
Screen Shot 2021-04-18 at 13.05.32.jpg
System Preferences keyboard shortcut overrides for Scrivener
Screen Shot 2021-04-18 at 13.05.32.jpg (105.98 KiB) Viewed 305 times
  • Fiction-writer curled up on her silicon hoard
  • Mac Scrivener 3.2.2, MacBook Air 11, MacOS 10.15.7 (Catalina)
  • iOS Scrivener 1.2.1, iPad 6, iPhone 12 pro, i(Pad)OS 14.5
  • Website: https://silverdrag0n.wordpress.com

User avatar
drmajorbob
Posts: 932
Joined: Sun Jul 01, 2012 1:38 am
Platform: Mac

Sun Apr 18, 2021 9:52 pm Post

Silverdragon wrote:I strongly suspect that many years ago you reassigned the keyboard shortcuts. In Scrivener 2, cmd-[ and cmd-] wouldn't have conflicted with anything. In Scrivener 3, the document history shortcuts changed so that they conflict.

I suggest you check your system preferences: Are cmd-[ and cmd-] listed in the app shortcuts for Scrivener? If so, remove them. If you use any keyboard macro apps such as Keyboard Maestro or Better Touch Tool, I suggest you check them as well.Screen Shot 2021-04-18 at 13.05.32.jpg

Good point, Silverdragon. I was doing those checks myself in Scrivener menus, Keyboard Maestro, and System Preferences, but I should have suggested the OP should do that as well.
Teeth, without gums, fall loosely in the mouth.

(I'm not a Literature & Latte employee. Just another user.)

User avatar
driver49
Posts: 53
Joined: Fri Dec 05, 2014 4:30 pm
Platform: Mac

Mon Apr 19, 2021 12:56 pm Post

kewms wrote:What version of Scrivener? What version of Mac OS? And did you upgrade either recently?

Katherine


I'm on Scrivener 3.2.2, not sure when the last update was. MacOS 11.2.3

I'm just digging in to all this input first thing this morning, trying to discern now if there is some setting that was unwittingly changed that I can change back. I'm surprised to see a variety of commands for indenting.

Thanks,

--P

User avatar
driver49
Posts: 53
Joined: Fri Dec 05, 2014 4:30 pm
Platform: Mac

Mon Apr 19, 2021 1:16 pm Post

Silverdragon wrote:
I suggest you check your system preferences: Are cmd-[ and cmd-] listed in the app shortcuts for Scrivener? If so, remove them. If you use any keyboard macro apps such as Keyboard Maestro or Better Touch Tool, I suggest you check them as well.Screen Shot 2021-04-18 at 13.05.32.jpg


Thank you, @Silverdragon. Now we're getting somewhere.

Indeed, when I opened keyboard preferences, I found what you suspected:

Screen Shot 2021-04-19 at 7.58.39 AM.png
Screen Shot 2021-04-19 at 7.58.39 AM.png (48.59 KiB) Viewed 251 times


and made the change you recommended:

Screen Shot 2021-04-19 at 7.59.52 AM.png
Screen Shot 2021-04-19 at 7.59.52 AM.png (29.09 KiB) Viewed 251 times


And lo, now have what I understand (per the prior posts) is in fact the standard set of keyboard shortcuts for indenting (seriously, I had NO idea!).

Screen Shot 2021-04-19 at 8.02.04 AM.png
Screen Shot 2021-04-19 at 8.02.04 AM.png (36.17 KiB) Viewed 251 times


And now, it seems, things are behaving "nominally" if not entirely "normally" (i.e. the way they worked for years).

My apologies to @DrMajorBob for doubting him.

It's slightly inconvenient to need THREE keys to work indentations instead of TWO, but I guess I can get used to that.

But still I wonder:

1) How / when did I set those keyboard shortcuts that I seem to recall using for as long as I've been using Scrivener (which is maybe 5 years now?)

2) There is still one behavior that mystifies me: until a few months ago, I could execute an "indent" command (using my old keystrokes) BEFORE I started typing on the indented line. Now, even with this return to the default keystrokes, I have to have at least one character on the line before the indentation will take effect. So I have to to type "x", then execute the indentation, then resume typing whatever. Again a slight inconvenience, but not the way it used to work so a bit of a mystery.

3) What changed so that the (admittedly custom) keyboard shortcuts I'd been using all along suddenly started deleting instead of indenting?? Can I ever get it back the way it was?

At least I can do indentations again, where as yesterday, every time I tried to indent the text just disappeared. But I do remain mystified re: how exactly I got here.

Thanks,

--PS

User avatar
drmajorbob
Posts: 932
Joined: Sun Jul 01, 2012 1:38 am
Platform: Mac

Mon Apr 19, 2021 3:19 pm Post

driver49 wrote:It's slightly inconvenient to need THREE keys to work indentations instead of TWO, but I guess I can get used to that.

Not a problem. Change it to another 2-key shortcut (in the same place in System Preferences) or better yet, change the shortcuts for document history to something else and change ⌘[ and ⌘] to what they used to be, so you don't have to reprogram your muscle memory.

https://www.notion.so/deepspacecorps/Adding-macOS-Shortcuts-for-Scrivener-459e06f830ec456aa6a7ecda6ad75bb7

If you have a numeric keypad and don't expect to use + or - in your work, you can change them to ONE-key shortcuts (I think).
Teeth, without gums, fall loosely in the mouth.

(I'm not a Literature & Latte employee. Just another user.)

User avatar
driver49
Posts: 53
Joined: Fri Dec 05, 2014 4:30 pm
Platform: Mac

Tue Apr 20, 2021 12:55 pm Post

drmajorbob wrote:Not a problem. Change it to another 2-key shortcut (in the same place in System Preferences) or better yet, change the shortcuts for document history to something else and change ⌘[ and ⌘] to what they used to be, so you don't have to reprogram your muscle memory.


Not quite following you there, let me see if I can unpack....

1. "shortcuts for document history" <- is that what was happening in my recent experience when I tried to use ⌘[ and ⌘] to indent? It was revering to a prior iteration of the line (like <ctrl+Z> ?

2. how / where do I change the commands 'for document history to something else' ? Is that a System Preferences setting or a Scrivener preferences setting?

3. If I do restore ⌘[ and ⌘] to my indents function, doesn't that put me back where I started (assuming I re-set 'something else' for history). I'm still mystified re: why something that had worked fine for so long stopped working, but... whatever.

Thanks,

--PS

User avatar
Silverdragon
Posts: 1845
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac
Location: Tarzana, California, USA
Contact:

Tue Apr 20, 2021 3:59 pm Post

When did you upgrade to Scrivener 3? To Big sur? When was your last upgrade to Big Sur?

From the time you upgraded to Scrivener 3, you were vulnerable. Scrivener has always passed shortcuts to MacOS for execution, and having cmd-[ and cmd-] each assigned to two different menu commands meant that MacOS was free to execute either at its discretion. Any system upgrade that contained even a tiny tweak to the shortcut handling routines might have triggered this.

In short, you lucked out for a long time.

Now you have a choice: you can live with the default shortcuts (retrain your muscle memory) or reassign cmd-] and cmd-[ to indents where you had them before AND reassign the document history shortcuts to not conflict (as drmajorbob suggests. ). Personally, I'd just leave it, but I'm a notorious keyboard shortcut hater. :D
  • Fiction-writer curled up on her silicon hoard
  • Mac Scrivener 3.2.2, MacBook Air 11, MacOS 10.15.7 (Catalina)
  • iOS Scrivener 1.2.1, iPad 6, iPhone 12 pro, i(Pad)OS 14.5
  • Website: https://silverdrag0n.wordpress.com

User avatar
drmajorbob
Posts: 932
Joined: Sun Jul 01, 2012 1:38 am
Platform: Mac

Tue Apr 20, 2021 5:46 pm Post

driver49 wrote:
drmajorbob wrote:Not a problem. Change it to another 2-key shortcut (in the same place in System Preferences) or better yet, change the shortcuts for document history to something else and change ⌘[ and ⌘] to what they used to be, so you don't have to reprogram your muscle memory.


Not quite following you there, let me see if I can unpack....

1. "shortcuts for document history" <- is that what was happening in my recent experience when I tried to use ⌘[ and ⌘] to indent? It was revering to a prior iteration of the line (like <ctrl+Z> ?

2. how / where do I change the commands 'for document history to something else' ? Is that a System Preferences setting or a Scrivener preferences setting?

3. If I do restore ⌘[ and ⌘] to my indents function, doesn't that put me back where I started (assuming I re-set 'something else' for history). I'm still mystified re: why something that had worked fine for so long stopped working, but... whatever.

Thanks,

--PS

If ⌘] does the wrong thing (call it X), then give X a different shortcut. Then give the paragraph indent ⌘] as a shortcut.

Where to do all that? As I said, in the same place another commenter above showed you: System Preferences/Keyboard/Shortcuts.
Teeth, without gums, fall loosely in the mouth.

(I'm not a Literature & Latte employee. Just another user.)