Can't Enter a Carriage Return

dr
driver49
Posts: 48
Joined: Fri Dec 05, 2014 4:30 pm
Platform: Mac

Wed Dec 23, 2020 2:41 pm Post

Can somebody please tell me what just happened to my Scrivener?

Out of the blue this morning: when I type a carriage return, instead of going to the next line and entering text, Scrivener pops up a box with all kinds of formatting options (screenshot attached) Never happened before. What changed and how do I go back to the normal mode I was in before where a carriage return just took me to the next line?

While I"m at it: another change I notice recently: It used to be that when I wanted to start a new line with an indent, I could go to the next line and type <cmd+]> and the cursor would jump to the indent and I could start typing there. Now when I do that, nothing happens, and I have to start typing first and then I can enter my indentation. What's up with that.

I'm on whatever Scrivener 3.2.2
Attachments
Screen Shot 2020-12-23 at 8.33.38 AM.png
Screen Shot 2020-12-23 at 8.33.38 AM.png (360.11 KiB) Viewed 237 times

User avatar
lunk
Posts: 4398
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Wed Dec 23, 2020 3:32 pm Post

Have you restarted your Mac?

Manually entering indents may lead to all sorts of problems with indents when you compile.
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, running different OS.
* iOS Scrivener 1 on an iPhone 11 Pro, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS

dr
driver49
Posts: 48
Joined: Fri Dec 05, 2014 4:30 pm
Platform: Mac

Wed Dec 23, 2020 3:39 pm Post

I have not restarted the Mac but I did restart Scrivener to no favorable result. Same effect.

Will restart the Mac later. But I don't think that's gonna make the diff.

Thanks,

--PS

sc
scshrugged
Posts: 559
Joined: Wed Feb 10, 2016 6:55 pm
Platform: Mac + iOS

Wed Dec 23, 2020 4:56 pm Post

It looks that you’ve inadvertently enabled Script Mode.

The command (remove the check) to return to normal mode is at the Format menu > Scriptwriting, or via ⌘8 at the keyboard.
I'm a Scrivener user, not an L&L employee.

dr
driver49
Posts: 48
Joined: Fri Dec 05, 2014 4:30 pm
Platform: Mac

Wed Dec 23, 2020 5:19 pm Post

That was it. Thank you.

Will be useful to remember if I ever do write a script....

--PS

dr
driver49
Posts: 48
Joined: Fri Dec 05, 2014 4:30 pm
Platform: Mac

Sat Dec 26, 2020 3:06 pm Post

But wait....

Assuming this thread is still open / somebody is monitoring it:

I have switched out of Scriptwriting mode and that pop-up formatting box has gone away, but I'm still having that weird problem with the indent feature.

It seems I have to enter a character before I can do the <cmd+]> command to indent the next line.

It used to be that I could just go to the next line, enter the indent command, and it would indent, and then I could start typing. Now I have to start typing and then issue the indent command, which is sorta weird.

Is there something I can toggle that will put it back the way it used to be?

Thanks,

--PS

User avatar
gr
Posts: 2273
Joined: Wed Feb 14, 2007 3:57 am
Platform: Mac + iOS
Location: Florida

Sat Dec 26, 2020 4:10 pm Post

When you hit carriage return a new paragraph is begun and is given the same styling as the previous paragraph — because this is usually what you would want to have happen. But in this case it means you are carrying forward some paragraph styling you got accidentally in the first place and do not want.

So, I am guessing you just need to set the last paragraph to have your default paragraph format, and the carriage return from there to get back to your normal. (You could ask for the whole doc to be set to your default paragraph format, but since you are apparently applying indents manually, that would probably change things you don’t want to change.)

-gr

(I am not from L&L. Just a fellow user with a hunch.)
gr : Scrivener user : not affiliated with Lit^Lat
Image
"Nothing, like something, happens anywhere." —Philip Larkin

dr
driver49
Posts: 48
Joined: Fri Dec 05, 2014 4:30 pm
Platform: Mac

Sat Dec 26, 2020 5:49 pm Post

So, I am guessing you just need to set the last paragraph to have your default paragraph format, and the carriage return from there to get back to your normal


That sounds like an interesting possibility... but.... how do I reset the last paragraph to a default setting?

I don't see "default settings" in the Format > Paragraph menus.

--P

User avatar
kewms
Posts: 7187
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Sat Dec 26, 2020 6:27 pm Post

Once you've formatted one paragraph to work the way you want, you can use the Project -> Project Settings -> Formatting pane to make it the default for this project, or Scrivener -> Scrivener Preferences -> Editing -> Formatting to make it the default Scrivener-wide.

Then, the Documents -> Convert -> Text to Default Formatting command will reformat existing text to the new default.

Katherine
Scrivener Support Team