Unwanted separators in the pdf output

od
odalage
Posts: 41
Joined: Fri Jul 29, 2016 2:58 pm
Platform: Mac
Contact:

Sat Oct 10, 2020 10:08 am Post

I have returned to using Scrivener after a long absence and I encountered a problem I never met before : in the pdf output of my work, whenever there is a new paragraph opening a page, the first line is ***. It does not happen in the .docx output.
So I found a way around : to export as a pdf the Word document, but it is not satisfactory. I wondered what I am doing wrong since in my previous works, it never happened.
Of course, I have checked every single line of the separators section in the compile settings for my format and nowhere is there anything remotely looking like a "***".

User avatar
MimeticMouton
Posts: 9049
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sat Oct 10, 2020 4:14 pm Post

There's an option in the compile format designer to use a visible separator, by default * * *, when a blank-line separator falls at the top or bottom of the page; probably this is what you're seeing. When you have your compile settings to output to PDF, double-click the compile format to open it in the compile format designer and go to the Text Layout pane, then take a look at the Empty Lines Across Page Breaks setting and deselect it if it's enabled.
Jennifer Hughes
(MM for short)

od
odalage
Posts: 41
Joined: Fri Jul 29, 2016 2:58 pm
Platform: Mac
Contact:

Sat Oct 10, 2020 4:27 pm Post

Thanks for the tip.
I'll try it.

od
odalage
Posts: 41
Joined: Fri Jul 29, 2016 2:58 pm
Platform: Mac
Contact:

Sat Oct 10, 2020 4:34 pm Post

Thanks again, that's it. For some odd reason, it never happened in the past but thanks to you, I have now solved this irritant.
O.