macOS Big Sur and Dark Mode

Posts: 28
Joined: Wed Jan 25, 2012 2:15 am
Platform: Mac

Sat Aug 15, 2020 8:40 pm Post

First of all, I understand that I am running the Beta version of the next OS release, macOS 11, Big Sur. This isn't so much a call for technical support as it is a notice that font colors for readability in Dark Mode don't work under Big Sur.

What I mean is that when you have a Dark Theme turned on within Scrivener, the text within the theme is ALWAYS dark. Even if you set it to display as white, or red, or purple text, the text remains black, Black text on a black background isn't very helpful.

This is a whole new OS, so I thought I would send along this little bug sooner rather than later. Keep making the best writing software available.

Thank you for your time.

User avatar
Posts: 178
Joined: Thu Jan 09, 2020 9:22 am
Platform: Mac

Wed Aug 19, 2020 1:23 pm Post

Thanks for the heads up.

It might be worth you holding the Alt/Option key down and going to File>Close Project and Clear Interface Settings to see if that clears the problem. Be aware it will return the project to default view options with all folders closed etc.

Also see if it is the same in a new project.

User avatar
Site Admin
Posts: 20840
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall

Wed Aug 19, 2020 5:19 pm Post

Many thanks for the bug report. For a horrible moment there I thought Apple had removed the function that I have to override to turn the text white (it's custom code I have to add to the text system). Fortunately, it turns out that Apple just changed the function name (meaning my code wasn't getting called at all), so this was an easy fix, and you can rest assured that this will be working again in our Big Sur/Apple Silicon update. In the meantime the only way around it is to choose to "Keep Editors Light" in the Scrivener > Appearance menu.

All the best,
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

Posts: 2
Joined: Sun Oct 07, 2018 9:08 am
Platform: Windows

Sat Oct 03, 2020 8:17 am Post

Thank you! I never noticed that option. Much better than the eye searing Full Light option. Glad it was a simple fix and look forward to the release of the update.