Turn off Auto-Numbering/Paste Plain Text

ps
pseingalt
Posts: 226
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Wed Feb 19, 2020 9:41 am Post

I was under the impression that Scrivener 3.0 uses its own text engine rather than relying on the underlying Mac OS text engine. But:
trying to copy plain (UTF) text from another document.
There's no "copy plain text" option.
Copying activated autonumbering, even though this is set to "None" on the edit bar.
There are no styles to turn off.
Is there a secret setting keeping autonumbering on?

ps
pseingalt
Posts: 226
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Wed Feb 19, 2020 9:43 am Post

I was under the impression that Scrivener 3.0 uses its own text engine rather than relying on the underlying Mac OS text engine. But:
trying to copy plain (UTF) text from another document.
There's no "copy plain text" option.
Copying activated autonumbering, even though this is set to "None" on the edit bar.
Image
There are no styles to turn off.
Is there a secret setting keeping autonumbering on?

Ma
Max44
Posts: 12
Joined: Tue Jan 07, 2020 3:25 pm
Platform: Mac

Wed Feb 19, 2020 11:01 am Post

In the "All Options" area of Compile, check out the "Formatting" pane > Section Layout... It sounds as though you are using a compile format that is set to insert auto-numbering as a title prefix, and you can edit it or remove it there.

ps
pseingalt
Posts: 226
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Wed Feb 19, 2020 11:17 am Post

Max44 wrote:In the "All Options" area of Compile, check out the "Formatting" pane > Section Layout... It sounds as though you are using a compile format that is set to insert auto-numbering as a title prefix, and you can edit it or remove it there.


I'm not compiling. Just drafting a document.

User avatar
xiamenese
Posts: 4690
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Wed Feb 19, 2020 11:27 am Post

pseingalt wrote:I was under the impression that Scrivener 3.0 uses its own text engine rather than relying on the underlying Mac OS text engine. But:
trying to copy plain (UTF) text from another document.
There's no "copy plain text" option.
Copying activated autonumbering, even though this is set to "None" on the edit bar.
Image
There are no styles to turn off.
Is there a secret setting keeping autonumbering on?

No, it does use the Apple text engine still. Have you tried "Paste and Match Style", which matches the style, even "no Style" of your document, not the original—i.e. it is plain text paste?

:)

Mark
The Scrivenato sometimes known as Mr X.
M1 MacBook Air (2021), 11.2.1, 16GB RAM, !TB SSID
iMac 27" (late 2015) 10.15.7, 24GB RAM, 512GB SSID
2017 iPad, iPadOS 14.3, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

ps
pseingalt
Posts: 226
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Wed Feb 19, 2020 12:31 pm Post

Now compiling, and Scrivener has added unwanted numbers to the document.
Numbering was inserted manually in the draft. There is no automatic numbering.
In the Compile => Format section you referred to, there is nothing to turn off that references autonumbering.
The top image is pre-compile, the bottom post-compile.
https://imgur.com/gallery/Y7NgMJk
Image

ps
pseingalt
Posts: 226
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Wed Feb 19, 2020 12:36 pm Post

xiamenese wrote:
pseingalt wrote:I was under the impression that Scrivener 3.0 uses its own text engine rather than relying on the underlying Mac OS text engine. But:
trying to copy plain (UTF) text from another document.
There's no "copy plain text" option.
Copying activated autonumbering, even though this is set to "None" on the edit bar.
Image
There are no styles to turn off.
Is there a secret setting keeping autonumbering on?

No, it does use the Apple text engine still. Have you tried "Paste and Match Style", which matches the style, even "no Style" of your document, not the original—i.e. it is plain text paste?

Keith may understand the internals of Apple's doc engine. I do not. I do not know if the original document had autonumbering on. I suspect that it did. However, in the new document, it did not. Not sure if Paste and Match Style refers to:
--the original document; or
--the destination document in the editing pane in Scrivener.
Using 3.1.5 by the way, on Mac 10.12.6, (please don't suggest an upgrade, I'll lose ntfs file system access).
A compile to text option would work, rtf has autonumbering.
Is there a compile to text option? Going to look now, but I didn't see a preset.

:)

Mark

ps
pseingalt
Posts: 226
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Wed Feb 19, 2020 12:52 pm Post

The internal Scrivener "Modern" compile setting to .docx still inserted unwanted paragraph numbers.
Tried the screenplay setting, just for the hell of it. Screenplays don't have outlines or numbered lines, right? They are plain text documents, right? No matter. Scrivener still inserted unwanted paragraph numbers.
Tried the "Manuscript (Times)" internal setting. No matter. Scrivener still inserted unwanted paragraph numbers.
Tried the "Enumerated Outline" option--maybe two negatives would cancel each other? No joy. Scrivener still inserted unwanted paragraph numbers.
Tried Modern Outline, but unchecked everything. No matter. Scrivener laughed and added unwanted paragraph numbers.
Opened Word. Is there any way to remove these once Word has put them there?
No.
Same with Textmaker, a Word clone.
And people say, "why do you bother with LaTeX?
Because there you can figure out what is going on.
I haven't used Scrivener for a while, because it just so happens that whenever I use it, "just so happens" that I have a fringe use case which causes, what? Seven compile efforts, two document openings, four forum posts/responses, two posts on a third party image posting site, a failed effort to make a collage. Still no answer. And that pushes me away.

ps
pseingalt
Posts: 226
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Wed Feb 19, 2020 12:59 pm Post

A couple of additional experiments, with odd results.
Compiled to plain text. Scrivener would not be defeated so easily. It added the hated, unwanted, uncommanded paragraph numbers. Why??
Tried pandoc=>Word (docx).
Sending the document through a Haskell black box without even a graphical interface to Word where the autonumbering virus originated, would do what?
Still, the uncommanded, unwanted paragraph numbers were added. BUT
the carefully curated section numbers were all deleted.
Every.
Single
one.
What now?

ps
pseingalt
Posts: 226
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Wed Feb 19, 2020 1:05 pm Post

To clarify:
1. When drafting a document, is there any way to paste plain text besides copying the contents of the clipboard to Emacs/Vim to strip everything out (possibly problematic because I need UTF characters) and then selecting again, copying again, and then, and only then, copying into Scrivener?
1.1 This is during the document drafting process on and in Scrivener.

Hours later...the first draft is finished. Time to circulate the work amongst greater minds.
Try to compile--and unwanted paragraph numbers are added to the entire document.
What setting is causing Scrivener to add these during the compile process? They are not in the draft.
What setting can be turned OFF to insure that these numbers are not generated during compile?
Scrivener for MacOS 3.1.5, Mac v. 10.12.6 ("Sierra")

ps
pseingalt
Posts: 226
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Wed Feb 19, 2020 1:33 pm Post

--Compiling to Markdown didn't work. Same issue.
--Compiling to LaTeX didn't work. Same issue. But at least I could fix it. Doc looks like crap though, all the paragraph separators are gone (a paragraph separator is two carriage returns in LaTeX, which otherwise ignores blank space in a *.tex file. Scrivener stripped those out. Uncommanded.
I think at this point I've tried everything. SOMETHING in Scrivener is adding paragraph numbers and there doesn't appear to be an (obvious) way to remove this already hidden, MCAS-like command.
("They'll never need it, so need to tell them about it.")
Boring update: I can see from the compiled LaTeX file where Scrivener turned on automatic numbering. Unfortunately, I have no idea how to turn it off from inside Scrivener. In the LaTex file, it is easy. But then I'm stuck with a no-collaboration LaTeX file. The contract gods want Word.
ps: Just searched for the word "autonumbering" in the 910 A4 page Scrivener MacOs manual, December, 2019 Revision 3.1.4.1-01.

And
the word is not in the book. "Auto-numbering" is. Search reports an instance of that word on p.154. But it's not there. Same with 179,180. Page 274? Auto-load is not "auto-number." It would appear that RTFM doesn't work here.
Finally, here's something potentially useful:

" Theprefix is using the <$hn> auto-number placeholder to generate1.1,1.1.2, 1.2.4... style numbering to the title. It is surrounded in square brackets and is followed by a tab character. We could use that tab to space the number out from the title further if we wanted."

But alas! the <$hn> prefix is nowhere to be found!

Here's a lead, from page 664:
"As demonstrated in some of our built-in formats, such as “Manuscript (Times)”, a number of captioning shortcuts have been added, so that you needn’t type in full auto-number codes every time you wish to caption or refer to a figure or table. This kind of utility will be useful to many projects."
But in the Manuscript (Times) template, the wicked <$hn> is nowhere to be found.

Then on page 691, this:
Printing with Placeholders and Number Tokens
The basic document print tool will not evaluate placeholder tags or the more complicated uses of auto-number counters in your documents. If you wish to print with these evaluated, you should select the documents you wish to print, and then use File ▸ Compile... with either the Contents tab’s compile group set to “Current Selection”, or the use of “Current Se- lection” as a filter (subsection 23.4.1).

I don't want to evaluate them. I want them off. Unfortunately, there's no explanation in this nearly 1000 page document as to how to do that.

Help=>List of all Placeholders triggers a pop-up which consists of a catalog and a manual concerning how to put these in your document. Great. Now if only there was a way:
--to reveal these hidden characters, so they can be deleted
--a way to delete them from (a) (any) menu bar.
But still
no joy.

ps
pseingalt
Posts: 226
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Wed Feb 19, 2020 2:03 pm Post

Maybe an export to hex; then the errant bytes could be deleted there.
But you would have to know the hex value of that autonumbering (excuse me) auto-numbering code. <$hn>? <$n> or...?

Surely there's an easier way than a hex export.

ps
pseingalt
Posts: 226
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Wed Feb 19, 2020 2:13 pm Post

Finally, a work around:

1. Purchase Vellum. It's only $250, no discounts.
2. Rummage around and find the Scrivener Vellum Export template. This may come with Scrivener, it may be a Vellum add-on; I don't remember.
3. Compile document for Vellum. You will get a .docx file.Vellum can't open anything else.
4. Open document with Vellum. The conversion will, initially look bad. The title pages consisting of one word; there may be a few of them. Keep trashing these until, finally
5. Your document appears as a chapter. Without the extra, uncommanded Scrivener autonumbering. The angels sing.

But you're not finished.

6. File=>Export to RTF (it's the only export choice).
7. Open the rtf file in Word.
8. A little minor tweaking, but your original numbering has been preserved with no unwelcome, uncommanded additions.

One might well wish there was a less complex, less expensive alternative.
But there doesn't seem to be.

Online
User avatar
Silverdragon
Posts: 1755
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac
Location: Tarzana, California, USA
Contact:

Wed Feb 19, 2020 4:24 pm Post

If you haven't yet tried it, "Edit->Paste and March Style" may do what you want. There's a keyboard shortcut but I don't have it memorised.

If you've already tried it, I apologise for taking your time.

Hope this helps!
  • Fiction-writer curled up on her silicon hoard
  • Mac Scrivener 3.2.2, MacBook Air 11, MacOS 10.15.7 (Catalina)
  • iOS Scrivener 1.2.1, iPad 6, iPhone 12 pro, i(Pad)OS 14.4
  • Website: https://silverdrag0n.wordpress.com

ps
pseingalt
Posts: 226
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Thu Feb 20, 2020 7:13 am Post

Anyone? Bueller?