Page 1 of 1

Straight and curly quotes

Posted: Sun Sep 15, 2019 8:43 pm
by johnro
My Scrivener MS seems to insert both straight and curly quotes in text. Several examples here, one of which is highlighted.
Screen Shot 2019-09-15 at 3.38.07 PM.png
example of quote marks
Screen Shot 2019-09-15 at 3.38.07 PM.png (59.1 KiB) Viewed 369 times
. I have almost always been drafting in TNR 12, which should always give curly quotes. I know I can fix this by compiling to Word, then doing a project replace quote mark with quote mark (which would seem to do nothing, but works). Is there any way to fix this in Scrivener?

Re: Straight and curly quotes

Posted: Mon Sep 16, 2019 10:54 am
by AmberV
It could be you got hit with the spellcheck/autocorrect bug that sometimes appears. That would be the best explanation for sporadic differences in punctuation like this.

At any rate, yes these are very easy to clean up in Scrivener: Edit ▸ Transformations ▸ Convert Quotes to Smart Quotes.

Re: Straight and curly quotes

Posted: Mon Sep 16, 2019 1:15 pm
by johnro
Damn. I should have known that! :oops: Thank you.

Re: Straight and curly quotes

Posted: Sun Sep 22, 2019 2:07 am
by Jack Daniel
Are you using Linguistic Focus? We've recently discovered that when this is invoked, quotes are added straight, but then the immediate conversion to curly does not happen, especially in Compose mode.

You have to then turn off LF, and sometimes you have to add a space after the quote mark, briefly, to get it to change to curly.

Until that is addressed, It might be a good idea to do a 'straight to curly' transformation to the entire document once completed.

Re: Straight and curly quotes

Posted: Sun Sep 22, 2019 2:19 am
by johnro
Aha. I did the transformation on the whole ms and it didn’t remove all straight quotes. Unaware of Linguistic Focus. Will check it out. Thanks

Re: Straight and curly quotes

Posted: Thu Oct 03, 2019 10:52 pm
by Jack Daniel
I've found that process a bit tricky, as well.

The way I see it, you must set the Binder so that all docs are open (none are nested shut). Then select all docs in the Binder, so that the entire thing (or manuscript) is highlighted, then click in the editor, and use Command > A to select all, then go to the menu to change the quotes to curly.

So there are 5 steps to this process. But it does seem to always change all straights to curlies, in my experience.