A Little Laggy

Da
David G.
Posts: 137
Joined: Sat Jun 04, 2011 3:21 pm
Platform: Mac

Fri Jul 19, 2019 12:13 pm Post

I am now fully engaged with Scrivener on a writing project. Checking the quick search bar, I am at approx. 40,000 words. I have six or so graphics placed here or there to help me clarify my points. I mention all this in case it helps with understanding the problem.

Scrivener has become a little laggy and it is very annoying. By this I mean that when I hit a line return, when I paste, etc., the app sits there doing nothing for about 5-10 seconds or so - I haven’t timed it. When it does this I have to be patient and stop writing and .. wait… for Scrivener.

Once this occurs it seems to only have stopped what I was trying to do for the moment and then it continues to respond as normal. That is, after a period of time the lag will happen, I have to pause, then I can continue to type as normal without a pause. Then before too long, it will happen again, and again, and again.

Since this is continuing to occur but it is not continual once it does occur, I am wondering if I have something set in Scrivener preferences that I could adjust such as, it is internally backing up too often or, it needs to have a memory ceiling reset or … well, I don't actually know - hence this post.

So far I can live with the problem, but I am already losing my hair too fast, and banging my head against the wall isn't helping. (just kidding) ;-)

But this is clearly a problem and, it is really annoying.

Thanks

Online
User avatar
lunk
Posts: 3438
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Fri Jul 19, 2019 12:38 pm Post

Do you have very many or very few subdocuments in the binder?
When the problem occurs, are you using scrivenings mode in the editor or composition mode or single document mode in the editor?
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, all running the latest MacOS
* iOS Scrivener 1 on an iPhone 8, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS

Online
User avatar
kewms
Posts: 4995
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Fri Jul 19, 2019 3:59 pm Post

What is your autosave interval? You can find it in the Scrivener -> Preferences -> General -> Saving pane.

The default interval is very short, and can cause exactly the behavior you're seeing: Scrivener thinks you've paused and tries to save.

Katherine
Scrivener Support Team

Da
David G.
Posts: 137
Joined: Sat Jun 04, 2011 3:21 pm
Platform: Mac

Fri Jul 19, 2019 4:06 pm Post

lunk wrote:Do you have very many or very few subdocuments in the binder?
I have more than a few subfolders now - actually, I meant dragging files onto other files to create a folder like structure. I have been assembling this document using separate sections and then placing the sections according to an outline applied in the Binder.

lunk wrote:When the problem occurs, are you using scrivenings mode in the editor or composition mode or single document mode in the editor?
I have no idea. This is a single text editor pane with the Binder showing or hidden at my pleasure to the left. This is selecting multiple items in the Binder, reviewing many sections, and editing many selected sections like this at the same time. I love it that I can select non-sequential sections in this manor with Scrivener as this allows me to see if an idea is being repeated elsewhere and if it is, that it follows my earlier logic.

Da
David G.
Posts: 137
Joined: Sat Jun 04, 2011 3:21 pm
Platform: Mac

Fri Jul 19, 2019 4:08 pm Post

kewms wrote:What is your autosave interval? You can find it in the Scrivener -> Preferences -> General -> Saving pane.

The default interval is very short, and can cause exactly the behavior you're seeing: Scrivener thinks you've paused and tries to save.

Katherine

Yes, I would say so, It is set to auto save after 2 seconds of inactivity. This is the default I assume? As I tend to save often as part of my writing habit - and only when I am not writing, I will probably extend this to 30 minutes or more.

Online
User avatar
lunk
Posts: 3438
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Fri Jul 19, 2019 4:18 pm Post

David G. wrote: As I tend to save often as part of my writing habit - and only when I am not writing, I will probably extend this to 30 minutes or more.

No, don’t. If you do that it means that Scrivener will inly save when you have been inactive for 30 minutes! The time tells Scrivener how long inactivity from it takes to autosave. You don’t have to do manual save because Scrivener does it for you. But if it saves to often, set the time to 5 or 10 seconds. That way it will only save when you stop to think, not when you suddenly just write slowly.
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, all running the latest MacOS
* iOS Scrivener 1 on an iPhone 8, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS

Da
David G.
Posts: 137
Joined: Sat Jun 04, 2011 3:21 pm
Platform: Mac

Fri Jul 19, 2019 4:23 pm Post

lunk wrote:
David G. wrote: As I tend to save often as part of my writing habit - and only when I am not writing, I will probably extend this to 30 minutes or more.

No, don’t. If you do that it means that Scrivener will inly save when you have been inactive for 30 minutes! The time tells Scrivener how long inactivity from it takes to autosave. You don’t have to do manual save because Scrivener does it for you. But if it saves to often, set the time to 5 or 10 seconds. That way it will only save when you stop to think, not when you suddenly just write slowly.

Worth thinking about. Thanks.

Online
User avatar
kewms
Posts: 4995
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Fri Jul 19, 2019 4:26 pm Post

FWIW, mine is set to 10 seconds. 2 seconds is definitely too short.

As lunk said, you don't want an extremely long interval because it sort of defeats the purpose. Although that's less important if you have the habit of manually saving every page or so.

Katherine
Scrivener Support Team