Speech numbering in scriptwriting mode

km
km85264
Posts: 6
Joined: Tue Dec 20, 2011 6:02 pm
Platform: Mac

Wed Jul 17, 2019 10:44 pm Post

I'm hoping to enter a radio play competition where the presentation guidelines are quite explicit: "For ease of reference, the pages of a script should be numbered consecu- tively throughout. Please note that each speech should be numbered and each new page should begin with speech number 1."
See https://static.rasset.ie/documents/dram ... -final.pdf for a visual example.
I have found an option under Format->Script Writing->Script Settings which allows Sequential Numbering on the left or the right for Dialogue or Character&Dialogue, but I'm having two problems: When I print to PDF, the line numbers only show up when there is a transition to Character/Dialogue from something else, for example:
FX: CAR DRIVING ON NARROW, POTHOLED AND TWISTY COUNTRY ROAD (General Text)
2 MIKE: Rotten old road, this. (Dialogue has a line number)
MAL: Yes(Dialogue, No line number)
EVELYN: What?(again, no line number)
General text (General text)
3 EVELYN:(Absently) Aye. (And the line number appears again, apparently because it follows general text)
Am I missing something fundamental, or have I found a bug?
Second thing is that the line numbers do not reset at the end of a printed page per the guidelines; is there a setting somewhere that might change that behaviour.
I guess I can get around this by exporting to Word then manually entering the line numbers, but that's going be a real pain. Is it possible to achieve this in Scrivener? If not, any recommendations on an app that would do it?
(Scrivener 3.1.3 on Mac)

km
km85264
Posts: 6
Joined: Tue Dec 20, 2011 6:02 pm
Platform: Mac

Thu Jul 18, 2019 5:42 pm Post

Can anybody advise here? I'm happy to put more work into figuring it out but would hate to find I had been wasting my time and it's not possible
Thanks
Kieran

User avatar
gr
Posts: 1985
Joined: Wed Feb 14, 2007 3:57 am
Platform: Mac + iOS
Location: Florida

Thu Jul 18, 2019 6:53 pm Post

You can do this by incorporating the <$np> placeholder (followed by a couple of spaces) into your script format settings. Alter your Script Settings somewhat as follows, then compile and see. This only works if you are compiling to pdf or print, though, but I think for your purposes that should be okay.
--gr

01 script setting.jpeg
01 script setting.jpeg (74.48 KiB) Viewed 164 times



02 script setting.jpeg
02 script setting.jpeg (80.48 KiB) Viewed 164 times
gr : Scrivener user : not affiliated with Lit^Lat
Image
"Nothing, like something, happens anywhere." —Philip Larkin

km
km85264
Posts: 6
Joined: Tue Dec 20, 2011 6:02 pm
Platform: Mac

Fri Jul 19, 2019 7:59 am Post

Brilliant, many thanks GR that is exactly what I need :D

User avatar
gr
Posts: 1985
Joined: Wed Feb 14, 2007 3:57 am
Platform: Mac + iOS
Location: Florida

Fri Jul 19, 2019 1:00 pm Post

My pleasure. Good luck in that competition!

—gr
gr : Scrivener user : not affiliated with Lit^Lat
Image
"Nothing, like something, happens anywhere." —Philip Larkin