Turn off word suggestions

User avatar
Starsky
Posts: 2
Joined: Wed Jul 17, 2019 6:34 pm
Platform: Mac

Wed Jul 17, 2019 6:39 pm Post

I'm trying to turn off the word suggestions that appear below the line as I'm typing, because they distract me as I'm writing. I've tried Preferences > Corrections > Uncheck "Suggest completions as you type", but that doesn't seem to do anything. I've unchecked everything below "Suggest completions as you type", and then unchecked "Suggest completions" too, and then rebooted Scrivener, and that didn't help either. I looked in the Project Settings area and the Auto-Complete list is completely blank. Any ideas how I can disable this feature? Thank you!

User avatar
lunk
Posts: 3433
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Wed Jul 17, 2019 8:42 pm Post

System settings..?
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, all running the latest MacOS
* iOS Scrivener 1 on an iPhone 8, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS

User avatar
Silverdragon
Posts: 1080
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Wed Jul 17, 2019 9:29 pm Post

Turn off Edit > Spelling and Grammar > Check Spelling While Typing.
So you know where I'm coming from:
  • I'm a user, not an L&L employee.
  • Mac Scrivener 3.1.3, MacBook Air 11, MacOS 10.14.6 (Mojave)
  • IOS Scrivener 1.1.5; iPhone 8 Plus, iOS 12.4; iPad 6th gen, iOS 12.4

User avatar
Starsky
Posts: 2
Joined: Wed Jul 17, 2019 6:34 pm
Platform: Mac

Thu Jul 18, 2019 2:17 pm Post

Silverdragon wrote:Turn off Edit > Spelling and Grammar > Check Spelling While Typing.


Thank you! That seems to have worked. It stinks that I guess Scrivener won't autocorrect spelling errors now, nor notice them, but it's good that the annoying word suggestion popups are gone. What a choice, there. No popup words = no spell check! :shock:

Thank you so much for letting me know how to fix those popup word suggestions. I appreciate the help!

sc
scshrugged
Posts: 424
Joined: Wed Feb 10, 2016 6:55 pm
Platform: Mac + iOS

Thu Jul 18, 2019 3:24 pm Post

Your Auto-Completion preferences aren't acting normally. You should be able to use Check Spelling without seeing the suggestions. I'd try resetting Scrivener preferences as described in this L&L Knowledge Base article:
https://scrivener.tenderapp.com/help/kb ... references

As the article notes, make sure at the start to save your current preferences through the Manage dropdown (and backup, of course).
I'm a Scrivener user, not an L&L employee.

User avatar
Silverdragon
Posts: 1080
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Thu Jul 18, 2019 4:11 pm Post

We're not talking about auto completion here. We're talking about macOS's ordinary spell check while typing, which you can see in Textedit, et al. With respect, @starsky confused the little Mac pop-up (which has an "x"-shaped close button at the left and only ever provides one option) with Scrivener 's auto completion (which, unless you're doing a screenplay, is off by default and requires the user to provide a list of items to be completed.)
So you know where I'm coming from:
  • I'm a user, not an L&L employee.
  • Mac Scrivener 3.1.3, MacBook Air 11, MacOS 10.14.6 (Mojave)
  • IOS Scrivener 1.1.5; iPhone 8 Plus, iOS 12.4; iPad 6th gen, iOS 12.4

User avatar
AmberV
Posts: 23244
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Thu Jul 18, 2019 4:46 pm Post

There are two types of prompt that can come up while you type. Scrivener’s is referred to as “completion”, which is tied into the Project Settings pane, under Auto-Completion. By default these will never appear unless you specifically call upon them, with the Edit ▸ Completions ▸ Complete menu command, or if you use Scriptwriting mode. The appearance of this function is like a menu that pops down from the word, in vertical format, where you can arrow between options and press Return to select one.

The other type of prompt comes from macOS, and that looks more like an iOS type thing, with a little blue bubble that appears and generally only provides one option to choose from. That I believe can be disabled system-wide in the System Preferences: Keyboard: Text pane, with Correct spelling automatically.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

sc
scshrugged
Posts: 424
Joined: Wed Feb 10, 2016 6:55 pm
Platform: Mac + iOS

Thu Jul 18, 2019 5:17 pm Post

I managed to get confused by the original post. I should’ve asked. If it is just a matter of check spelling, Starsky and any onlookers, ignore my earlier post about resetting preferences.

I’m sorry for any confusion I might have introduced.
I'm a Scrivener user, not an L&L employee.

User avatar
Silverdragon
Posts: 1080
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Thu Jul 18, 2019 5:45 pm Post

No problem, scshrugged! My response came across as a bit curmudgeonly, for which I apologize.
So you know where I'm coming from:
  • I'm a user, not an L&L employee.
  • Mac Scrivener 3.1.3, MacBook Air 11, MacOS 10.14.6 (Mojave)
  • IOS Scrivener 1.1.5; iPhone 8 Plus, iOS 12.4; iPad 6th gen, iOS 12.4