Compile goofing up

TK
TKBounds
Posts: 7
Joined: Fri May 31, 2019 10:44 pm
Platform: Mac

Wed Jul 10, 2019 9:28 pm Post

When I do a compile, whether I output directly to a printer or to a .rtf, I don't get the double-spacing between lines I used to. How do I fix this?

Online
User avatar
lunk
Posts: 3438
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Wed Jul 10, 2019 10:13 pm Post

When you assign and format the section type in Compile, you find line- and paragraph spacing in the ordinary top menu, Format, i.e. the same way you do it when formatting in the editor.
Just put the cursor in the example text (like when you decide on font), and the Format etc
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, all running the latest MacOS
* iOS Scrivener 1 on an iPhone 8, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS

Online
User avatar
kewms
Posts: 4994
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Wed Jul 10, 2019 10:48 pm Post

If you've done most of your formatting in the editor, you may find that the "Default" Compile format is the best place to start. It ignores most of the capabilities of the Compile command, just passing your text straight through.

You can also use the Print Current Document command to print whatever is in the current editor exactly as it appears on your screen. That's my go-to command for draft copies for my own use.

Katherine
Scrivener Support Team

User avatar
gr
Posts: 1993
Joined: Wed Feb 14, 2007 3:57 am
Platform: Mac + iOS
Location: Florida

Thu Jul 11, 2019 3:29 am Post

TKBounds wrote:I don't get the double-spacing between lines I used to.


When you say “used to”, do you mean before Scriv 3 or do you mean something is mysteriously different since then?
gr : Scrivener user : not affiliated with Lit^Lat
Image
"Nothing, like something, happens anywhere." —Philip Larkin

TK
TKBounds
Posts: 7
Joined: Fri May 31, 2019 10:44 pm
Platform: Mac

Tue Jul 16, 2019 2:54 am Post

gr wrote:
TKBounds wrote:I don't get the double-spacing between lines I used to.


When you say “used to”, do you mean before Scriv 3 or do you mean something is mysteriously different since then?


With Scriv 3 , when I select Compile from the File menu, Short Story (courier) is selected under Formats/Project Formats. I double click Section Layouts and set the Formatting to double (2.0) spacing for the Scene Text and Save the new setting. The spacing does not take and defaults to 1.2 when I compile directly to print or save to a .rtf.

Do I need to set/reset something in that format to get the output I want? The weird thing is compiles put out things the way I wanted them until recently with 3.0.

I need the double-spacing for critique copies.

Online
User avatar
lunk
Posts: 3438
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Tue Jul 16, 2019 10:10 am Post

TKBounds wrote:[I double click Section Layouts and set the Formatting to double (2.0) spacing for the Scene Text and Save the new setting. The spacing does not take and defaults to 1.2 when I compile directly to print or save to a .rtf.

compile sets the format for Compile, and only for the exact setting/output for which you set the format. It sounds as if you are doing something else. Are you setting things up in Compile and then exporting or something like that?

Have you done the interactive tutorial, the part about Compile?
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, all running the latest MacOS
* iOS Scrivener 1 on an iPhone 8, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS

User avatar
gr
Posts: 1993
Joined: Wed Feb 14, 2007 3:57 am
Platform: Mac + iOS
Location: Florida

Tue Jul 16, 2019 12:36 pm Post

TKBounds wrote:With Scriv 3 , when I select Compile from the File menu, Short Story (courier) is selected under Formats/Project Formats. I double click Section Layouts and set the Formatting to double (2.0) spacing for the Scene Text and Save the new setting. The spacing does not take and defaults to 1.2 when I compile directly to print or save to a .rtf.


Here are two factors I can think of that would result in your adjustment not seeing the light of day:

1) In the format settings of Section Layout > Scene Text, the Override checkbox is not checked.

2) Your documents have a Section Type that is not being assigned to the Section Layout you have adjusted (Scene Text). Check the Inspector or the rightmost panel of the Compile dialog box to see what Section Type your docs have. Then, in the middle panel of the Compile dialog, check to see if that Type is being assigned to the Section Format you think it is (Scene Text).
gr : Scrivener user : not affiliated with Lit^Lat
Image
"Nothing, like something, happens anywhere." —Philip Larkin