Good morning -- compile question

Ju
JudiPhil
Posts: 2
Joined: Fri Jul 05, 2019 12:46 pm
Platform: Mac

Fri Jul 05, 2019 1:01 pm Post

While I love writing in Scrivener 3, I find compiling in it beyond difficult and am struggling to figure it out. Right now, I'm trying to compile a project to publish an e-book on Amazon. I prefer to write in double spacing because it's much easier to edit that way, I want to publish in single spacing with paragraphs indented. I spent more hours that I want to report--most of a day-- trying to figure out various other aspects of the compile and was successful, but I cannot figure out how to make it output to single spacing with paragraphs indented. Any help would be gratefully appreciated.

User avatar
lunk
Posts: 3478
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Fri Jul 05, 2019 1:17 pm Post

When you are setting up compile, when setting font etc for the text, simply click the Format in the top menu, as if you were in the Editor, and change line and paragraph spacing.
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, all running the latest MacOS
* iOS Scrivener 1 on an iPhone 8, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS

User avatar
gr
Posts: 2023
Joined: Wed Feb 14, 2007 3:57 am
Platform: Mac + iOS
Location: Florida

Fri Jul 05, 2019 5:00 pm Post

As lunk says, when you are in this place shown below in compile settings, Format > Paragraph > Line and Paragraph Spacing brings up those parameters for the format-setting paragraph pictured there. You can also just pick your linespacing from the (familiar) pop-up menu noted here, or call up the whole dialog box by choosing Other... off that same pop-up.

linespacing.png
linespacing.png (385.73 KiB) Viewed 196 times
gr : Scrivener user : not affiliated with Lit^Lat
Image
"Nothing, like something, happens anywhere." —Philip Larkin

Ju
JudiPhil
Posts: 2
Joined: Fri Jul 05, 2019 12:46 pm
Platform: Mac

Fri Jul 05, 2019 7:29 pm Post

Thanks for the screenshot. But I think that's what I've done.

I've attached 3 screen shots and labeled them. Unfortunately, I added them so they're in reverse order.

With both of the output files I used the same setting as the compile screenshot.

Any suggestions as to what I'm doing wrong?

Thanks for your help
Attachments
Screenshot 2019-07-05 13.20.28.png
This is the file compiled which is double spaced with paragraphing indent
Screenshot 2019-07-05 13.20.28.png (72.2 KiB) Viewed 183 times
Screenshot 2019-07-05 13.15.58.png
This is the file compiled which is single spaced with no paragraphing
Screenshot 2019-07-05 13.15.58.png (135.86 KiB) Viewed 183 times
Screenshot 2019-07-05 13.01.25.png
This is the screen shot of my compile window
Screenshot 2019-07-05 13.01.25.png (134.6 KiB) Viewed 183 times

User avatar
kewms
Posts: 5161
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Fri Jul 05, 2019 7:34 pm Post

Down at the very bottom, where it says "text and notes use default formatting?" That's the problem. You need to override the Editor formatting. See GR's screenshot.

Katherine
Scrivener Support Team

User avatar
lunk
Posts: 3478
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Fri Jul 05, 2019 7:37 pm Post

At the bottom, you tell Scrivener to use the default formatting. Change to ”override” something (don’tbremember the exact wording)
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, all running the latest MacOS
* iOS Scrivener 1 on an iPhone 8, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS