Spelling check(set to automatic language) stopped working suddenly

an
angrygymnast
Posts: 4
Joined: Thu Jun 13, 2019 2:15 am
Platform: Mac

Thu Jun 13, 2019 2:36 am Post

I am writing my Thesis, I'm 5-6 pages away from reaching my goal. But my scrivener project decided that it would not check the languages I'm writing with simultaneously. I am studing a BA in English. The Thesis is in Spanish but we have to quote the original text in English (Duh!).

I've been using scrivener for more than 6 years or so. This is the first time that this ever happens to me and I really don't know what I did, I was typing a paragraph and suddenly some of the English words were underlined (they are correctly typed). I though I had clicked on something but my settings are like normal (they are set to automatic language).

I'm attaching some evidence, Just click on the link it will direct you to my dropbox.

https://www.dropbox.com/s/ak66wfh7ouztb ... 8.png?dl=0

If I open another document (a new blank document, not project) the 'set to automatic language' works fine.
So I thought I'd paste it and transfer the research to a blank document. But nope, the bug is there.

Also ALL the rest of my work got underlined (english quotes). I really need to have my document back the way it was. It's really helpful to have my spelling mistakes underlined in case I miss them (I wear glasses so it does come handy) .

https://www.dropbox.com/s/1ya07i2klstf3 ... 9.png?dl=0

Please if anyone has an answer to this dilemma I will greatly appreciate it. I still have to write the introduction and I can't believe the program is doing this.

I already did the following:
I restarted scrivener.
Restarted the computer
un clicked spelling check, restarted everything.
System preferences is se to automatic language as well.

I really don't know what I'm doing wrong. PLEASE HELP ME.

Copy pasting is not cutting it. it is just copy pasting the bug to any new document or project I opened, despite the new document or project is working fine. and this started all of the sudden.

ETA: I have two computers. This is happening on my laptop computer only (macbook pro). as soon as I wrote this post, I went to check on my iMac and the file looks as usual. I don't know what is wrong. The settings are the same.

User avatar
kewms
Posts: 6223
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Thu Jun 13, 2019 5:42 am Post

What versions of Mac OS do you have on the two computers?

Do you see the same behavior in TextEdit on the problem computer?

Katherine
Scrivener Support Team

an
angrygymnast
Posts: 4
Joined: Thu Jun 13, 2019 2:15 am
Platform: Mac

Thu Jun 13, 2019 5:56 am Post

I have sierra on both computers.

I have on the two computers scrivener 2 (version 3 just works on trial. I have yet to install this version on my iMac).

hereby I attach text edit screen capture. works fine. detects spelling mistakes both in english and in spanish

https://www.dropbox.com/s/upg4gcp102ak3 ... 1.png?dl=0

This is text edit with fresh text (above) and copied text from scrivener (below). You can see that the one on top detects both languages but the one below with the copy pasted text from scrivener doesn't.

https://www.dropbox.com/s/3n51iid2hr415 ... 4.png?dl=0

I believe this is an issue with the dictionaries of the program or something as I opened old proyects and all of them have the same issue. HOWEVER, if I start a new project or a new document and type in both languages I have no problem... whereas if I copy paste sections of the troublesome text, I have the issue again.

https://www.dropbox.com/s/cvz5n72xn830h ... 7.png?dl=0

you can see in the image above scrivener 3 on trial on macbook pro. on one side there is a brand new project it detects both the languages. on the other side the copy pasted thingie. I noticed the blockquote text does not have that issue (the one highlighted in yellow).In any case like I said all previous documents or projects show this bug on the Macbook, I don't know why. This happens as well on the scrivener 2 program.

No issue whatsoever on my iMac though.