Help with Block Quotes

Ci
Cinder6
Posts: 146
Joined: Mon Feb 22, 2010 10:04 pm

Sat Dec 15, 2018 8:32 pm Post

I'm using the Paperback 6x9 compile preset, and I'd like to learn how to change two aspects of block quotes. First, I want to know if there's a way to add a line break before and after the quote; second, I want to indent the first paragraph after the quote.
Attachments
compiled.png
compiled.png (190.42 KiB) Viewed 2039 times
draft.png
draft.png (145.83 KiB) Viewed 2039 times

User avatar
AmberV
Posts: 23800
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Dec 17, 2018 6:07 pm Post

Both of these requests should be easy to achieve with a little customisation. For each you will find the relevant settings in the Styles compile format pane, so load up the compile format designer and head there, clicking on the “Block Quote” entry in the style list.

  • Paragraph spacing: normally some use of paragraph spacing would be the best way to approach this problem, but Scrivener unfortunately does not have an understanding of styled ranges of text as being a single entity. You can’t say: put 12pts of space before it and 12pts after—you can say put that much space around each paragraph in the block quote though (incidentally, that’s the method we use in the main editor, for the stock “Block Quote” example style). If your block quotes are limited to one paragraph at a time then this is definitely the method I’d use:

    1. Click into the sample text area to activate the formatting controls.
    2. Use the Format ▸ Paragraph ▸ Paragraph and Line Spacing... menu command.
    3. Add your spacing to the Paragraph spacing before and after fields.

    But if that doesn’t work in your favour, then the Prefix/suffix fields, in the style options sidebar is where you’ll want to fix this. You can insert a carriage return with ⌥↩. Just be aware that literal empty lines may cause issues in some cases. It will be worth proofing around them once you get to the desktop publishing phase. You may even find it’s best to not do this in Scrivener, and wait until the document is in a DTP program, where style settings can be applied to contiguous paragraphs as one entity.
  • Indent suppression: you’ve probably already spotted it, but if not, check the style sidebar and disable, Flatted next indent.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Ci
Cinder6
Posts: 146
Joined: Mon Feb 22, 2010 10:04 pm

Wed Dec 19, 2018 12:49 am Post

Thank you. Both of those helped. Unfortunately, it looks like adding the carriage return before/after the block quote also adds an indent to the first quoted paragraph. I do have "flatten first indent" checked; removing the carriage returns fixes it.

User avatar
AmberV
Posts: 23800
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Wed Dec 19, 2018 6:33 pm Post

Good point, that’s one of the ways in which empty lines for formatting effect can make a mess of things. :) I hadn’t considered the effect undesirable. In this case the flattening is being applied to the empty line, which is considered a part of the content of the block quote, and therefore the first line; can’t think of a way around that.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles