Ignoring the time zone change in custom metadata = reverting to today's date

ef
efm
Posts: 1
Joined: Mon Dec 10, 2018 11:31 am
Platform: Mac

Mon Dec 10, 2018 12:08 pm Post

I recently spent three months in a different timezone (America), writing the first half of a novel. I use the custom metadata tag to keep track of what date/time different scenes are happening. This is fictional, and therefore doesn't need to be linked to timezones – in fact, the last thing I want is for the dates/times to change automatically! Now I'm back in the UK, all the metadata time tags are five hours out, because I guess they were adjusted for the UK timezone. I found the 'Ignore time zone change' tick box in the custom metadata settings, but if I click this then all of the date tags on my scenes set to today's date (a disaster! I thought I had lost the whole timeline of my book... Luckily, unticking the box reverts the dates to their original form). At the moment I'm using a workaround, setting my mac to American eastern time so I can see the correct times on my scenes. Obviously this isn't a longterm solution though! Would really appreciate any tips/better workarounds.

Thanks,
E

Online
User avatar
AmberV
Posts: 24312
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Dec 10, 2018 6:52 pm Post

Thanks for the report! I’ve noted a few odd things about this setting beyond what you reported (I can reproduce that easily enough). We’ll take a look at it.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
Silverdragon
Posts: 1539
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Tue Dec 11, 2018 8:02 pm Post

Great to hear! I've run into problems with this setting (novel set in 1880s London; writing from California et al.) and had to depend on Aeon Timeline to catch it—a luxury I'm sure many don't have.
  • Fiction-writer curled up on her TP hoard.
  • Mac Scrivener 3.1.5, MacBook Air 11, MacOS 10.15.6 (Catalina)
  • IOS Scrivener 1.2.1; iPhone 8+, iPad 6; i(Pad)OS 13.6
  • Website: https://silverdrag0n.wordpress.com

Online
User avatar
AmberV
Posts: 24312
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Tue Dec 11, 2018 9:34 pm Post

And I'm pleased to report it will be fixed in the next update. We found a few other oddities and got them cleaned up as well.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

En
EndlessLoop
Posts: 76
Joined: Wed May 28, 2014 5:02 am
Platform: Mac

Tue Jan 08, 2019 2:25 am Post

AmberV wrote:And I'm pleased to report it will be fixed in the next update. We found a few other oddities and got them cleaned up as well.


You may have already found this oddity, but in case you haven't:

I have a metadata date field pulled in from Aeon -- which automatically sets the field with the ignore toggle on. If I have the field in the Outliner as a column fully expanded, it shows the right date, as shown here:

full.png
full.png (10.58 KiB) Viewed 4469 times


However, if I contract the field, if the time is after what I'm guessing is a certain time UTC*, it bumps the date to the next day, as shown here:

compact.png
compact.png (9.76 KiB) Viewed 4469 times


*(I'm in Australia. At the moment, this day jump only happens with times >= 2pm which is 3am UTC this time of year),

Is this one of the things you'd already found?

User avatar
KB
Site Admin
Posts: 20775
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Jan 08, 2019 12:45 pm Post

Could you please check the Project Settings to see if this date custom metadata field is set to "Ignore time zone changes"? I've just spotted an issue whereby the contracted formats of the dates aren't updated to use the same time zone as the preferred date format if this setting is ticked, which may be the issue here.

Thanks and all the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

En
EndlessLoop
Posts: 76
Joined: Wed May 28, 2014 5:02 am
Platform: Mac

Tue Jan 08, 2019 8:53 pm Post

KB wrote:Could you please check the Project Settings to see if this date custom metadata field is set to "Ignore time zone changes"?


Yup. That's the way it comes in from Aeon (with good reason, obviously). Here's proof (the custom format is my own tampering, but it happens with either my homebaked format or any of the standard ones when "Ignore etc." is selected):

settings.png
settings.png (27.35 KiB) Viewed 4387 times


Once again, it only happens for dates with time components set >= 2pm, which at my location's current daylight saving time makes it 3am UTC. We're +10 standard, +11 DST.

Using 3.1.1, which I forgot to mention originally.

Hope that helps.

User avatar
KB
Site Admin
Posts: 20775
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Wed Jan 09, 2019 12:53 pm Post

Great, thanks for the confirmation. Hopefully this is fixed for 3.1.2, then, as there was a time zone bug here. Let me know if you still see the issue in 3.1.2 when it's out.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

En
EndlessLoop
Posts: 76
Joined: Wed May 28, 2014 5:02 am
Platform: Mac

Wed Jan 09, 2019 10:02 pm Post

KB wrote:Great, thanks for the confirmation. Hopefully this is fixed for 3.1.2, then, as there was a time zone bug here. Let me know if you still see the issue in 3.1.2 when it's out.

All the best,
Keith


Will do. Thanks for the bug splatting.

En
EndlessLoop
Posts: 76
Joined: Wed May 28, 2014 5:02 am
Platform: Mac

Thu Feb 21, 2019 12:29 am Post

KB wrote:Let me know if you still see the issue in 3.1.2 when it's out.


Ok, contracting columns is no longer an issue, but...

... something weird is happening with Aeon/Scrivener syncing after the update (at least for me). I'll explain in screenshots

Here's an event created in Aeon with date and time:

Image

And here are the custom metadata fields that Aeon creates for syncing over to Scriv:

Image

Here is how they appear in Scriv in the Metadata tab in the Inspector when I click on the settings cog. " Ignore time
zone changes" is ticked by default :

Image

But the times/dates and dates in Scriv have jumped *forward* 11 hours (my current timezone is UTC +11):

Image

If I create a doc in Scriv and enter dates and times like so:

Image

... it syncs over fine into Aeon:

Image

... but when I go back to Scriv after the sync the time jump has hit that doc as well:

Image

... but everything remains fine in Aeon:

Image
Image

I've tried it both with and without "Ignore time zone changes", and the shift behaviour stays the same.

Let me know if you need any further info.

User avatar
KB
Site Admin
Posts: 20775
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Fri Mar 08, 2019 11:53 am Post

After a bit of investigation (thanks to Ioa), it turns out that this is because Scrivener's file format requires the microseconds to be included for custom meta-data dates, but Aeon is omitting these. (This isn't Aeon's fault, as it seems I forgot to update the file format specs with this requirement.) I have therefore added a workaround to the next update which makes the microseconds optional, so that the date will work properly without them.

Thanks and all the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

En
EndlessLoop
Posts: 76
Joined: Wed May 28, 2014 5:02 am
Platform: Mac

Fri Mar 08, 2019 8:58 pm Post

KB wrote:) I have therefore added a workaround to the next update which makes the microseconds optional, so that the date will work properly without them.

Thanks and all the best,
Keith


Great! Looking forward to it.Thanks to the two of you.

se
se1961
Posts: 151
Joined: Tue Jul 05, 2011 8:00 pm
Platform: Mac

Sun Apr 21, 2019 5:20 pm Post

Hi! I believe I am having a related problem, but I can't quite pin it down. I have always been able to successfully sync Scrivener and Aeon files. On my current project, all of my Aeon events are showing up in Scrivener with the custom metadata field set for four hours earlier. I am writing and syncing in the same timezone (EST) as I always have. "Ignore timezone changes" is ticked. I'm baffled, and a little stuck. I'm using Scrivener 3.1.2 and Aeon 2.3.16. Any help would be somewhat urgently appreciated, as I am unable to use the sync feature at all at the moment. ☹️

User avatar
Silverdragon
Posts: 1539
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Sun Apr 21, 2019 8:04 pm Post

I find that the only way currently to get this working is to force Scrivener to use plain text fields instead of date-type fields. What I did:

  • In Aeon, with my project's sync panel open, I clicked the gear icon in the upper right corner to open the project sync settings.
  • I set both Start Date and End Date to None. While the Aeon events still contained the dates, this stopped Aeon from writing them to my Scrivener metadata temporarily.
  • I closed the project's sync panel in Aeon, and opened the project in Scrivener.
  • Then I opened Project > Project Settings… > Custom Metadata. I deleted the old Start and End fields.
  • I added new Start and End fields with slightly different names and made sure that they were plain text, single line. (See screenshot.)
  • Finally I closed the project in Scrivener, opened it again for sync in Aeon, and connected the new text metadata fields to Start Date and End Date in Aeon.

After syncing, the metadata fields in Scrivener had the correct date and time. Of course since they're just text they won't sort correctly in Scriv, but for me that's a small price to pay. :D Maybe after KB distributes the fix he mentioned earlier in this thread I'll switch back to proper date/time fields, but then again, maybe not. Plain text seems to Just Work.
screenshot 2019-04-21 12.54.06.png
screenshot 2019-04-21 12.54.06.png (119.41 KiB) Viewed 950 times
  • Fiction-writer curled up on her TP hoard.
  • Mac Scrivener 3.1.5, MacBook Air 11, MacOS 10.15.6 (Catalina)
  • IOS Scrivener 1.2.1; iPhone 8+, iPad 6; i(Pad)OS 13.6
  • Website: https://silverdrag0n.wordpress.com

se
se1961
Posts: 151
Joined: Tue Jul 05, 2011 8:00 pm
Platform: Mac

Mon Apr 22, 2019 3:41 pm Post

@silverdragon Thank you so much for replying so quickly. I very much appreciate your quick and friendly answers, in other threads as well. In fact, as I read THIS whole thread more carefully, and then looked up "what is my time zone relative to UTC?" I discovered that is exactly the offset for me -4 hours. Thanks also to @Endlessloop for including your timezone information, because that allowed me to do a little more digging. I look forward to a fix!