make it so that the option for “view the groups subdocuments as scrivenings” is turned on by default ?

da
danklim
Posts: 17
Joined: Wed Mar 08, 2017 9:08 pm
Platform: Mac

Sun Dec 09, 2018 11:00 pm Post

Hi, how can i make it so that the option for “view the groups subdocuments as scrivenings” is turned on by default ? Also, after changing whatever setting necessary, do i need to save the preset in preferences or anything else? currently, it deselects any time that i go to a different document, and I want to make this always on by default and never have to change it again. thanks.
Attachments
Screen Shot 2018-12-09 at 6.00.48 PM.png
Screen Shot 2018-12-09 at 6.00.48 PM.png (37.11 KiB) Viewed 660 times
Screen Shot 2018-12-09 at 6.00.48 PM.png
Screen Shot 2018-12-09 at 6.00.48 PM.png (37.11 KiB) Viewed 660 times

User avatar
KB
Site Admin
Posts: 20716
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Dec 10, 2018 11:31 am Post

Once you select it in a project, it will remain the default for that project (for that particular editor - the two editors can have a different setting).

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

da
danklim
Posts: 17
Joined: Wed Mar 08, 2017 9:08 pm
Platform: Mac

Sun Jul 21, 2019 1:43 pm Post

KB wrote:Once you select it in a project, it will remain the default for that project (for that particular editor - the two editors can have a different setting).

All the best,
Keith


Thank you. This solves the issue partially but not completely. Once I select this setting/option for the project, the largest/default (the ones called "drafts"," research", and "trash" documents remain in the setting by default. However, subdocuments (that have more subdocuments underneath them) under/in these documents keep defaulting back to having the option/setting Off for “view the groups subdocuments as scrivenings”. It turns off for these subdocuments every time that I click on a different document.

How can I make it so that the setting is always On by default for ALL documents?

sc
scshrugged
Posts: 459
Joined: Wed Feb 10, 2016 6:55 pm
Platform: Mac + iOS

Sun Jul 21, 2019 3:52 pm Post

danklim wrote:
Thank you. This solves the issue partially but not completely. Once I select this setting/option for the project, the largest/default (the ones called "drafts"," research", and "trash" documents remain in the setting by default. However, subdocuments (that have more subdocuments underneath them) under/in these documents keep defaulting back to having the option/setting Off for “view the groups subdocuments as scrivenings”. It turns off for these subdocuments every time that I click on a different document.

How can I make it so that the setting is always On by default for ALL documents?

Draft, Research and Trash are folders. You could convert the relevant documents into folders. Or, if I'm understanding you correctly––you prefer to have documents and their children respect scrivenings view mode as default––try the setting at Scrivener Preferences > Behaviors > Folders & Files > Treat all documents with subdocuments as folders

Reference: Manual subsection 7.6 Folders are Files are Folders, and B.4.5 Folders & Files.
I'm a Scrivener user, not an L&L employee.