Quotes to Smart Quotes - any way to automate?

User avatar
Cassady
Posts: 196
Joined: Sun Jun 16, 2013 12:06 pm
Platform: Mac + iOS
Location: Sqornshellous

Mon Jun 25, 2018 10:25 am Post

Hello all,

I did a cursory search, but didn't find anything. Hoping someone can help.
I have multiple projects that I am working on at the moment, and this appears to happen in some projects, but not in others, so thinking I am missing a setting somewhere.

When I am typing new text inside an existing document, by default, single quotes and double-quotation marks are being inserted as 'straight/plain/dumb' quotes. I want them as "smart", or 'curly'.

I know I can use – and I do – the Edit/Transformations/Convert Quotes to Smart Quotes, but is there a way to make this happen automatically?
I clearly have some OCD tendencies, since despite knowing I can just type what I need to, and do one transformation at the end, I just cannot let it stand! :oops:
So I am constantly jumping into the above menu, and doing the conversion, and wasting time doing it.

I have the Edit/Substitutions/Smart Quotes ticked - am I misunderstanding that? Should it be unchecked?
My thinking was having it checked would automatically do the conversion?
Checking and unchecking it, doesn't appear to make a difference at the moment - but maybe I need to close and restart Scrivener?

Any suggestions?

User avatar
KB
Site Admin
Posts: 20713
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Jun 25, 2018 2:35 pm Post

Is there any chance you are in script mode (if so, no word count will appear in the footer bar and instead there will be a menu button for script elements on the right).

You have everything set up correctly, so it should be working. However, we have had spontaneous reports of either smart quotes or spell-checking not working for a couple of years now, but we have as yet been able to reproduce it on any of our machines or find a cause.

One thing to check: are you using page view? If so, if you turn off page view, quit and restart Scrivener, does it work then?

Does this affect one project or all projects?

Thanks and all the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
Cassady
Posts: 196
Joined: Sun Jun 16, 2013 12:06 pm
Platform: Mac + iOS
Location: Sqornshellous

Mon Jun 25, 2018 3:04 pm Post

KB wrote:Is there any chance you are in script mode (if so, no word count will appear in the footer bar and instead there will be a menu button for script elements on the right).

You have everything set up correctly, so it should be working. However, we have had spontaneous reports of either smart quotes or spell-checking not working for a couple of years now, but we have as yet been able to reproduce it on any of our machines or find a cause.

One thing to check: are you using page view? If so, if you turn off page view, quit and restart Scrivener, does it work then?

Does this affect one project or all projects?

Thanks and all the best,
Keith


Thanks Keith.

I am not in Script mode, but am using the Pages view.
Switching if off, quitting Scrivener, and then restarting, sorted the problem.
Switching Page view on again, after the restart, also sees it behaving as expected.

It does happen across various projects, but it probably gets sorted each time I close Scrivener on the Mac, for the purposes of my prolonged use of Scrivener over on iOS – which might explain it only occurring periodically, and in different Projects.

Pity that I cannot be of much assistance in terms of it being reproduced that side - but if a restart fixes it, then its not the end of the world. Thank you for the prompt assistance!

User avatar
KB
Site Admin
Posts: 20713
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Jun 25, 2018 3:38 pm Post

Thanks for the information! Sometimes - but even this doesn't seem to be consistent - there seems to be something about the UI settings in the project that causes a glitch. So turning page view off and back on again either side of a reload might have cleared that glitch.

If you can find a way to reproduce it - a series of steps that always results in the quotes not working - I would be very grateful if you could report back. There must be some very specific sequence somewhere that is triggering the issue.

Thanks and all the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

ti
tiffysquid
Posts: 4
Joined: Tue Jun 26, 2018 3:21 am
Platform: Mac

Tue Jun 26, 2018 3:27 am Post

I seem to be having a weird glitch. I'm using the newest update, Scrivener 3.0.3, on a MacBook Pro running Sierra.

I've opened an old file. In Preferences|Corrections, the "smart quotes" box is unchecked. I've cut-and-pasted some text that uses straight quotes.

Whenever I click into a work inside quotation marks and change it, or add type, Scrivener takes half a second and then converts the nearby quotes into smart quotes. This is the opposite of what I need and is kinda driving me nuts!

User avatar
KB
Site Admin
Posts: 20713
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Jun 26, 2018 12:28 pm Post

Note that the setting in Preferences is "Use smart quotes in *new projects*". The setting can also be turned on or off for individual projects using Edit > Substitutions > Smart Quotes. Make sure the setting is turned off there in your project.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

ps
pseingalt
Posts: 147
Joined: Sun Nov 07, 2010 3:14 am
Platform: Mac

Sat Jun 30, 2018 11:59 am Post

As you're on a Mac, you don't have to use the degree mark (' or ") or a Scrivener process to convert these to curly quotes. You can just type type curly quotes by using the keyboard:

Alt + ] produces an opening single curly quote ( ' )
Alt + Shift + ] produces a closing single curly quote ( ' )
Alt + [ produces an opening double curly quote ( “ )
Alt + Shift + [ produces a closing double curly quote ( ” )

User avatar
Cassady
Posts: 196
Joined: Sun Jun 16, 2013 12:06 pm
Platform: Mac + iOS
Location: Sqornshellous

Mon Jul 02, 2018 10:39 am Post

pseingalt wrote:As you're on a Mac, you don't have to use the degree mark (' or ") or a Scrivener process to convert these to curly quotes. You can just type type curly quotes by using the keyboard:

Alt + ] produces an opening single curly quote ( ' )
Alt + Shift + ] produces a closing single curly quote ( ' )
Alt + [ produces an opening double curly quote ( “ )
Alt + Shift + [ produces a closing double curly quote ( ” )


Much obliged. It is still taking a while to change the muscle-memory, but I do try and use the above as much as possible when typing.

My challenge lands when I am dictating the text, or copying or pasting from work I have written elsewhere.
That said, the fix above works in those instances when the transformation is not automatic.

td
tdellaringa
Posts: 17
Joined: Fri Jun 22, 2018 2:33 pm
Platform: Mac

Thu Jul 18, 2019 4:50 pm Post

I am having the same problem. I pasted text in with quotes, and they will not convert. Restarting doesn't help. Page view or not, doesn't matter. Latest Mac OS.

Any way to do this aside from manually?