Remove indent from first paragraph and after empty lines not working

ma
mamster
Posts: 203
Joined: Fri Jan 26, 2007 6:26 pm

Fri Apr 20, 2018 12:43 am Post

Hello. I'm trying to use the feature "Remove indent from first paragraph and after empty lines" when compiling to DOCX. In my project, I've designated a document as a Section. I've assigned the Titled Section layout to Section documents, and then in a custom format, I've selected Titled Section under Section Layouts. In the Settings tab, I selected:

Remove indent from first paragraph and after empty lines

When I compile, however, it behaves as if I selected "Remove indent from first paragraph." There are definitely a number of empty lines in the document, but the paragraph is indented after each one. Any idea what I'm missing? Thanks!

User avatar
AmberV
Posts: 24307
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Fri Apr 20, 2018 12:25 pm Post

The option appears to be working on my end. However one thing that might be getting in the way here is if you are using a paragraph style on the text that you intend to have transformed by the compiler. Basically a style tells the compiler to keep its hands off of the text, because they are generally meant to be used for special cases where you would not want the compile settings applied. If you apply a style to normal paragraph text then it will ignore that as well.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

ma
mamster
Posts: 203
Joined: Fri Jan 26, 2007 6:26 pm

Fri Apr 20, 2018 6:17 pm Post

Thanks, AmberV. I did "remove all tab stops" in the format definition, and that seemed to fix it.