Scratch Pad and font settings, again

El
Ellida
Posts: 23
Joined: Wed Oct 29, 2008 2:33 am
Platform: Mac
Location: USA

Sat Dec 30, 2017 3:10 pm Post

Dear genius makers of Scrivener:
Why can't you allow the Scratch Pad to zoom? Or, alternatively, give a preference to set the font of the Scratch Pad separately from the font for comments and notes? --On my large screen (and even on the laptop), the Scratch Pad font is tiny. But if I reset it in Preferences, the notes and comments become huge too, Which means I can only see a little bit of them in the Inspector without scrolling. -- . And every time I transfer a scratch pad note to a project, it looks equally huge. So then I have to manually reformat the transfer. A zooming option would take care of all this. --I love the Scratch Pad. It's a brilliant part of Scrivener, But why make it so cumbersome to use? -- I looked at all the old conversations about this. The only answer I could find was that font settings don't matter when you print a project. Yes, but they do matter when you want to write, and think, and do that by looking at the screen! My main point is simple: Moving from editor to notes to scratchpad should be seamless. Right now it isn't. -- Of course, I would love to be proven wrong. Please reply that in my new Scrivener 3 there is a hidden preference to fix this!

User avatar
Silverdragon
Posts: 597
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Sat Dec 30, 2017 5:26 pm Post

Screenshot_2017-12-30_09_20_04.png
Screenshot_2017-12-30_09_20_04.png (109.7 KiB) Viewed 991 times

Personally, I find sarcasm in social media to be counterproductive.
So you know where I'm coming from:
  • I'm a user, not an L&L employee.
  • Mac Scrivener 3.0.2, MacBook Air 11, MacOS 10.12.6 (Sierra)
  • IOS Scrivener 1.1.5, iPhone 6s, iPad Air 2, iOS 11.4

br
brookter
Posts: 1684
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Sat Dec 30, 2017 5:37 pm Post

If you set your scratchpad notes to be RTF rather than plain text, you can have the Ruler (cmd-r) and change the font / font-size / spacing etc. The standard TextEdit styles are available.

The traditional shortcuts for increasing decreasing font size work as well: cmd-a to select all, then cmd-+ or -.

HTH.

Screenshot 2017-12-30 17.35.53.png
Screenshot 2017-12-30 17.35.53.png (156.92 KiB) Viewed 986 times

El
Ellida
Posts: 23
Joined: Wed Oct 29, 2008 2:33 am
Platform: Mac
Location: USA

Sat Dec 30, 2017 5:55 pm Post

Dear Silverdragon, I agree about sarcasm in social media.. But I certainly didn't intend to be sarcastic in any way. I genuinely consider Scrivener a genius app, the best ever made for writers. I have used it faithfully for almost ten years, and wouldn't think of writing in any other way. So I am sorry if you thought I was being sarcastic. I certainly don't consider a small issue with the Scratch Pad to be so important that it detracts from the overall genius of the app! -- That aside, I am not sure what your screen shot is supposed to show? Doesn't it just confirm my issue: the same font has to be used for Scratch Pad and document notes?

-- Dear Brookter, thanks for taking the trouble to post. -- I do have my scratch pad notes set to rtf. I realize I can change the size of the text in individual notes. But I would so like tohave the scratchpad in the same font as my editor, and all notes (footnotes, document notes etc) for easy interchange between them. Without any fiddling at all. When I set the font to a larger size in Scratch Pad, it gets imported into the editor in that large font. Then I have to reformat it there. --A general zoom setting, as in the editor, would avoid that work (But there may be other solutions). The trouble now is that if I do use the same font in the Scratchpad, the print gets so tiny on screen, I can't read the notes, or see what I type.

User avatar
Silverdragon
Posts: 597
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Sat Dec 30, 2017 6:54 pm Post

First, I apologize for misinterpreting your post. Mine was intended to point out that comments font is no longer tied to scratchpad/notes.

It is certainly possible to assign the same font and size to the notes/scratchpad as to the editor. To make this readable in both, I first set the zoom in my editor to 100% and chose a comfortable font size (big!), then set the default editor formatting to this, and used the same font size for notes/scratchpad. I also went to the Editing/options panel in Preferences and set my default text zoom to 100%. With these adjustments, all text in notes, main editor, and scratcpad are the same size.

As for paragraph formatting, what about Documents > Convert > Text to Default Formatting... when you add or append your notes? It's much more flexible now and would be a single step conversion. It doesn't require you to select your recently appended/added text. Alternatively, if you're appending rather than adding a new text, copy plus paste and match style would seem to me to actually be easier than trying to dig through the drop-down cascaded menus to find the right text to append to....

Of course I may be totally off base here, and if so I again apologize.
So you know where I'm coming from:
  • I'm a user, not an L&L employee.
  • Mac Scrivener 3.0.2, MacBook Air 11, MacOS 10.12.6 (Sierra)
  • IOS Scrivener 1.1.5, iPhone 6s, iPad Air 2, iOS 11.4

El
Ellida
Posts: 23
Joined: Wed Oct 29, 2008 2:33 am
Platform: Mac
Location: USA

Sat Dec 30, 2017 7:10 pm Post

Silverdragon, thanks. The idea of setting the editor to 100% zoom is a proimising one. Will try out.

tg
tgustilo
Posts: 2
Joined: Wed Jan 20, 2010 11:14 pm

Mon Jan 08, 2018 3:49 pm Post

Hi, I can't get my scratchpad to update the font settings. I've changed them in preferences as indicated above (and restarted and rebooted, etc). Thanks for help.