TOC Table of Contents Format

mi
mickputley
Posts: 33
Joined: Sat Dec 23, 2017 1:13 am
Platform: Mac

Fri Dec 29, 2017 6:36 am Post

Thanks for Scrivener 3. Like so many it took me a while to adjust, but loving it. How do I format the TOC. Specifically how to configure wether the chapter number is called out or not i.e. "Chapter One - The Start" or just "The Start" and is there a way to switch the formatting to "preserve" formatting like you can with text in a scene. My real problem is that with a typical e-reader using font sizes that 'most' people would pick, my chapter lines in the TOC are spilling into two lines like...

Chapter Five - The Mysterious
Magician.

I realize that extreme font size used by some readers makes this wrapping inevitable, but I want it to look more elegant for 'most readers'
Thanks

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Fri Dec 29, 2017 8:27 am Post

Someone else might have a better solution, but...

1. Apply a CSS class name to the relevant section layout

2. Style your CSS class name from step 1 as you want

3. Use the Document Title Links panel to include or exclude title prefixes (such as the chapter number or anything else the user has defined)

1 TOC CSS Style.jpg
1 TOC CSS Style.jpg (244.65 KiB) Viewed 1505 times


2 Set Style Details.jpg
2 Set Style Details.jpg (317.63 KiB) Viewed 1505 times


3 Include or Exclude Prefixes.jpg
3 Include or Exclude Prefixes.jpg (189.31 KiB) Viewed 1505 times

mi
mickputley
Posts: 33
Joined: Sat Dec 23, 2017 1:13 am
Platform: Mac

Sun Dec 31, 2017 12:43 am Post

Hmmm when I add 'toc' to the CSS class Name in the settings tab of the layout 'table of contents' and then go to the 'Sales section, I do not see toc listed. What am I doing wrong?

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Sun Dec 31, 2017 8:29 am Post

Hi

If you set a class that doesn't exist, you will need to create that style using the plus button on the top right of the styles menu (in compile).

If you open the sample project attached and look at the 'Ebook Copy' settings under project formats, you can see a style called toc which I have styled in a large red font just for the sake of clarity. When compiled, the TOC takes on the styling from this toc style, although with something like an ebook, you are confined by the reader's reading device and the stylings/fonts it can support.

When compiled to ePub, for example, the TOC in the sample project will appear in a large red font, but the default of Palatino can be overridden by the settings on the reader's device.

This is what I have been doing to style contents. Someone else might know of/have a better solution.

Scrivener Test.zip
(100.78 KiB) Downloaded 68 times

mi
mickputley
Posts: 33
Joined: Sat Dec 23, 2017 1:13 am
Platform: Mac

Mon Jan 01, 2018 8:17 pm Post

Thanks!

po
poeticplenties
Posts: 3
Joined: Sun Apr 28, 2013 12:08 pm
Platform: Mac

Sun Dec 23, 2018 2:06 pm Post

Screen Shot 2018-12-23 at 14.04.13.png
Screen Shot 2018-12-23 at 14.04.13.png (66.82 KiB) Viewed 321 times
Screen Shot 2018-12-23 at 14.04.39.png
Screen Shot 2018-12-23 at 14.04.39.png (62.25 KiB) Viewed 321 times
Hello there. I have spent hours trying to find a solution to this and I thought perhaps you folks at this post might be able to help me.
I am compiling my non-fiction format document as Custom.
I am on mac
Using Scrivener Version 2.7
I am baffled as to why my table of contents is indenting all my folders. I only want the documents in those folders to indent but not the main chapters. (See snap shot below) I'd like all the Chapters to appear as the Forward does without having to recode manually (because I am Copying - Pasting Special - ToC - often due to constant re-edits)
Please can someone help me!? Im going in sane now with this. And publisher wants ToC very soon so it needs to look good.
Screen Shot 2018-12-23 at 14.04.13.png
Screen Shot 2018-12-23 at 14.04.13.png (66.82 KiB) Viewed 321 times