Compiling with a specific language

User avatar
Deruji
Posts: 19
Joined: Sat Jul 08, 2017 9:59 pm
Platform: Mac + Linux
Location: Germany
Contact:

Sat Dec 09, 2017 1:57 pm Post

I have run into an interesting conundrum. I have my system setting set to Japanese and Scrivener to English. When trying to compile chapters with the usual tag for chapters <$t> I get the numbers written out in Japanese instead of English .
I am aware it uses the sytem language, although the help file just says "current language setting", which suggests it is set in Scrivener's preferences.
Is there an alternative way to determine which language is used besides having to change my system language?
Dañiel L.G.
For other writings please visit me at: smashwords
Image

Online
User avatar
AmberV
Posts: 23713
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Dec 11, 2017 2:46 pm Post

I’ve clarified the user manual, but in short that’s just how the counter works. Since macOS is providing the numbering, and it provides numbering based on the system localisation settings, you get localised numbering in all cases. The only way around it is to temporarily set the system to English, or whatever you need, when compiling.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
Deruji
Posts: 19
Joined: Sat Jul 08, 2017 9:59 pm
Platform: Mac + Linux
Location: Germany
Contact:

Mon Dec 11, 2017 4:50 pm Post

Thank you for the reply. At least I now know it's a technical limitation in that sense and I haven't missed something vital.
Dañiel L.G.
For other writings please visit me at: smashwords
Image